Steam for Linux > Общи дискусии > Подробности за темата
Jeff 6 февруари 2013 в 2:47след.
Really bad input lag in CS:S
Well first off my game doesnt show anything but a black screen unless I use the launch option of "-sw".

But my main issue is that all input is delayed by like half a second. If I walk around or move my mouse it has a really bad delay. If anyone has an idea of why this is happening and would like to share that'd be great! :)


Edit2: I FIGURED IT OUT... kinda.
Ends up turning vsync off will get rid of the lag. The problem is that my frame rate changes so much when vsync is off that it is super choppy. (its going from like 100 to 200fps)


Edit:
More info:
OS: Linux Mint x64 with cinnamon
Graphics: ATI HD5870 (mobile)
Proc: i7 1.6ghz
Последно редактиран от Jeff; 7 февруари 2013 в 12:46след.
Показване на 1-15 от 17 коментара
< >
Monster Cock Rally 6 февруари 2013 в 9:42след. 
My friend experiences the same issue. We're looking for a resolution.
Vorenon 7 февруари 2013 в 12:29сут. 
Do you have sync to vblank enabled within the graphics card driver? It produces input lag for me.
twitch.tv/otdxo 7 февруари 2013 в 1:03сут. 
ya blow_jobs
Последно редактиран от twitch.tv/otdxo; 7 февруари 2013 в 1:03сут.
Spacepiss Cocksman 7 февруари 2013 в 1:05сут. 
I am the friend mentioned above.

Ubuntu 12.10 x64 & Arch Linux x64 (gnome 3 shell) have this lag where the crosshair doesn't actually move until about a half second after my hand moves. The crosshair continues to move after my hand stops moving.

CS:S runs between 200-300 FPS.

Steps tried:
1. Nvidia 313.09 and 313.80 drivers
2. Vsync disabled in-game and in the Nvidia control panel
3. Steam community disabled in-game
Последно редактиран от Spacepiss Cocksman; 7 февруари 2013 в 8:10след.
peMan {SP} 7 февруари 2013 в 1:53сут. 
I think I'm affected too. I've enabled mouse "Raw Input" option so this only happens with keyboard input. Sometimes, when a keep pushing W for a long time, it seems that the keyboard does not respond. Actually, the keyboard responds with 1 second delay (or even more). Pushing Escape twice seems to fix the delay issue, but it will probably show up in the next few rounds.
gutigen o) 7 февруари 2013 в 2:06сут. 
Cyberz 7 февруари 2013 в 4:57сут. 
I have the same issue, only tried for few min.
Jeff 7 февруари 2013 в 12:46след. 
Updated the main post.
mxup 7 февруари 2013 в 1:24след. 
runs butter smooth here.. since you're on a laptop, did you disable dynamic power management..?
Jeff 7 февруари 2013 в 1:27след. 
If you're talking about the ATI powerplay then it doesn't really matter since it is set to maximum performance when plugged in.
Spacepiss Cocksman 7 февруари 2013 в 8:28след. 
Jeff 8 февруари 2013 в 12:08след. 
muxol 16 февруари 2013 в 10:35след. 
I have the same issue using AMD Catalyst 13.2 or 13.1 drivers. I've tried various things like vsync off and none have permanently worked. The issue does not arise for other games like Serious Sam 3 BFE.
gutigen o) 17 февруари 2013 в 3:53сут. 
Първоначално публикувано от All In One Pancake:
Edit2: I FIGURED IT OUT... kinda.
Ends up turning vsync off will get rid of the lag. The problem is that my frame rate changes so much when vsync is off that it is super choppy. (its going from like 100 to 200fps

Easy to fix, just lock your framerate. Go with something minimal, but remember that fps should always be above 66 because tickrate is synced with framerate (and standard tickrate is 66 in CS:S and shouldn't be changed).

Create a text file called autoexec.cfg in
/home/yourname/.local/share/Steam/SteamApps/yourname/Team Fortress 2/tf/cfg
and put this command there
fps_max 90

Последно редактиран от gutigen o); 17 февруари 2013 в 8:52сут.
VermeV 17 февруари 2013 в 7:32сут. 
I had the same problem; on top of locking fps with fps_max I had to disable multicore rendering in the video settings.
Показване на 1-15 от 17 коментара
< >
На страница: 15 30 50
Дата на публикуване: 6 февруари 2013 в 2:47след.
Публикации: 17