Steam for Linux

Steam for Linux

Steam for Linux > Общи дискусии > Подробности за темата
jeff 6 февруари 2013 в 2:47 следобед
Really bad input lag in CS:S
Well first off my game doesnt show anything but a black screen unless I use the launch option of "-sw".

But my main issue is that all input is delayed by like half a second. If I walk around or move my mouse it has a really bad delay. If anyone has an idea of why this is happening and would like to share that'd be great! :)


Edit2: I FIGURED IT OUT... kinda.
Ends up turning vsync off will get rid of the lag. The problem is that my frame rate changes so much when vsync is off that it is super choppy. (its going from like 100 to 200fps)


Edit:
More info:
OS: Linux Mint x64 with cinnamon
Graphics: ATI HD5870 (mobile)
Proc: i7 1.6ghz
Последно редактиран от jeff; 7 февруари 2013 в 12:46 следобед
< >
Показване на 1-15 от 17 коментара
My friend experiences the same issue. We're looking for a resolution.
Vorenon 7 февруари 2013 в 12:29 сутринта 
Do you have sync to vblank enabled within the graphics card driver? It produces input lag for me.
ya blow_jobs
Последно редактиран от twitch.tv/proxylord; 7 февруари 2013 в 1:03 сутринта
I am the friend mentioned above.

Ubuntu 12.10 x64 & Arch Linux x64 (gnome 3 shell) have this lag where the crosshair doesn't actually move until about a half second after my hand moves. The crosshair continues to move after my hand stops moving.

CS:S runs between 200-300 FPS.

Steps tried:
1. Nvidia 313.09 and 313.80 drivers
2. Vsync disabled in-game and in the Nvidia control panel
3. Steam community disabled in-game
Последно редактиран от SSttSSoW Astro Cock; 7 февруари 2013 в 8:10 следобед
peMan 7 февруари 2013 в 1:53 сутринта 
I think I'm affected too. I've enabled mouse "Raw Input" option so this only happens with keyboard input. Sometimes, when a keep pushing W for a long time, it seems that the keyboard does not respond. Actually, the keyboard responds with 1 second delay (or even more). Pushing Escape twice seems to fix the delay issue, but it will probably show up in the next few rounds.
Cyberz 7 февруари 2013 в 4:57 сутринта 
I have the same issue, only tried for few min.
jeff 7 февруари 2013 в 12:46 следобед 
Updated the main post.
mxup 7 февруари 2013 в 1:24 следобед 
runs butter smooth here.. since you're on a laptop, did you disable dynamic power management..?
jeff 7 февруари 2013 в 1:27 следобед 
If you're talking about the ATI powerplay then it doesn't really matter since it is set to maximum performance when plugged in.
muxol 16 февруари 2013 в 10:35 следобед 
I have the same issue using AMD Catalyst 13.2 or 13.1 drivers. I've tried various things like vsync off and none have permanently worked. The issue does not arise for other games like Serious Sam 3 BFE.
gutigen 17 февруари 2013 в 3:53 сутринта 
Първоначално публикувано от All In One Pancake:
Edit2: I FIGURED IT OUT... kinda.
Ends up turning vsync off will get rid of the lag. The problem is that my frame rate changes so much when vsync is off that it is super choppy. (its going from like 100 to 200fps

Easy to fix, just lock your framerate. Go with something minimal, but remember that fps should always be above 66 because tickrate is synced with framerate (and standard tickrate is 66 in CS:S and shouldn't be changed).

Create a text file called autoexec.cfg in
/home/yourname/.local/share/Steam/SteamApps/yourname/Team Fortress 2/tf/cfg
and put this command there
fps_max 90

Последно редактиран от gutigen; 17 февруари 2013 в 8:52 сутринта
VermeV 17 февруари 2013 в 7:32 сутринта 
I had the same problem; on top of locking fps with fps_max I had to disable multicore rendering in the video settings.
< >
Показване на 1-15 от 17 коментара
На страница: 15 30 50

Steam for Linux > Общи дискусии > Подробности за темата
Дата на публикуване: 6 февруари 2013 в 2:47 следобед
Публикации: 17