abundantmind Feb 5, 2013 @ 3:15am
Ubuntu 12.10 x64 was working...but not anymore. Why?
I completely understand that the beta is intended for 12.04 users, but I was playing Half Life after I purchased it for several days...when it just stopped working. Very frustrating...

Possible Causes...

1. I was fiddling with the Big Picture option and probably checked that as the default view (cuz it's cool!) for when I open the app.

2. Steam updated itself...and broke itself.

3. ???

Now when I click on the Steam Icon it appears in the tray on the left for a few seconds...then it just dies.

Any suggestions would be appreciated, including possible command line instructions to uninstall and re-install from scratch.
Showing 1-9 of 9 comments
< >
TdR Feb 5, 2013 @ 3:29am 
Run steam from terminal and see what is the error.
abundantmind Feb 5, 2013 @ 3:43am 
Here's the tail end of the output...

Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 121 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 122 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 123 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 124 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 125 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 126 :
Failed to compile fragment shader - shader info log for opengl/fancyquaduber.frag 4 127 :
sdlopenglsurface.cpp (1270) : Assertion Failed: m_stackCompositionLayers.Count() == 1
Assert( Assertion Failed: m_stackCompositionLayers.Count() == 1 ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/panorama/./renderer/sdlopenglsurface.cpp:1270

Installing breakpad exception handler for appid(steam)/version(1359765526_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130205204101_1.dmp
success = yes
response: CrashID=bp-c9dbd44e-bbb6-45c6-93ac-b6bd92130205
!! Last miles service delay: 76
Failed creating tenfoot windowsteamstartuphandlers.cpp (516) : Assertion Failed: TenfootController()
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
Shutting down. . .
unlinked 2 orphaned pipes
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 620 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
abundantmind Feb 5, 2013 @ 3:47am 
If I pipe the terminal output into steam.out file, here's the contents...

Running Steam on ubuntu 12.10
STEAM_RUNTIME is enabled automatically on ubuntu
Shutting down. . .
abundantmind Feb 5, 2013 @ 3:50am 
If I Ctrl-C out of the terminal window, I get these results...

Running Steam on ubuntu 12.10
STEAM_RUNTIME is enabled automatically on ubuntu
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
unlinked 0 orphaned pipes
Gtk-Message: Failed to load module "overlay-scrollbar"
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
[0205/204907:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
Installing breakpad exception handler for appid(steam)/version(1359765526_client)
TdR Feb 5, 2013 @ 3:55am 
Try:
STEAM_RUNTIME=0 steam
in terminal and wait for steam to update. After that it should be fixed...
abundantmind Feb 5, 2013 @ 5:39am 
Perfect. Thanks a bunch.
MachinaeWolf Sep 13, 2013 @ 12:14pm 
I'm having a similar issue on debian 64bit but that command doesn't fix it for me

Running Steam on debian 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 3851 with name 0eBlobRegistryMutex_530668F5CDA6A2B6CC0048DB95D0FA93
removing stale semaphore last operated on by process 3851 with name 0eBlobRegistrySignal_530668F5CDA6A2B6CC0048DB95D0FA93
removing stale semaphore last operated on by process 3851 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 3851 with name 0eSteamEngineLock
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
[0913/131010:ERROR:object_proxy.cc(239)] Failed to call method: org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
[0913/131010:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation

also:

$ sudo cat /var/log/syslog|grep systemctl
Sep 13 13:03:04 shadow-lugia dbus-daemon[1077]: dbus[1077]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
Sep 13 13:03:04 shadow-lugia dbus[1077]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.NetworkManager.service': Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.

Edit: hmm may have solved the issue for the moment, unfortunately I think it deleted my games or maybe uninstalling steam and reinstalling did either way here's what fixed it: rm -Rf ~/.steam/steam/appcache as suggested by http://askubuntu.com/questions/345120/why-doesnt-steam-start

PS: or rather it ignored the installed files in ~/.local/share/Steam/SteamApps/ and I'm not sure how to make it see that folder again got it

Or not... close steam open it again doesn't start >_<
MachinaeWolf Sep 13, 2013 @ 12:58pm 
Thanks Doc guess I have to do that all the time to make it work, at least it'll work :)
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Feb 5, 2013 @ 3:15am
Posts: 9