faDol Feb 4, 2013 @ 9:30am
trying to run a dedicated server but having errors with steam and steam didcated server after installing
i'm trying to run a l4d2 didcated server but after installing steam i get the following error if i run steam in terminal

steam
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0_client)
main.cpp (367) : Assertion Failed: failed to intiialize update status ui, or create initial window
Assert( Assertion Failed: failed to intiialize update status ui, or create initial window ):/data/steamlinux/src/steamexe/./main.cpp:367

Installing breakpad exception handler for appid(steam)/version(1.0_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130204181516_1.dmp
success = yes
response: CrashID=bp-ebdae4cd-3472-4f48-98b1-9c5d72130204
Installing bootstrap /root/.local/share/Steam/bootstrap.tar.xz
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(0_client)
main.cpp (367) : Assertion Failed: failed to intiialize update status ui, or create initial window
Assert( Assertion Failed: failed to intiialize update status ui, or create initial window ):/data/steamlinux/src/steamexe/./main.cpp:367

Installing breakpad exception handler for appid(steam)/version(1.0_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130204181517_1.dmp
success = yes
response: CrashID=bp-619bb32e-367b-418a-98a8-8caaa2130204


i also tried installing hldsupdatetool.bin and followed these steps :
wget http://www.steampowered.com/download/hldsupdatetool.bin
chmod +x hldsupdatetool.bin
./hldsupdatetool.bin
./steam -command update -game left4dead2 -dir ~/hlds -verify_all
vi ~/hlds/left4dead2/left4dead2/cfg/server.cfg

however i couldn't create the server.cfg as vi give me an error while saving which i think is because the directory doesn't exist as i can't to find the folder hlds and if i cd to steam i only see Clientregistry.blob
Showing 1-3 of 3 comments
< >
faDol Feb 5, 2013 @ 6:58am 
any one ?
johndrinkwater [🐧︀ 🎮] Feb 5, 2013 @ 9:19am 
It looks like you’ve installed steam into the root account (with sudo), you should avoid doing that and just install the package as a normal user. Unsure what the actual problem is, might be worth filing a bug here https://github.com/ValveSoftware/steam-for-linux/issues
faDol Feb 6, 2013 @ 9:56am 
i did
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Feb 4, 2013 @ 9:30am
Posts: 3