Login (OpenMandriva) Feb 4, 2013 @ 7:22am
[Solved]Fedora 18 (64 bits) no sound in game
After an update of steam or my system all game launched with steam have no sound. Someone have this problem ?
Before that I have played with sound without problem.
Last edited by Login (OpenMandriva); Feb 5, 2013 @ 1:12am
Showing 1-8 of 8 comments
< >
Login (OpenMandriva) Feb 4, 2013 @ 7:27am 
And I have some non-steam games like shank 2 work with sound .
instabilis Feb 4, 2013 @ 9:33am 
Exit Steam, then open Terminal and type
STEAM_RUNTIME=0 steam
Latest Steam comes with the Steam runtime, which is currently enabled by default.
Login (OpenMandriva) Feb 4, 2013 @ 9:49am 
It lauch updater but always no sound in games .
Thank you for the awnser.
Login (OpenMandriva) Feb 5, 2013 @ 12:56am 
When I launch Half-Life in terminal I have this log:
SDL_InitSubSystem(SDL_INIT_AUDIO) failed.
S_Startup: SNDDMA_Init failed.

AL lib: pulseaudio.c:612: Context did not connect: Access denied
ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
AL lib: alsa.c:512: Could not open playback device 'default': No such device or address
AL lib: oss.c:169: Could not open /dev/dsp: No such file or directory
Server module initialized.

World module initialized.

STEAM Auth Server

AppActive: active
AppActive: active
Installing breakpad exception handler for appid(hl_linux)/version(1.0_client)
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Steam_SetMinidumpSteamID: Caching Steam ID: 76561197986848855 [API loaded yes]
Steam_SetMinidumpSteamID: Setting Steam ID: 76561197986848855
Game update: AppID 70 "Half-Life (Beta)", ProcID 8446, IP 0.0.0.0:27015
Unknown command: VModEnable

Dropped Thymus from server
Reason: Server shutting down

ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
AL lib: alsa.c:512: Could not open playback device 'default': No such device or address
AL lib: oss.c:169: Could not open /dev/dsp: No such file or directory
World module shutdown.

Server module shutdown.
Login (OpenMandriva) Feb 5, 2013 @ 1:11am 
I have search on github steam.
I have install this : libXdmcp.i686
And launch steam with your command Instabilis.
It works.

For the other the link who helped me [github.com]

Thank you ;)
thetargos Oct 27, 2013 @ 12:38am 
While this fixes the issue for some games, it does not for others, for instance, PKHD Beta (I know, I know... beta) doesn't load at all when launched from Steam (regardless of how you launch Steam) and if launched without Steam it wont have any sound. The console output is pretty much the same as the above "missing" libasound_module_pcm_module.so library in the "wrong" path (notice it looks for it under /usr/lib/i386-linux-gnu/alsa-lib, instead of $HOME/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/alsa-lib/, it totally cuts off the Steam jail (runtime environment). And when launched with the "linux32" command to force all 32-bit paths are used it simply crashes (alas, Steam itself runs fine with this command 'STEAM_RUNTIME=0 linux32 steam'... and all other games work with sound).

I hope they fix this soon-ish in a future update.
thetargos Nov 8, 2013 @ 7:29pm 
Just to mention that with the latest update to Steam the above method for launching Steam no longer works for me, and using native 64-bit binaries doesn't work either (well, it "loads" and launches games, only without any sound). I wonder if any other non-*buntu [or derivatives] users have experienced this issue as well.
arc| Gps Dec 3, 2013 @ 6:57am 
I had a problem, after installing openSUSE 13.1, no sound in any game from Valve.
There seems to be a problem with two different machine id's which afects atleast suse and Arch.
https://github.com/ValveSoftware/steam-for-linux/issues/1179#issuecomment-13066470
Showing 1-8 of 8 comments
< >
Per page: 15 30 50
Date Posted: Feb 4, 2013 @ 7:22am
Posts: 8