Cheiron Feb 4, 2013 @ 2:54am
FTL: Faster Than Light not starting
On trying to start FTL trough Steam I get no errors, Steam just acts like the game has started and ended (opening the daily deals screen). If I try to open the FTL executable from the terminal I get the following errors:
Loading Arch = amd64
No settings file found!
Initializing Crash Catcher...
Initializing Video
libGL error: failed to load driver: r600
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 3 (X_GLXCreateContext)
Serial number of failed request: 30
Current serial number in output stream: 31
I run Xubuntu 12.10 64-bit with the latest update. I have a AMD 4250 graphics card and I am using the Open Source drivers. Other games such as Legend of Grimrock and Cave Story+ run just fine, alltough not through Steam.
Any ideas or solutions?
Showing 1-3 of 3 comments
< >
instabilis Feb 4, 2013 @ 3:08am 
FTL runs in 64-bit by default on a 64-bit system, I'm guessing your other games are 32-bit? Maybe you're just missing the 64-bit version of a dependency?

Hopefully it doesn't depend on the proprietary drivers...
SlowCyclist Feb 16, 2013 @ 3:48pm 
I run Gentoo rather than Ubuntu, so this may not apply to You. I ran steam with 'LIBGL_DEBUG=verbose' and saw that r600 couldn't load because FTL ships with its own version of libstdc++, corresponding to an older version of GCC than r600 needed. So I replaced the shipped libstdc++ with a symlink to my system's own.
Cheiron Feb 17, 2013 @ 4:33am 
I found a fix looking like this one for ubuntu and you are indeed right. The version of some liberaries that ship with this game are just too old and thus it produces errors like this. Thank you!
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Feb 4, 2013 @ 2:54am
Posts: 3