Tele42 Feb 1, 2013 @ 9:21pm
Birth of a new distribution.
For lack of a better term to express it, Valve has created their own unnamed distro inside our home folders.

I got a preview of the possible conflicts that can occur on Wednesday, January 30th, and now it looks like steam-runtime is here to stay. The Valve Linux Team have a whopping 283MB of dependencies and support files into your steam client, of which, you already had at least 98% of the files. These files are not a matter of having something just in case, they are loaded before the system libraries are considered. I personally am biased against this solution, but it makes sense to provide stability to the game makers and themselves. I hope that Valve is willing to invest the upkeep costs in ensuring this newborn distro is kept secure and safe for the user, since I have heard no official stance on a universal or cooperative solution to distro and package management integration issues. I am probably one of the first users to look into this dependency blob, because when left alone, it breaks sound on big picture mode for me.

So to Valve, good luck to you in this new change in the development of Steam, I hope you have not bitten off more than you can chew.
Last edited by Tele42; Feb 1, 2013 @ 9:39pm
Showing 1-15 of 25 comments
< >
Admiral Spooks Feb 1, 2013 @ 10:09pm 
That's not the definition of a distribution.
slouken Feb 1, 2013 @ 10:10pm 
It's embryonic and experimental. :)
What distribution and release are you running? Can you tell how it breaks sound?

Thanks!
The Doctor Feb 1, 2013 @ 10:34pm 
Yeah, I'm on arch linux and I get no sound in big picture mode, and in CS, BUT if I launch CS from the terminal, sound works, although I have no idea why
TheBombOCat Feb 1, 2013 @ 10:52pm 
I think one day they'll come to their own distro... Steam Box, you know.
Hyper_Eye Feb 2, 2013 @ 12:03am 
I noticed that the update pushed out today was huge. I don't know what I think about this direction yet. I do know that, given the size of the steam-runtime directory, keeping a steam-runtime.old is a pretty big waste of resources. Is there a good reason for not simply deleting the old files?
blackout24 Feb 2, 2013 @ 2:03am 
Originally posted by The Doctor evasi0n.com:
Yeah, I'm on arch linux and I get no sound in big picture mode, and in CS, BUT if I launch CS from the terminal, sound works, although I have no idea why

Are you using a DE other than Gnome? Because in this case you're using ALSA by default and not pulseaudio what most games and the client expect.

export SDL_AUDIODRIVER=alsa

Should fix it.
Rain Ninja Feb 2, 2013 @ 3:45am 
I'm also on Arch (with Pulse though) and also had no sound in Big Picture Mode after the latest updates.

However when I run "STEAM_RUNTIME=0 steam" and therefore run Steam without the bundled runtime the sound is fine in BPM. Until I see something more helpful, I can only assume the ALSA libs in the runtime aren't playing too nice on Arch. There were also messages in console about not being able to connect to Pulseaudio before I disabled the Steam Runtime.
omegadot Feb 2, 2013 @ 3:48am 
I would say it's highly misleading telling someone what sound server they are running based on simply not running gnome. While ALSA is surely a high likelihood, it's not guaranteed.
blackout24 Feb 2, 2013 @ 4:22am 
Just did the Steam Update also can confirm that sound is gone now. Arch Linux x86_64 with Gnome 3.6.2

I enabled the tray icon through installing lib32-libappindicator on one of my Arch machines and it worked fine. With the new update the icon is only a read x one a white piece of paper on both PCs. It works as intended but reacts a bit slow that was also the case with the lib32-libappindicator fix on my laptop tough.

EDIT: In some cases the tray icon reacts very fast (entry gets highlighted instantly on mouse-over) sometimes I takes about a second. Will see if I can find a way to reproduce.

@Rain Ninja
I got that too. When not disableing STEAM_RUNTIME.
PulseAudio connect failed (used only for Mic Volume Control) with error: Access denied
Last edited by blackout24; Feb 2, 2013 @ 5:59am
arc| Gps Feb 2, 2013 @ 4:41am 
My stean says:

Running Steam on opensuse 12.2
STEAM_RUNTIME is enabled automatically on opensuse
[Linux] SweMonkey Feb 2, 2013 @ 6:12am 
Sound works for me, Fedora 17 (x86) with KDE 4.9.5
Tele42 Feb 2, 2013 @ 7:18am 
Originally posted by slouken:
It's embryonic and experimental. :)
What distribution and release are you running? Can you tell how it breaks sound?

Thanks!

I run 64 bit Gentoo linux with JACK and an experimental openal to JACK pipeline, the steam-runtime packaged libopenal.so.1 is incapable of parsing my ~/.alsoftrc config and it also fails to open a stream to an alsa loopback device. This gives me only one remaining path of integration: openal -> pulseaudio -> JACK -> alsa ... or I can force steam to find system install of openal.

Now that I have had a night to sleep on it, perhaps the best course of action is to add a config option to disable steam runtime with a warning that no support will be given, so fringe cases like mine have a way to correct the behavior.
Sarge Feb 2, 2013 @ 9:47am 
Disabling all sound devices in pulseaudio except the one you want to use may be an easy method to get sound to work again without having to do any configuration, since the 'stack' for Linux Steam simply wont have additional devices to choose from.

This worked for me in Wheezy.
Profile: Off for all devices except my USB headset.
Last edited by Sarge; Feb 2, 2013 @ 10:20am
Tele42 Feb 2, 2013 @ 10:01am 
Originally posted by Sarge:
Disabling all sound devices in pulseaudio except the one you want to use may be an easy method to get sound to work again without having to do any configuration, since the new 'stack' for Linux Steam simply wont have additional devices to choose from.

This worked for me in Wheezy.
Profile: Off for all devices except my USB headset.

As helpful as this might be to you, it is not relevent to my setup. On my system, pulseaudio can only see JACK as it has been bolted onto the side and is run only for compatibilty testing. One audio middleware is bad enough for latency, two is excessive. While pulseaudio has no requirements to get the sound to the speakers in a timely manner, JACK is designed to do the job in a hurry.
Sarge Feb 2, 2013 @ 10:34am 
Originally posted by Tele42:
As helpful as this might be to you, it is not relevent to my setup
This was understood. This information was for other people who view this post.
Originally posted by slouken:
It's embryonic and experimental. :)
What distribution and release are you running? Can you tell how it breaks sound?
Thanks!
EDIT: I did not look hard enough.
Last edited by Sarge; Feb 2, 2013 @ 10:47am
Showing 1-15 of 25 comments
< >
Per page: 15 30 50
Date Posted: Feb 1, 2013 @ 9:21pm
Posts: 25