CPC|Assassin8or Feb 1, 2013 @ 2:22pm
Bizarre FPS lock in TF2
Hi guys,

I have tried Ubuntu 12.04 x64 and have now upgraded to 12.10 x64, along with inumerable hours spent trying to graphics drivers to work and SoL and TF2 to work.

What I have found, irrespective of graphics card in my system though is that I can't get over 10 FPS, but generally 9 FPS is what I normally see.

My hardware? I've tried a E1200 at 2.6GHz and now am using my Q6600 at 3GHz. The motherboard is a p35 Neo2 although I have tried the platinum version of this board too. I have 4GB of DDR2 PC6400 RAM running at 800MHz.

For graphics hardware I have tried an 8800GT 256MB from nVIDIA and an HD4350 512MB from AMD/ATI.

Even through all these harware changes there seems to be something really holding back my machine. I'm using the stock -generic kernels from apt-get and I've not done anything other than get the graphics cards working with the system and letting them compile DKMS and in the case of the HD4350 I've had to use a PPA that downgrades X.org on 12.10 so that it will work with the 13.1 legacy drivers.

Does anyone have any tips? I just can't play at 9fps which means that I'm stuck on Windows for now for any kind of gaming where I get > 100fps most of the time.
Showing 1-4 of 4 comments
< >
-FwG- ^ Bucky21659 Feb 1, 2013 @ 3:14pm 
Seems that you didn't install your graphics drivers right.
Try these commands in terminal..
sudo apt-get remove --purge fglrx*
sudo apt-get remove --purge fglrx-*
sudo apt-get install fglrx-experimental-9
sudo apt-get install fglrx-experimental-9

And that's with the AMD GPU, in terms of NVidia drivers I have no clue.
BurritoBazooka Feb 1, 2013 @ 3:46pm 
for nvidia drivers, it worked for me to install nvidia-experimental-310. For me, it was in the precise-updates/restricted repository of Ubuntu (I use Linux Mint 13 64-bit, Cinnamon). You may have to enable that repo in the Sources of whatever package manager you are using.

That's what works for me, anyway. There appears to be a -313 version in the xorg-edgers PPA. But I haven't tried that.

Also, you should try and disable Sync to VBlank (or similar options) in the graphics driver settings (nvidia-settings brings up the settings dialog for me. It is a package in itself).

also hi bucky
CPC|Assassin8or Feb 2, 2013 @ 12:14am 
I doubt that this is a graphics driver issue when I can run the games, with both sets of graphics card manufacturers' drivers and still have the same issue. I installed the GPU drivers for the nVIDIA card using the script from Ubuntu xtreme's website: http://ubuntuxtreme.com/howto/nvidia-drivers-installer-script/
For the ATI card I had to use the PPA from here: https://launchpad.net/~makson96/+archive/fglrx

The reason that I can't use that fglrx-experimental is that my card is too old with it being a 4000 series card, and in addition, 12.10 needs x.org downgrading as the 13.1 legacy drivers don't support it.

I thought that someone might mention Sync to VBlank, but everytime that I installed the nVIDIA drivers that option was disabled already.
BurritoBazooka Feb 2, 2013 @ 9:25am 
I dunno.. if you fail to get anything useful from here in the next few days, it might be worth submitting a bug report on GitHub, relating to maybe your CPU or your nvidia card. You might get help from Valve there.
It's also worth noting, you might want to check the git development for that script - the last update was 5 months ago. The Steam Beta developed a lot over the past 5 months. I wouldn't be surprised if a new script is needed.
Showing 1-4 of 4 comments
< >
Per page: 15 30 50
Date Posted: Feb 1, 2013 @ 2:22pm
Posts: 4