Steam for Linux > Discusiones generales > Detalles del tema
amurgaming 29 de Ene, 2013 a las 22:14
HL1 & CS1.6 mouse input issues (ingame) running Ubuntu via vmware Fusion
Is anyone else having mouse x/y axis issues running their Ubuntu using vmware ? (Fusion 5.02 in my case)

I haven't tried any other games but HL1 and CS1.6 yet. Both are unplayable because the mouse driver signal seems to get screwed which causes any mouse input to be super sensitive and anything else but looking at the ground is impossible.

Switching the fusion mouse profile from default, to mac to windows doesn't change a thing. I know my problems are most likely vm related, but I wanted to ask here if anyone else has similar problems, instead of making a post at Valve's github pages.
Mostrando 1-7 de 7 comentarios
< >
-FwG- ^ Bucky21659 29 de Ene, 2013 a las 23:10 
Why would you want to run your games in a VM?
Floop the Pig 30 de Ene, 2013 a las 1:05 
yea... don't run games in a VM..
-FwG- ^ Bucky21659 30 de Ene, 2013 a las 9:23 
All I can say is VM's handle the mouse differently than the actual host OS, does.. and I'm pretty sure that's where your problem's coming from.
amurgaming 30 de Ene, 2013 a las 21:35 
Publicado originalmente por Bucky21659: Linux Gamer:
All I can say is VM's handle the mouse differently than the actual host OS, does.. and I'm pretty sure that's where your problem's coming from.

True, I just never had any problems with my windows vm whatsoever - no problems running HL1 Source at all.

Publicado originalmente por Bucky21659: Linux Gamer:
Why would you want to run your games in a VM?

I use vms to run older windows games on my mac. Works great in general and I enjoy the convenience of a virtual OS without having to reboot.
-FwG- ^ Bucky21659 31 de Ene, 2013 a las 10:47 
Well HL1 and CS1.6 are also being ported to Mac natively (I checked in my OS X Steam install, and tested there too, works like a charm).
So just get your native Steam install up and download it through there.
Last note: It's not good to run games in a VM because VM's typically don't have really good hardware acceleration, so if, for example, your graphics card can run a game at 200FPS, well the VM will probably get somewhere between 20-60.
PB 15 de Feb, 2013 a las 0:41 
I had the same problem, and I figured out how to fix it.

I'm using VMWare Workstation 9, and within VMWare Workstation I went to Edit->Preferences->Input, and for the dropdown menu labeled "Optimize mouse for games:", I changed the default setting "Automatic" to "Always". After doing this CS 1.6 started using my mouse correctly and not spazzing out looking straight down.

I also realized I needed to force hide the VMWare toolbar when fullscreen, otherwise if the mouse got to the top of the screen while playing, the toolbar would pop down which I didn't want to happen. To stop this, I just went to View->Exclusive Mode, within VMWare.

Hope this helps!
amurgaming 19 de Feb, 2013 a las 10:33 
Publicado originalmente por PB:
I had the same problem, and I figured out how to fix it.

I'm using VMWare Workstation 9, and within VMWare Workstation I went to Edit->Preferences->Input, and for the dropdown menu labeled "Optimize mouse for games:", I changed the default setting "Automatic" to "Always". After doing this CS 1.6 started using my mouse correctly and not spazzing out looking straight down.

I also realized I needed to force hide the VMWare toolbar when fullscreen, otherwise if the mouse got to the top of the screen while playing, the toolbar would pop down which I didn't want to happen. To stop this, I just went to View->Exclusive Mode, within VMWare.

Hope this helps!

I haven't had the chance to try it out yet but this is very likely the solution. Thanks a lot mate!
Mostrando 1-7 de 7 comentarios
< >
Por página: 15 30 50
Publicado el: 29 de Ene, 2013 a las 22:14
Mensajes: 7