Steam for Linux > 一般討論 > 主題細節
[APG]RoboCop[CL] ☮ 外人 2013 年 01 月 29 日 @ 下午 3 時 41 分
Steam not booting up
Hello I've been trying to log Steam and ive updated it to its latest. I felt like almost giving up since I tried to fix and download the lib32.so and data files to keep it working. But when I clicked on Start Steam Beta nothing happened. My Linux is Ubuntu 12.04 64Bit.
顯示 1-15,共 38 則回應
< >
Cheogh 2013 年 01 月 29 日 @ 下午 5 時 56 分 
type steam in a terminal and see if that gives any information.
CDTI 2013 年 01 月 30 日 @ 上午 10 時 44 分 
In which language do you have Ubuntu? I know it sounds silly, but I had Ubuntu in Catalan language and steam didn't boot up, but I just changed it to English and it just did it.

EDIT: Just to check it again, I returned back Ubuntu to Catalan, tried to open steam and nothing happened, it didn't boot up. Maybe it's because I had Ubuntu in English when I installed Steam...
最後修改者:CDTI; 2013 年 01 月 30 日 @ 上午 10 時 51 分
8 Dimensional Octagon 2013 年 01 月 30 日 @ 下午 4 時 06 分 
you said you tried the fix with lib32.so, but was that fix `apt-get install ia32-libs` ? I can't imagine anything else that is not a huge pain or would just break it.
ツ MrTheSoulz™ 2013 年 01 月 30 日 @ 下午 5 時 55 分 
happens to me too, i was playing TF2 just fine i closed it and decided to restart my pc. when it rebooted steam updated and now wont open...
heres the log from the terminal:

XXX@MrTheSoulz-PC:~$ steam
/home/XXX/.local/share/Steam/steam.sh: linha 376: 3474 Falha de segmentação (imagem do núcleo gravada) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/XXX/.local/share/Steam/bootstrap.tar.xz
/home/XXX/.local/share/Steam/steam.sh: linha 169: 3478 Falha de segmentação (imagem do núcleo gravada) tar xf "$STEAMBOOTSTRAPARCHIVE"
XXX@MrTheSoulz-PC:~$
CDTI 2013 年 01 月 31 日 @ 上午 3 時 41 分 
MrTheSoulz 發表:
[...]
/home/XXX/.local/share/Steam/steam.sh: linha 169: 3478 Falha de segmentação (imagem do núcleo gravada) tar xf "$STEAMBOOTSTRAPARCHIVE"
XXX@MrTheSoulz-PC:~$

Change the language of your system to English, reboot (or log out - log in) and try to open Steam again. As I explained before, I had your same exact error and when I changed Ubuntu's language from Catalan (in my case) to English, everything went alright again.
[LINUX]FinCoder 2013 年 01 月 31 日 @ 上午 5 時 20 分 
"STEAM_RUNTIME=0 steam", but that on console, withouth quates.
trigger_ftu 2013 年 01 月 31 日 @ 上午 7 時 36 分 
i've tried this and i get an error.
".local/share/Steam/steam.sh: line 403: 5810 Segmentation fault $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@""

it seems to be an issue with steam itself.

and it's od seeings after 2-3 times of doing this it works but only in the store page. when it looks to the library it crashes.
最後修改者:trigger_ftu; 2013 年 01 月 31 日 @ 上午 7 時 37 分
FunnyLookinHat 2013 年 01 月 31 日 @ 上午 9 時 17 分 
I'm getting the same error - it appears to be related to it trying to update a package.
STEAM_RUNTIME is enabled automatically on ubuntu
/home/funnylookinhat/.local/share/Steam/steam.sh: line 403: 6915 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

However, if I do the following, Steam will start correctly:
STEAM_RUNTIME=0 steam

Then, after I close Steam, it will try to update Steam and crash with the same error.

Wondering if I have a bad update package? I'm on Ubuntu 13.04 ( development ).
carterclan 2013 年 01 月 31 日 @ 上午 11 時 01 分 
I am getting same fault also on 13.04 (development)
ツ MrTheSoulz™ 2013 年 01 月 31 日 @ 上午 11 時 04 分 
same thing for me im on 13.04 and i can only run it with STEAM_RUNTIME=0 steam
[APG]RoboCop[CL] ☮ 外人 2013 年 01 月 31 日 @ 下午 12 時 47 分 
That's no good, it was working in 2012 but nothing works now.
ツ MrTheSoulz™ 2013 年 02 月 1 日 @ 下午 1 時 33 分 
any news? i can only open steam if i run "STEAM_RUNTIME=0 steam" on a terminal :/
PRAEst76 2013 年 02 月 1 日 @ 下午 2 時 04 分 
I've had the same issue since the last update. also running 13.04.

STEAM_RUNTIME is enabled automatically on ubuntu
/home/praest76/Steam/steam.sh: line 403: 23685 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
Installing bootstrap /home/praest76/Steam/bootstrap.tar.xz
Installing breakpad exception handler for appid(steam)/version(1359600063_client)
Installing breakpad exception handler for appid(steam)/version(1359600063_client)
Installing breakpad exception handler for appid(steam)/version(1359600063_client)
Installing breakpad exception handler for appid(steam)/version(1359600063_client)
STEAM_RUNTIME is enabled automatically on ubuntu
/home/praest76/Steam/steam.sh: line 403: 23800 Segmentation fault (core dumped) $STEAM_DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"

Is anyone getting this issue and *not* running 13.04?
powerarmour 2013 年 02 月 1 日 @ 下午 3 時 56 分 
Same here in 13.04, can only start by 'STEAM_RUNTIME=0 steam'
scott_test123 2013 年 02 月 1 日 @ 下午 5 時 20 分 
A new client has just been released that will work on 13.04 without having to type STEAM_RUNTIME=0
顯示 1-15,共 38 則回應
< >
每頁: 15 30 50
張貼日期: 2013 年 01 月 29 日 @ 下午 3 時 41 分
回覆: 38