tbw Jan 29, 2013 @ 1:43am
Can't install steam under Debian
Can't install steam under Debian
uname -a
Linux comp 3.2.0-4-686-pae #1 SMP Debian 3.2.35-2 i686 GNU/Linux

root@comp:/home/andrew# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 7.0 (wheezy)
Release: 7.0
Codename: wheezy

root@comp:/home/andrew/Загрузки# dpkg -i steam_latest.deb
Выбор ранее не выбранного пакета steam.
(Чтение базы данных … на данный момент установлено 165286 файлов и каталогов.)
Распаковывается пакет steam (из файла steam_latest.deb) …
dpkg: зависимости пакетов не позволяют настроить пакет steam:
steam зависит от multiarch-support (>= 2.15-0ubuntu10.2), однако:
Версия multiarch-support в системе 2.13-37.
steam зависит от libc6 (>= 2.15), однако:
Версия libc6:i386 в системе 2.13-37.
steam зависит от libpulse0 (>= 1:0.99.1), однако:
Версия libpulse0:i386 в системе 2.0-6.

dpkg: ошибка при обработке параметра steam (--install):
проблемы зависимостей — оставляем не настроенным
Обрабатываются триггеры для man-db …
Обрабатываются триггеры для hicolor-icon-theme …
Обрабатываются триггеры для desktop-file-utils …
Обрабатываются триггеры для gnome-menus …
При обработке следующих пакетов произошли ошибки:
steam

root@comp:/home/andrew/Загрузки# steam
Setting up Steam content in /root/.local/share/Steam
/root/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /root/.local/share/Steam/ubuntu12_32/steam)
Installing bootstrap /root/.local/share/Steam/bootstrap.tar.xz
/root/.local/share/Steam/ubuntu12_32/steam: /lib/i386-linux-gnu/i686/cmov/libc.so.6: version `GLIBC_2.15' not found (required by /root/.local/share/Steam/ubuntu12_32/steam)
Showing 1-3 of 3 comments
< >
storzi Jan 29, 2013 @ 2:00am 
you need newer glibc packages, debian only offers version 2.13 (even in sid).
2.17 is available in experimental though.
-> try glibc packages from experimental
tbw Jan 29, 2013 @ 2:02am 
it is danger
AlamA Jan 29, 2013 @ 10:42am 
http://steamcommunity.com/app/221410/discussions/0/882965118613928324/?tscn=1359270752

Kano script (with repackaging of steam.deb)
wget http://kanotix.com/files/fix/install-steam-wheezy.sh
sudo ./install-steam-wheezy.sh
./install-steam-wheezy.sh

Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 29, 2013 @ 1:43am
Posts: 3