Saphira Jan 28, 2013 @ 7:03am
Half Life won't start (Library problem?)
I tried to start Half Life for Linux on my Ubuntu 12.10 x64 and get these errors on the console:

/home/wolf/.steam/sdk32/steamclient.so
with error:
/home/wolf/.steam/sdk32/steamclient.so: cannot open shared object file: No such file or directory
[S_API FAIL] SteamAPI_Init() failed; Sys_LoadModule failed to load: /home/wolf/.steam/sdk32/steamclient.so
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Failed to initalize authentication interface. Exiting...

/home/wolf/Steam/SteamApps/common/Half-Life/hl.sh: line 38: 21576 Segmentation fault ${DEBUGGER} "${GAMEROOT}"/${GAMEEXE} $@
Game removed: AppID 70 "Half-Life (Beta)", ProcID 21508

I think this is something related to the library "steamclient.so" which somehow fails to get the Steam PID or games PID.
Showing 1-3 of 3 comments
< >
-FwG- ^ Bucky Jan 28, 2013 @ 8:22am 
I'm trying to reinstall now, I'll report back my results.
-FwG- ^ Bucky Jan 28, 2013 @ 9:26am 
Reinstalling didn't work, but I just restarted Steam and voila it worked like a charm.
janek Feb 16, 2013 @ 6:19pm 
to resolve problem with:
"Failed to initalize authentication interface. Exiting..."

please turnoff your firewall using:
# service iptables stop

or just edit your iptables rules.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 28, 2013 @ 7:03am
Posts: 3