Steam for Linux

Steam for Linux

Janskis Jan 28, 2013 @ 12:51am
[SOLVED]One more Fatal error: failed to load steamui.so
everything worked fine, until i installed nvidia drivers. then this happened:

starting steam from a shortcut/panel: Fatal error: failed to load steamui.so.

steam in terminal results in this (and the beforementioned error)

Installing breakpad exception handler for appid(steam)/version(1359221069_client)
Installing breakpad exception handler for appid(steam)/version(1359221069_client)

I have installed ia32-libs and also put "sudo sh -c 'echo "/usr/lib32\n/usr/lib/i386-linux-gnu/mesa\n" >> /etc/ld.so.conf.d/steam.conf' && sudo ldconfig" in terminal.

any ideas on getting this to work?

edit: running mint 14 nadia 64bit
Last edited by Janskis; Jan 28, 2013 @ 9:51am
< >
Showing 1-7 of 7 comments
gutigen o) Jan 28, 2013 @ 2:10am 
Drivers from nvidia website or repositories? You may want to look at this: https://github.com/ValveSoftware/steam-for-linux/issues/321
[Linux] Junior s2 Camila Jan 28, 2013 @ 2:13am 
The only system I got success on doing manual install of drivers was openSUSE. On Ubuntu and derivatives Steam is broken, there's this error which is fixable. Problem is, after fixing this error there's another one, saying the openGL doesn't support my VGA.

So I recomend you to install via Software Manager on Mint, search "nvidia" and scroll down, there's a "310 Experimental Beta", use that.

NOTE: Install the 310 after removing the old installation. Command that I use, that works FOR ME
sudo apt-get remove --purge nvidia-*
Janskis Jan 28, 2013 @ 4:49am 
Originally posted by Linux Junior s2 Camila:
The only system I got success on doing manual install of drivers was openSUSE. On Ubuntu and derivatives Steam is broken, there's this error which is fixable. Problem is, after fixing this error there's another one, saying the openGL doesn't support my VGA.

So I recomend you to install via Software Manager on Mint, search "nvidia" and scroll down, there's a "310 Experimental Beta", use that.

NOTE: Install the 310 after removing the old installation. Command that I use, that works FOR ME
sudo apt-get remove --purge nvidia-*

Thank you!

I uninstalled old drivers with the command provided and installed 310exp from the package manager. Now steam starts and HL runs real smooth :)
[Linux] Junior s2 Camila Jan 28, 2013 @ 5:18am 
Glad that helped =)
[Linux] Junior s2 Camila Jan 28, 2013 @ 5:21am 
BTW Could you edit the Topic title to -> [Solved]?
Janskis Jan 28, 2013 @ 9:52am 
Originally posted by Linux Junior s2 Camila:
BTW Could you edit the Topic title to -> [Solved]?
yeah, did that :) first time having to ask myself, usually find the answer from the old posts, so not used to editing the "solved" mark :P
[Linux] Junior s2 Camila Jan 28, 2013 @ 4:41pm 
NP =)
< >
Showing 1-7 of 7 comments
Per page: 15 30 50

Date Posted: Jan 28, 2013 @ 12:51am
Posts: 7