doaN 27. Jan. 2013 um 23:00 Uhr
[Counter-Strike 1.6 BETA] 4:3 aspect ratio resolution in fullscreen mode
I've been playing Counter-Strike 1.6 since around 2002.
When I heard that the port was complete I was excited like a child before Christmas.

But I'm used to play with a low resolution (800x600), even if my computer can run the game at a high resolution. So I tried to launch the game with the usual launch options "-w 800 -h 600" but it doesn't work. I can only run the game in fullscreen with my native screen resolution which is 1680x1050. When I try to change the video options, nothing happened.

I'm running with the nVidia proprietary driver (304.51), so I looked into the nVidia panel but there isn't any option about de ration scaling, etc...

So I'm asking any help for running the game in 4:3 resolution in a fullscreen mode on a WIDESCREEN monitor.
Zuletzt bearbeitet von doaN; 27. Jan. 2013 um 23:01 Uhr
Beiträge 1-15 von 16
< >
bl33ding_silence 27. Jan. 2013 um 23:08 Uhr 
There is just a shot in the dark, but have you tried tinkering with the configuration file?

The file for Half Life is hl.conf in ~/Steam/SteamApps/common/Half-Life , which has options to set screen resolution. I'm sure Counter strike has a similar file.
doaN 28. Jan. 2013 um 6:34 Uhr 
I didn't find any "cs.conf"

And I already tried with the launch options.
ThOR27 28. Jan. 2013 um 6:54 Uhr 
At least here, inside the game, where you change resolution, you also have another option to change aspect ratio (I don't recall the name now) but it's there
doaN 28. Jan. 2013 um 8:03 Uhr 
Yeah I know but it doesn't make anything

The only way that I have to change my resolution is to change from fullscreen to windowed.

But I don't want to play with a window. I want to play with fullscreen with aspect ratio 4:3 with the resolution 800x600.
Zuletzt bearbeitet von doaN; 28. Jan. 2013 um 8:04 Uhr
doaN 29. Jan. 2013 um 8:47 Uhr 
Okay I found a solution to use any resolution in full screen mode on a DVI monitor.
The solution is here: http://ubuntuforums.org/showthread.php?t=2072181

But I'm still stuck with the aspect ratio. Even if my video option "Display Mode" is Normal the ratio isn't respected. I got a stretched image.

http://i.imgur.com/Xxwo45q.png
Zuletzt bearbeitet von doaN; 29. Jan. 2013 um 9:07 Uhr
ThOR27 29. Jan. 2013 um 11:15 Uhr 
Do you want the game to show black at borders and perfect 4:3 screen in the middle? I'm pretty sure that in nvidia settings you can change that behavior on your monitor settings.
JukkaN 29. Jan. 2013 um 13:39 Uhr 
Put

Option "FlatPanelProperties" "Scaling = Native"

In your xorg.conf under the 'Device' or 'Screen' section.

Reboot.

Set your desktop res the same what you have ingame.

Worked for me.

You should also disable composition if you have it on.
Zuletzt bearbeitet von JukkaN; 29. Jan. 2013 um 13:40 Uhr
doaN 30. Jan. 2013 um 10:57 Uhr 
Yeah but it's really boring the change the desktop resolution each time I launch the game.
This problem really annonying me. I didn't find a solution yet...
FractaL 30. Jan. 2013 um 20:45 Uhr 
I had the same exact issue in the new windows beta on my ATI/AMD/Radeon (ugh, names) card. Solution was to set my monitor resolution before entering the game.
Zuletzt bearbeitet von FractaL; 30. Jan. 2013 um 20:46 Uhr
John 20. Feb. 2013 um 21:24 Uhr 
Ursprünglich geschrieben von doaN:
I've been playing Counter-Strike 1.6 since around 2002.
When I heard that the port was complete I was excited like a child before Christmas.

But I'm used to play with a low resolution (800x600), even if my computer can run the game at a high resolution. So I tried to launch the game with the usual launch options "-w 800 -h 600" but it doesn't work. I can only run the game in fullscreen with my native screen resolution which is 1680x1050. When I try to change the video options, nothing happened.

I'm running with the nVidia proprietary driver (304.51), so I looked into the nVidia panel but there isn't any option about de ration scaling, etc...

So I'm asking any help for running the game in 4:3 resolution in a fullscreen mode on a WIDESCREEN monitor.

Hello! open CS 1.6, Settings, Video, Put a tick on parameter "Low video quallity. Help with slower video cards." and then the size of the screen will change on 4:3. Good luck ;)
NA`VI TV xjie6ywek 21. Feb. 2013 um 1:09 Uhr 
Ursprünglich geschrieben von Romd:
Ursprünglich geschrieben von doaN:
I've been playing Counter-Strike 1.6 since around 2002.
When I heard that the port was complete I was excited like a child before Christmas.

But I'm used to play with a low resolution (800x600), even if my computer can run the game at a high resolution. So I tried to launch the game with the usual launch options "-w 800 -h 600" but it doesn't work. I can only run the game in fullscreen with my native screen resolution which is 1680x1050. When I try to change the video options, nothing happened.

I'm running with the nVidia proprietary driver (304.51), so I looked into the nVidia panel but there isn't any option about de ration scaling, etc...

So I'm asking any help for running the game in 4:3 resolution in a fullscreen mode on a WIDESCREEN monitor.

Hello! open CS 1.6, Settings, Video, Put a tick on parameter "Low video quallity. Help with slower video cards." and then the size of the screen will change on 4:3. Good luck ;)

Not work!( (and -nofbo in options not work!)
doaN 21. Feb. 2013 um 16:02 Uhr 
I still didn't find a solution...
John 10. März 2013 um 8:30 Uhr 
-nofbo yes. it's work.
VermeV 10. März 2013 um 11:50 Uhr 
A simple solution for your problem is start either Steam or Counter-strike on a separate xserver in which you set your own resolution and aspect ratio; I don't have Ubuntu but seems like there is plenty enough info on its forum: http://ubuntuforums.org/showthread.php?t=2101504http://ubuntuforums.org/showthread.php?t=2101504
Zuletzt bearbeitet von VermeV; 10. März 2013 um 11:51 Uhr
Wilioncas 6. Apr. 2013 um 7:56 Uhr 
Thank you R2G | Romd
-nofbo fixed the problem
I have been searching, reinstalling drivers... Thanks a lot
Beiträge 1-15 von 16
< >
Pro Seite: 15 30 50
Geschrieben am: 27. Jan. 2013 um 23:00 Uhr
Beiträge: 16