WebNuLL Jan 27, 2013 @ 1:25am
[Solution] Got no in-game sound? See here.
If you dont have sound because of any problems with pulseaudio you should try to run STEAM setting SDL enivronment variable.

SDL_AUDIODRIVER=alsa steam

This should force SDL library to use alsa driver.

If this isnt working, you can also try with pulseaudio:

SDL_AUDIODRIVER=pulseaudio steam

And finally if you have issues with pulseaudio blocking alsa sound you should disable pulseaudio integration in alsa:

sudo su # or just su (depends on OS you are using)
echo "" > /usr/share/alsa/alsa.conf.d/50-pulseaudio.conf
echo "" > /usr/share/alsa/alsa.conf.d/51-pulseaudio-probe.conf
Showing 1-2 of 2 comments
< >
bobebubab Jan 27, 2013 @ 11:23am 
+1
Anaconda256 Jan 27, 2013 @ 3:22pm 
Thanks, had mistakenly set SDL_AUDIODRIVER to just pulse instead of pulseaudio. HL sound works fine now! Odd that the music worked without it though.
Showing 1-2 of 2 comments
< >
Per page: 15 30 50
Date Posted: Jan 27, 2013 @ 1:25am
Posts: 2