Steam for Linux > Общие обсуждения > Подробности темы
Do Mi Re Do Re Tiiii Doooo 25 янв, 2013 @ 22:49
Mint Debian installation help requested
So I recently moved from Ubuntu 11.04 to LMDE, largely to get Steam. I'm attempting to use the wonderful guide here[aspensmonster.com], and am at the point of trying to resolve dependencies.

sudo dpkg -i steam_latest.deb
[sudo] password for bill:
(Reading database ... 208471 files and directories currently installed.)
Preparing to replace steam 1.0.0.22 (using steam_latest.deb) ...
Unpacking replacement steam ...
dpkg: dependency problems prevent configuration of steam:
steam depends on multiarch-support (>= 2.15-0ubuntu10.2); however:
Version of multiarch-support on system is 2.13-37.
steam depends on xterm | gnome-terminal; however:
steam depends on libc6 (>= 2.15); however:
Version of libc6:i386 on system is 2.13-37.
steam depends on libcairo2 (>= 1.6.0); however:
steam depends on libcups2 (>= 1.4.0); however:
steam depends on libfontconfig1 (>= 2.8.0); however:
steam depends on libfreetype6 (>= 2.3.9); however:
steam depends on libgdk-pixbuf2.0-0 (>= 2.22.0); however:
steam depends on libglib2.0-0 (>= 2.14.0); however:
steam depends on libgtk2.0-0 (>= 2.24.0); however:
steam depends on libnspr4 (>= 1.8.0.10); however:
steam depends on libnss3 (>= 3.12.3); however:
steam depends on libopenal1 (>= 1:1.13); however:
steam depends on libpango1.0-0 (>= 1.22.0); however:
steam depends on libpulse0 (>= 1:0.99.1); however:
Version of libpulse0:i386 on system is 2.0-6.
steam depends on libxinerama1; howeve
dpkg: error processing steam (--install):
dependency problems - leaving unconfigured

My main problem is that I don't know how to resolve the various possible errors in the guide -- how do I ignore a false positive, and how do I install a package that is simply not recognized, which appears to be mostly the problem? Additionally, I'm using MATE, not Gnome, so that's why gnome-terminal (and some other Gnome packages) is missing. Is there any way to work around that?
Показано 14 из 4 комментариев
< >
Ilrita 25 янв, 2013 @ 22:55 
If you freshly installed Mint, then you should not have had these dependency issues at all. I installed perfectly fine. Have you go into the Software Center and made sure you checked "Canonical" (I think that's the name of it), give your password and then run an update?

Other than that, you will probably have to install each dependency it lists single handedly.
Do Mi Re Do Re Tiiii Doooo 25 янв, 2013 @ 23:30 
Mint != Mint Debian. Mint Debian does not contain any code from Ubuntu, which is developed by Canonical.
jb 26 янв, 2013 @ 6:20 
Do Mi Re Do Re Tiiii Doooo 13 фев, 2013 @ 14:56 
Thanks! After having just rebooted for the first time since your post, that script worked for me, and in fact this post is from inside Steam!!! WOOOOOOOOOOOOOOOOOOO
Показано 14 из 4 комментариев
< >
На страницу: 15 30 50
Дата создания: 25 янв, 2013 @ 22:49
Сообщений: 4