Steam for Linux

Steam for Linux

WMP Jan 25, 2013 @ 10:31am
Half-Life bug
wmp@wmp-Aspire-4820TG:~/.steam/steam/SteamApps/common/Half-Life$ LD_LIBRARY_PATH=. ./hl_linux Using breakpad crash handler Setting breakpad minidump AppID = 70 Forcing breakpad minidump interfaces to load Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Looking up breakpad interfaces from steamclient Calling BreakpadMiniDumpSystemInit Steam_SetMinidumpSteamID: Caching Steam ID: 76561198021953274 [API loaded yes] Steam_SetMinidumpSteamID: Setting Steam ID: 76561198021953274 scandir failed:/home/wmp/.local/share/Steam/SteamApps/common/Half-Life/./platform/SAVE ARB Multitexture extensions found. 8 texture units. Detail texture supported. [0125/191609:ERROR:resource_bundle.cc(411)] Failed to load /home/wmp/.local/share/Steam/SteamApps/common/Half-Life/cef_gtk.pak Some features may not be available. [0125/191609:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation ILocalize::AddFile() failed to load file "resource/hl_l_english.txt". Platform config directory: platform/config 0:Initializing platform... warning: Unknown nb_ctl request: 4 warning: Unknown nb_ctl request: 4 warning: Unknown nb_ctl request: 4 warning: Unknown nb_ctl request: 4 warning: Unknown nb_ctl request: 4 warning: Unknown nb_ctl request: 4 Server module initialized. World module initialized. STEAM Auth Server AppActive: active "SDL_WINDOWEVENT_SHOWN in 2\n" "SDL_WINDOWEVENT_EXPOSED in 2\n" "SDL_WINDOWEVENT_EXPOSED in 2\n" "SDL_WINDOWEVENT_EXPOSED in 2\n" "SDL_WINDOWEVENT type 6 (unknown) in 2\n" "SDL_WINDOWEVENT_RESIZED in 2\n" "SDL_WINDOWEVENT_EXPOSED in 2\n" "SDL_WINDOWEVENT_MOVED in 2\n" AppActive: active "SDL_WINDOWEVENT_FOCUS_GAINED in 2\n" 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 1 0 LoadLibrary failed on ./hl_l/dlls/hl.so: ./hl_l/dlls/hl.so: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu Host_Error: Couldn't get DLL API from ./hl_l/dlls/hl.so! 1 0 1 0 1 0 1 0 1 0 1 0 scandir failed:/home/wmp/.local/share/Steam/SteamApps/common/Half-Life/SAVE Naruszenie ochrony pamięci (core dumped) wmp@wmp-Aspire-4820TG:~/.steam/steam/SteamApps/common/Half-Life$
Kubuntu 12.10 on integrated Intel card
Last edited by WMP; Jan 25, 2013 @ 10:32am
< >
Showing 1-5 of 5 comments
chucc Jan 25, 2013 @ 10:47am 
I got the same segmentation fault.

The game starts. I click "new game". Choose a difficulty, then click "play".
Nothing happens. The difficulty popup just disappeared, and I'm back at the start screen.
So I click "new game" one more time, choose a difficulty, and click "play". Then segmentation fault.

Same thing happens every time.

Processor Information: Vendor: GenuineIntel Speed: 3068 Mhz 8 logical processors 4 physical processors HyperThreading: Supported FCMOV: Supported SSE2: Supported SSE3: Supported SSSE3: Supported SSE4a: Unsupported SSE41: Supported SSE42: Supported Network Information: Network Speed: Operating System Version: "openSUSE 12.2 (x86_64)" (64 bit) Kernel Name: Linux Kernel Version: 3.4.11-2.16-desktop X Server vendor: The X.Org Foundation X Server release: 11203000 Video Card: Driver: ATI Technologies Inc. ATI Radeon HD 5670 Driver Version: 4.2.12002 Compatibility Profile Context 9.002 Desktop Color Depth: 24 bits per pixel Monitor Refresh Rate: 59 Hz VendorID Not Detected DeviceID Not Detected Number of Monitors: 1 Number of Video Cards Not Detected Primary Display Resolution: 1920 x 1200 Desktop Resolution: 1920 x 1200 Primary Display Size: 20.39" x 12.76" (24.02" diag) 51.8cm x 32.4cm (61.0cm diag) Primary VRAM Not Detected Sound card: Audio device: AV200 Memory: RAM: 5972 Mb Miscellaneous: UI Language: English LANG: en_US.UTF-8 Microphone: Not set Total Hard Disk Space Available: 302380 Mb Largest Free Hard Disk Block: 276654 Mb Installed software: Recent Failure Reports: Fri Jan 25 17:41:19 2013 GMT: file ''/tmp/dumps/assert_20130125184116_1.dmp'', upload yes: ''CrashID=bp-33b9798c-1e8e-47ae-b0a1-8e5942130125''
WMP Jan 25, 2013 @ 12:08pm 
Yes, i have this issue after this same steps.
chucc Jan 25, 2013 @ 12:56pm 
I found a fix! You have to add "-game valve" to the command line. Like this:

LD_LIBRARY_PATH=. ./hl_linux -game valve
WMP Jan 25, 2013 @ 1:03pm 
You have right :)
thetargos Jan 25, 2013 @ 1:35pm 
Will try this as soon as I get home. I had that issue last night, only no segfault. Only a message in the console about a bogus CD Key.
< >
Showing 1-5 of 5 comments
Per page: 15 30 50

Date Posted: Jan 25, 2013 @ 10:31am
Posts: 5