Steam for Linux > 综合讨论 > 主题详情
Ilrita 2013年1月24日下午5:07
OpenGL issue; Ubuntu 12.04 (others too)
Hiya guys,

Maybe someone here has a solution or encounters the same problem on a similar build. So I have a GeForce Sparkle 6600 LE card and have installed the latest driver it wants from me, which is 304.64 (unless that is wrong?).

However, I cannot use my GPU in my system at all if I plan to boot into a Linux OS. I have tried Ubuntu, Kubuntu, Xubuntu, Edbuntu, Linux Mint (Nadia and Maya), Manjaro and have tried Arch, but I can't get that to even boot up to installation if the GPU is in. If I put the card in after I install the driver, I get pulled into a black screen that does nothing. The computer is still on, but it is like it isn't at the same time. Booting into recovery or safe graphics mode results in a Command Line Screen, only it displays that it is trying to boot into safe graphics mode, but never does. I have let it sit for about twenty minutes before I did a hard shut off.

Inside without the GPU I can see and do everything quiet normally, but whenever I run Steam and try to play TF2 or if I try to run anything that requires OpenGL, I get a "you do not have OpenGL installed" and this blasted problem in Steam;

Could not find required OpenGL entry point 'glGetError'| Either your video card is unsupported, or your OpenGL driver needs to be updated

Which then reports I should update my nvidia-settings, but that makes me reboot which either does one of two things 1) boots me to a black screen or 2) boots in fine with the wrong driver like 256. I have read countless threads for nearly two weeks straight now and the only step I have seen and could not do is install "lib32-nvidia-utils". I cannot find it, and if I try to install via the terminal, I get "E: Unable to locate package lib32-nvidia-utils".

Here is my info. I have multiple distros, mainly using Linux Mint and Ubuntu, but I will settle if I could get Steam or rather any OpenGL required software/game to work in whatever distro I must. So for now, I'll post my Ubuntu info;

Release: Ubuntu 12.04 (precise) 64bit
Kernel Version: 3.2.0-36-generic
GCC Version: 4.6 (x86_64-linux-gnu)
Xorg Version: 1.11.3
CPU: AMD Athlon(tm) II X2 240 Processor
GPU: Currently using on board, "GeForce 6150SE nForce 430".
External GPU: GeForce Sparkle 6600 LE 256mb card
Driver: 304.64

I know only one other person with a setup like mine and is having the same exact issues, only their GPU is 512mb version instead.

Any suggestions, guys?

*I can launch Steam fine and it runs smoothly outside of games, if this matters.
正在显示第 1 - 15 条,共 25 条留言
< >
gutigen o) 2013年1月25日上午2:10 
Can you install 310.x drivers? your GPU may be too old for this.
blackout24 2013年1月25日上午3:16 
No 310 is for 8000 series or higher.
gutigen o) 2013年1月25日上午3:18 
引用自 t.jp Arch Linux
No 310 is for 8000 series or higher.

Well, that's it, TF2 requires 310.x+ drivers, right?
vargablood 2013年1月25日上午3:38 
disabled the onboard gpu in bios or set the discret as preferred ?? Does the setup of your friend you compare with also have a onboard gpu ??
Ilrita 2013年1月25日下午2:23 
Yes, my friend had to switch to on board too because the GPU won't work. We both purchased compaq computers a while ago until we could build our rigs. And I'll look into the BIOS option to disable onboard, but I don't know what or how to set the discrete as preferred.

@gutigen o)
If that is the case, I tried that too. Whenever I tried drivers not for my GPU/on board, Steam would tell me I am not currently using a driver or that I'm using the wrong one--though it would not tell me which to use.
MrTheSoulzツ 2013年1月25日下午3:11 
引用自 Ilrita
Yes, my friend had to switch to on board too because the GPU won't work. We both purchased compaq computers a while ago until we could build our rigs. And I'll look into the BIOS option to disable onboard, but I don't know what or how to set the discrete as preferred.

@gutigen o)
If that is the case, I tried that too. Whenever I tried drivers not for my GPU/on board, Steam would tell me I am not currently using a driver or that I'm using the wrong one--though it would not tell me which to use.

hi, the black screen is related to a bad driver i belive, happened to me once when i tried to manualy install nvidias drivers from theyr website.
what i recomend you do to is install the latest drivers from ubuntu repository under system settings its the last tab that says adicional drivers but before you install it make sure you have linux-headers and linux-source libs installed, they can be installed from the software center.
if this dosent work for you i recomend you try the alpha version of ubuntu 13.04 im using it 24/7 and its stable enough and faster then 12.10 BUT its buggy when new updates come out but they get fixed pretty fast they update it 2 or even 3 times a day.
it also comes with the latest linux-source and linux-headers preinstalled but make sure you do a clean install and you connect and update ubuntu when you are installing it from the bios.
Ilrita 2013年1月25日下午3:17 
Update;

Wow, that cured a lot of the problems! Thanks so much vargablood!

Setting my BIOS to the slot of the GPU allowed me to boot into the computer more than before (though I still get those ugly static screens) and it brought me to the Command Line Interface, which never happened before with the GPU in. Lightdm did not start, but when I did

sudo service lightdm restart

The screen blackened out and reappeared, asking me to update 33 packages, which I did, and then it rebooted and came back with a screen of the following commands;

http://pastebin.com/2Ut9tC5Q
(where the "----" is means the screen cut off so I could not see the rest of it)

All of them reported "[OK]" except the ones that actually said "failed/stopped" before it reboot again and gave me the following TTY1 command line;

plymouthd: ./plugin.c: 540: map_to_device: Assertion 'head->size > o' failed
mountall: DIsconnected from Plymouth
Checking battery state... (on a desktop, though)

And it just say there like that, so I turned it off, removed GPU and am now back in my Ubuntu install.
Ilrita 2013年1月25日下午3:21 
引用自 MrTheSoulz
hi, the black screen is related to a bad driver i belive, happened to me once when i tried to manualy install nvidias drivers from theyr website.
what i recomend you do to is install the latest drivers from ubuntu repository under system settings its the last tab that says adicional drivers but before you install it make sure you have linux-headers and linux-source libs installed, they can be installed from the software center.
if this dosent work for you i recomend you try the alpha version of ubuntu 13.04 im using it 24/7 and its stable enough and faster then 12.10 BUT its buggy when new updates come out but they get fixed pretty fast they update it 2 or even 3 times a day.
it also comes with the latest linux-source and linux-headers preinstalled but make sure you do a clean install and you connect and update ubuntu when you are installing it from the bios.
Hiya!

I have also tried all the drivers available in Additional Drivers. Only nvidia-experimental-304 seemed to work, but it was driver 304.44 and was behind in drivers, so I was constantly asked to update to the newest driver. Any of the other drivers resulted in resolutions I could not change at about 800x740, and also made my TTY1 command line bad.

I will try Ubuntu 13.04 on a new HDD to see if I can get the GPU to work, but hopefully I won't have to do that as I've gone through quiet a bit of distros.

Thanks!
vargablood 2013年1月25日下午3:24 
fine :) setup a new ubuntu installation with the preferred setting using your discrete graphics. i hope those will fix all your porblems so you can use your GT6600. After installin new NVIDIA Drivers manually using command line allways do a sudo reboot :)
Ilrita 2013年1月25日下午3:28 
Hiya!

You mean do a fresh install with the GPU in and with the BIOS set to the GPU, correct? I hope it fixes my problems, too. I really want to play Steam, and use some OpenGL programs.
vargablood 2013年1月25日下午3:29 
yes thats what i mean :)
vargablood 2013年1月25日下午3:33 
dont worry to much about ugly boot screens. that allways happens to me usin nvidia cards and ubuntu. maybe theres an easy reason to solve this but i never cared .....
Ilrita 2013年1月25日下午3:53 
So it you get the same? Weird. I wonder if others get the screens booting into Linux, too. Nvidia should work on that!

Alright, I'm going to do a fresh install of Ubuntu 13.04 tonight. Just did a fresh install of Manjaro with the needed drivers (which is so easy, by the way guys; automatically gets you the correct driver!) and with the GPU in, but sadly I get the same problems.

edits

How can I make it install using my preferred settings? I don't see any options that differ from Ubuntu or whatnot.
最后由 Ilrita 编辑于; 2013年1月25日下午4:20
MrTheSoulzツ 2013年1月25日下午6:05 
引用自 Ilrita
引用自 MrTheSoulz
hi, the black screen is related to a bad driver i belive, happened to me once when i tried to manualy install nvidias drivers from theyr website.
what i recomend you do to is install the latest drivers from ubuntu repository under system settings its the last tab that says adicional drivers but before you install it make sure you have linux-headers and linux-source libs installed, they can be installed from the software center.
if this dosent work for you i recomend you try the alpha version of ubuntu 13.04 im using it 24/7 and its stable enough and faster then 12.10 BUT its buggy when new updates come out but they get fixed pretty fast they update it 2 or even 3 times a day.
it also comes with the latest linux-source and linux-headers preinstalled but make sure you do a clean install and you connect and update ubuntu when you are installing it from the bios.
Hiya!

I have also tried all the drivers available in Additional Drivers. Only nvidia-experimental-304 seemed to work, but it was driver 304.44 and was behind in drivers, so I was constantly asked to update to the newest driver. Any of the other drivers resulted in resolutions I could not change at about 800x740, and also made my TTY1 command line bad.

I will try Ubuntu 13.04 on a new HDD to see if I can get the GPU to work, but hopefully I won't have to do that as I've gone through quiet a bit of distros.

Thanks!
the low resulotion and bugs like that on ubuntu 12.10 when you install nvidias driver its becuase it dosent come with linux-headers and linux-source happened to me also.

with 13.04 its pretty easy it comes with better open source drivers and with those two libs that were missing from 12.10 preinstalled.

if you are gonna use 13.04 i recommend you download the latest daily build from theyr official website and when installing make sure you update it while installing it from the bios and also when you 1st boot the pc.

give us some feedback if it works ok for you so other people knows how to fix it :D

PS: also after updating evrything install the nvidia drivers and check if you have the r310 now or if it dosent install the r304 and reboot and see if that helped.
最后由 MrTheSoulzツ 编辑于; 2013年1月25日下午6:08
Ilrita 2013年1月25日下午6:26 
Hiya!

I downloaded from here, 32 bit version; http://cdimage.ubuntu.com/daily-live/current/ Is that correct one?

And you mean I should check the "update while installing" option? Should I also check the "install third-ware programs" option too?

Should I install manually, or will they be available inside the "Additional Drivers" tab through preferences?

I will definitely leave some feedback if this works. I have seen a lot of people experiencing this problem.
正在显示第 1 - 15 条,共 25 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年1月24日下午5:07
帖子数: 25