Duke Wellington Jan 23, 2013 @ 9:03pm
Starting up TF2: Failed to create OpenGL device! (Error 0xFFFFFFFF)
I recently installed a fresh copy of Ubuntu 12.10, and after going through a fuss to get the right drivers for my system (detailed below post), I finally managed to get TF2 to run on Ubuntu (yay!). However, when it first started up, I had a host of graphical artifacts appearing on the screen all over the place until I got to the menu. After I changed some graphical settings, they came back and I had to open the console and type 'quit' just to quit the game (as I couldn't see anything useful on the screen besides artifacts). After that, I tried to boot the game up again, but this time the game failed to create the OpenGL device (error in title), and ever since it keeps repeating. I'm a little frustrated because I finally had managed to get it working, only to slap me in the face again just as I booted up tf2.

My hardware:
CPU: AMD Phenom II X4 AM3 955 BE @ 3.4 Ghz (OC'd)
GPU: Sapphire Radeon HD 4890 w/ 1 GB GDDR5 & PCI-E 2.0 x16 @ 901 Mhz (factory OC'd, discontinued, legacy driver)
Motherboard: MSI 790FX-GD70 w/ BIOS @ v.1.H0
OS: Ubuntu 12.10 (64-bit) Quantal Quetzel
Linux Kernel: 3.5.0-22-generic

Initially, I had tried to install the stock drivers from AMD's page (since USC doesn't have the listings in 12.10), but the drivers failed to install appropriately due to this bug: https://bugs.launchpad.net/ubuntu/+source/fglrx-installer-updates/+bug/1025488

So I had to use a work-around, and downloaded a custom PPA with a patched 13.1 legacy driver using an older version of x-server (1.12.4)

Link here: https://launchpad.net/~makson96/+archive/fglrx

Upon a reboot after installing the updated legacy drivers, I was able to successfully configure my driver, and I used these settings in the CCC:
Display Properties: 1920x1080@120Hz
Display Options: Enable Tear Free Desktop to reduce tearing.
3D:
  • Application-based Anti-Aliasing setting
  • Adaptive Anti-Aliasing set to 'Quality'
  • Anisotropic Filtering set to 16X
  • Mipmap Detail Level set to 'High Quality'
  • Vertical refresh set to 'On, unless application specifies'
  • Catalyst A.I. set to 'Advanced'

Any help would be appreciated.
Showing 1-15 of 15 comments
< >
Richie442 Jan 25, 2013 @ 8:55am 
I am experiencing the same problem with newly released 13.1 driver on HD 3650 graphic card ( Ubuntu 12.04 LTS). Installed, changed graphic settings, force quit the game, relaunch, black screen and then this error message... reinstalling the game didn't help.... i am so bored with AMD right now..
Last edited by Richie442; Jan 25, 2013 @ 8:59am
Pocket Jan 25, 2013 @ 11:01pm 
Exact same problem. First launch, menu looked fine aside from some weird banding around the buttons. Changed a couple of graphics options (enabled AA, turned textures up to Very High), and immediately the options menu started flashing like a strobe light. Nothing I clicked worked after that, so I quit, and now when I start I get that.

Kubuntu 12.04 64 bit
AMD legacy driver 13.1 manually installed (I had to use --force because it was still detecting traces of fglrx despite my best efforts to clear it off), default settings in Catalyst unaltered
Radeon HD 4850

Edit: Oh, and FYI Half-Life beta is working fine for me so far. Even has AA turned on by default somehow.
Last edited by Pocket; Jan 25, 2013 @ 11:02pm
moraes.alvarez Jan 26, 2013 @ 12:07pm 
Yep. That's the case with me as well.

Couldn't run with 12.6 catalyst legacy (HD 4850). Updated to 13.1 legacy through the AMD installer (created a package) and the game ran once. Tried changing video settings, the game crashed and then it wouldn't start ever again.

I'm running Ubuntu Precise.

I'm selling my HD 4850 and buying some NVidia card right away. Can't take this anymore.
Richie442 Jan 27, 2013 @ 2:26am 
AMD is losing a lot of customers with this attitude. Bad performance, waiting 7 months for new graphic driver on Linux which is..bad. HD 2000-4000 as "legacy". Going next time for Nvidia card... and i was always an "AMD" "Ati" Guy.
ss900 Jan 30, 2013 @ 11:29pm 
I found that removing the video configuration file the game works again.
In order to remove the video configuration file please execute the following command from the terminal:
rm ~/.steam/steam/SteamApps/<steamID>/Team Fortress 2 Beta/tf_beta/videoconfig_linux.cfg

NOTE: substitute <steamID> with your original steam user name.
I suspect that anti-aliasting should not be enabled with "legacy" AMD cards in order to run the game properly.

Hope this helps.
Last edited by ss900; Jan 31, 2013 @ 1:39am
Pocket Jan 31, 2013 @ 10:45am 
Hmm. I deleted that file, and now it just doesn't start up. The "Preparing to launch Team Fortress 2" window just sits there forever.
Originally posted by ss900:
I suspect that anti-aliasting should not be enabled with "legacy" AMD cards in order to run the game properly.
Well that sucks. Hopefully they'll get that ironed out before release. Source engine games look way worse without AA than most games, due to the reliance on high polygon counts vs. faking it with bumpmaps. Half-Life, incidentally, has AA on by default (whereas before it wasn't even an option) and has no such issues.
Last edited by Pocket; Jan 31, 2013 @ 10:48am
ss900 Jan 31, 2013 @ 9:43pm 
You may also try removing the *.cfg configurations in ~/.steam/steam/SteamApps/<steamID>/Team Fortress 2 Beta/tf_beta/cfg in order to restart the game with the default settings.

Regarding the AA issue I think that Half-Life is based on the GoldSrc engine but TF2 is based on the Source Engine so they might use different AA techniques.

In any case is Half-Life available for the Linux platform? I'm unable to find it on the Linux section on the Steam store.
Pocket Feb 1, 2013 @ 8:01am 
That's because it's still in beta. If you already own the game, the beta will be in your library.
Duke Wellington Feb 1, 2013 @ 11:28pm 
All right. I went ahead and reinstalled a fresh 12.10, and this time stood with Unity. I confirmed that tf2 indeed breaks with anti-aliasing (anything with mat_antialias anything besides 0 or 1). I also tried varying driver anti-alias settings within the CCC to see if the driver was interfering, but to no avail. Also, when on full screen, tapping middle click seems to generate a flash of artefacts on the screen, I'm unsure why. When in windowed mode, this is not the case. I know this because I usually bind my middle mouse click to 'jump' in most games and every time I jumped in the game a splash of artefacts would flash on my screen. Other than that, I haven't investigated too deeply to see if there are any other problems with artefacts.

Also, when doing net_graph 3, I recorded my average fps in a multi-player match at around 22-30 fps, when in windows I'm able to buff out between 60-120 fps depending on what I look at. I have a feeling that I should maybe just go ahead and install 12.04 and see if the legacy 13.1 drivers do a better job with performance on that. I know that the 13.2 beta recently came out for those who have HD 5000 series and up, so I'm SOL until AMD releases an equivalent legacy driver, if they haven't stopped altogether on them (the 13.1 legacy catalyst really just uses the 12.6 display driver).

P.S. When you enable anti-alias and can't boot into the game, just do this:
Go to ~/.local/share/Steam/SteamApps/{username}/Team Fortress 2/tf/ and then locate the videoconfig_linux.cfg file, then open it with gedit or your favorite text editor, and change the appropriate line "mat_antialias" "#" with number "0" in place of the "#", then save and boot the game.

And if you have trouble finding the steam folder, press ctrl+h in the file manager (or ls -a in the terminal) to help you locate the appropriate directory.
Last edited by Duke Wellington; Feb 1, 2013 @ 11:47pm
Pocket Feb 2, 2013 @ 1:03am 
Yep, after rebooting, I was able to get the game to run again. And man, they weren't kidding about framerates. But yeah, it's the AA that's doing it. It shouldn't be too hard for either Valve or AMD to get that sorted. I did post on AMD's feedback/bug-tracker thing about the issue. The framerate I'm expecting to see fixed once 13.2 goes out of beta and gets backported.
Duke Wellington Feb 12, 2013 @ 9:29am 
Okay, so I finally got around to installing 12.04 LTS, and I tried downloading the drivers through the 'Additional Drivers' section of the OS, only to run into this when running TF2:

OpenGL extension "GL_EXT_texture_sRGB_decode" is not supported. Please update your OpenGL driver.

Then I uninstalled that driver in case it was the older version and downloaded and installed the one from the main page on AMD's site. It installed all right this time (finally) on the 3.2.0-37-generic kernel, but my system is rather sluggish now, and I hang when starting steam (a restart doesn't help). I tried opening Steam from a terminal and got this output:

Running Steam on ubuntu 12.04 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1360621458_client)
SteamUpdateUI: An X Error occurred
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 139 (ATIFGLEXTENSION)
Minor opcode of failed request: 66
Serial number of failed request: 13
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 29
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 40
xerror_handler: X failed, continuing
SteamUpdateUI: An X Error occurred
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 136 (GLX)
Minor opcode of failed request: 14 (X_GLXGetVisualConfigs)
Serial number of failed request: 51
xerror_handler: X failed, continuing
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(Steam)/version(1360621458_client)
Installing breakpad exception handler for appid(Steam)/version(1360621458_client)
Error opening file for reading: Permission denied
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 3054 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 3054 with name 0eSteamEngineLock

(process:3150): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
CAsyncIOManager: 0 threads terminating. 0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 242 single object sleeps, 0 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 1 multi object alertable sleeps
framefunction.cpp (120) : Assertion Failed: CFrameFunctionMgr::~CFrameFunctionMgr: non static FrameFunction still registered
Assert( Assertion Failed: CFrameFunctionMgr::~CFrameFunctionMgr: non static FrameFunction still registered ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/common/framefunction.cpp:120

Installing breakpad exception handler for appid(Steam)/version(1360621458_client)
peek of pipe from 0/0 failed: 11

Note: Steam just hangs at this point. No further output is generated, yet the program doesn't exit, and the only way to stop it is with ctrl+c.


Update: After a reinstall of Steam, it no longer hangs but I get this:
Fatal Error: Steam failed to load: *SteamStartEngine(0xfff0b2b0) failed with error 1: Failed to create pipe: 13

Update 2: I'm able to run the game using this crude workaround: http://steamcommunity.com/app/221410/discussions/0/846938351012409765/
Alas, the anti-aliasing problem still exists, as does middle-click artefacts. Here is a screen of loading anti-aliasing for the first time:
http://s9.postimage.org/3mgj18n67/TF2_Artefacts.png
Here is a screen with the in-game fps, and the absense of the rgba decode with poor performance:
http://s12.postimage.org/819eht9kd/TF2_No_Color_Decode.png
Last edited by Duke Wellington; Feb 12, 2013 @ 3:20pm
Matt Damon Apr 1, 2013 @ 11:27pm 
It's because of anti-aliasing. Don't enable it and you should be fine.
rim6o May 24, 2013 @ 11:01am 
Originally posted by Duke Wellington:

P.S. When you enable anti-alias and can't boot into the game, just do this:
Go to ~/.local/share/Steam/SteamApps/{username}/Team Fortress 2/tf/ and then locate the videoconfig_linux.cfg file, then open it with gedit or your favorite text editor, and change the appropriate line "mat_antialias" "#" with number "0" in place of the "#", then save and boot the game.

And if you have trouble finding the steam folder, press ctrl+h in the file manager (or ls -a in the terminal) to help you locate the appropriate directory.
Thank you! Always a more elegant solution compared to crude removal of configs.

Also AMD HD 3650 here, Linux (Fedora 18). Skrew AMD. Never again!

One more thing. The error dialogue contains a link to Steam support article. Can anyone paste it here?
Doc Holliday May 24, 2013 @ 11:40am 
AMD has bad linux driver support
Doc Holliday May 24, 2013 @ 11:41am 
use amd opensource drivers
Showing 1-15 of 15 comments
< >
Per page: 15 30 50
Date Posted: Jan 23, 2013 @ 9:03pm
Posts: 15