Steam for Linux > 総合掲示板 > トピックの詳細
The Monster 2013年1月18日 8時02分
[Issue] [Help needed] League of Legends (wine) won't launch when added to native steam
I followed the instructions from a YouTube video on how to add WINE games to Steam (native). I created a .sh file and pasted below it the command found in the PlayOnLinux shortcut of Skyrim, added it to steam, and ran it. It worked well. Then I tried to do the same for League of Legends and the game attempted to launch but crashed after displaying the League of Legends logo. Here's the steam terminal output:
FalseGame update: AppID 0 "League of Legends", ProcID 858, IP
[main] Message: PlayOnLinux (4.1.9) is starting
[clean_tmp] Message: Cleaning temp directory
Script started /home/user/.PlayOnLinux/shortcuts/League of Legends
[POL_System_CheckFS] Message: Checking filesystem for rads_user_kernel.exe
[POL_Wine] Message: Running wine-1.5.12-LeagueOfLegends rads_user_kernel.exe run lol_launcher LoLLauncher.exe %F (Working directory : /home/user/.PlayOnLinux/wineprefix/LeagueOfLegends/drive_c/Riot Games/League of Legends/RADS/system)
[POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
wine: configuration in '/home/user/.PlayOnLinux//wineprefix/LeagueOfLegends' has been updated.
( DEBUG)[15:13:29.004] RADS::Common::RegistryHelp::RegKeyValueString::RegKeyValueString: (Software\Riot Games\RADS, LocalRootFolder, c:\rads)
( ERROR)[15:13:30.318] RADS::User::PandoManager::start: StartPMB failed, returned error 6
( ERROR)[15:13:30.319] RADS::UserKernel::UserCommandThread::ThreadProc: Invalid command line.
( ERROR)[15:13:30.322] RADS::UserKernel::NamedPipe::ConnectionThread::ThreadProc: The handle that was passed to the API has been either invalidated or closed.
( ERROR)[15:13:30.322] RADS::UserKernel::NamedPipe::ConnectionThread::ThreadProc: ConnectNamedPipe failed.
( ERROR)[15:13:30.548] RADS::Common::HTTPConnection::GetFile: perform request failed with code 7
( ERROR)[15:13:30.548] RADS::Common::HTTPConnection::GetFile: Failed on /rest/getToken?format=xml&ClientID=PMB_Client
( ERROR)[15:13:30.554] RADS::Common::HTTPConnection::GetFile: perform request failed with code 7
( ERROR)[15:13:30.554] RADS::Common::HTTPConnection::GetFile: Failed on /rest/getToken?format=xml&ClientID=PMB_Client
( ERROR)[15:13:30.561] RADS::Common::HTTPConnection::GetFile: perform request failed with code 7
( ERROR)[15:13:30.561] RADS::Common::HTTPConnection::GetFile: Failed on /rest/shutdown?format=xml&netToken=
[POL_Wine] Message: Wine return: 0
Game removed: AppID 0 "League of Legends", ProcID 858

Does anyone have an idea on how to get this to work? I'd like to run League of Legends via Steam because the Steamlogin project (steam desktop environment) would probably boost the FPS of League of Legends by a lot.
1-2 / 2 のコメントを表示
< >
The Wounded 2013年1月18日 10時31分 
this is about native steam not running through wine, look on the wine website appdatabase for problems with that.
The Monster 2013年1月18日 14時51分 
Uh no it's the other way around. It's a WINE application not running within Steam that has been installed from a .deb file via the software center and not from an .exe file installed through WINE.
1-2 / 2 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年1月18日 8時02分
投稿数: 2