Steam for Linux > 一般討論 > 主題細節
Jeros 2013 01 月 18 @ 3:22上午
Steam refuses to install, at a loss as to why
Running lubuntu 64bit 12.04

When I try to install with gdebi I get this:

Error: Dependency is not satisfiable: libudev0 (>= 175-0ubuntu9.2)

Anyone know how to solve this, I have done the normal sudo apt-get update and that and everything is fully up to date.
顯示 1-7,共 7 則回應
< >
[Linux] Schrödinger's cat 2013 01 月 18 @ 3:30上午 
sudo apt-get install libudev0 ?
Jeros 2013 01 月 18 @ 3:57上午 
sudo apt-get install libudev0 ?

Tried that an I get:

Reading package lists... Done
Building dependency tree
Reading state information... Done
libudev0 is already the newest version.

JarnoKai 2013 01 月 18 @ 7:24上午 
how about libudev0-dev or something? Try to google it, i think you will find an answer.
AlamA 2013 01 月 19 @ 2:05下午 
sudo apt-get install libudev0:i386

you need :i386 to say you want the install the i386 version of libudev0 package
Jeros 2013 01 月 21 @ 3:32上午 
AlamA 發表:
sudo apt-get install libudev0:i386

you need :i386 to say you want the install the i386 version of libudev0 package

I did this but it still says its the wrong version when I trying to install the steam deb file

I am assuming 12.04 is not the issue? I cannot use 12.10 effectively on my system.
gradinaruvasile 2013 01 月 21 @ 3:37上午 
What does "apt-cache policy libudev0" return?
Jeros 2013 01 月 21 @ 3:46上午 
libudev0:
Installed: 175-0ubuntu9
Candidate: 175-0ubuntu9
Version table:
*** 175-0ubuntu9 0
500 http://gb.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
100 /var/lib/dpkg/status


I have solved the problem now.

When I disabled all the updates from Important security/Proposed/Unsupported and Restricted sources to ensure only the most stable packages, I had lumped myself with an old version of libudev0 that is apparently considered the most stable.

I will make an exception for steam however :P

Feel stupid now. But would not have solved it without you laszlo.kertesz :P
顯示 1-7,共 7 則回應
< >
每頁: 15 30 50
張貼日期: 2013 01 月 18 @ 3:22上午
回覆: 7