Fred Jan 17, 2013 @ 6:15pm
AMD Catalyst Display Driver 13.1 is out
AMD Catalyst 13.1 Proprietary Linux x86 Display Driver[support.amd.com]
AMD Catalyst 13.1 Proprietary Linux Graphics Driver Release Notes[support.amd.com]
Installation / Removal / Update Guides: Unofficial Wiki for the AMD Linux Driver[wiki.cchtml.com]

Resolved Issues
[368958]: Driver release version is added to GL_VERSION
[367282]: Bblank VGA display after resume from suspend
[367245]: X crash for AMD PowerXpress™ A+I High-Performance mode on Ubuntu 12.10
[366820] Performance of Valve Linux games
[366805]: Segmentation fault when exit QtOpenGL applications such as AMD CodeXL
[366425]: Xserver getting exit upon resume from suspend on RHEL 5.8
[364107]: VariBright not working when change AMD PowerPlay™ settings in AMD Catalust Control Center:LE
[363638]: VariBright doesn’t work after resume from suspend on "Trinity" platform
[350759]: Flickering cursor when run some full-screen OpenGL games with CrossFire enabled
[347895]: OpenGL performance on "Southern Islands" ASICs
[344996]: 16 re-frames doesn’t work for H.264 @Level 5.1
[337240]: Corruption when resize the Konsole window
[304016]: One display goes black after changing from multi-display desktop from single independent

Known Issues
[356966]: Tearing appears at the top/left corner with monitor rotation + Vsync is enabled
[350671]: Corruption may be experienced when running Unigine Tropics 1.3
[341497]: OpenGL Bitmap performance may be impacted in certain situations
Last edited by Fred; Jan 18, 2013 @ 1:34am
Showing 1-15 of 44 comments
< >
Evil Penguin Jan 17, 2013 @ 7:09pm 
Yup, TF2 performance is still horrible with the Radeon HD 7970.
Massive frame drops.
porkloin Jan 17, 2013 @ 7:16pm 
Yeah, no real performance improvements on Radeon HD 7750. The installation process on 12.10 was significantly better, though.
Junior s2 Camila Jan 17, 2013 @ 7:53pm 
You guys also have fps drops? With my nvidia drivers (310.14, 310.19, 313.09) I also have these. Sometimes it gets fixed with CTRL+SPACE (and then minimize), or (if you have) disabling anti-aliasing.
porkloin Jan 17, 2013 @ 8:00pm 
I haven't been able to run with anti-aliasing on at all since the beginning, and I have to leave reflection and shadow details down at the minimum, etc. 13.1 doesn't seem to have resolved much, however.
Last edited by porkloin; Jan 17, 2013 @ 8:00pm
Junior s2 Camila Jan 17, 2013 @ 8:36pm 
That's so sad, hearing that from ATI.
Comrade msw1 Jan 17, 2013 @ 10:10pm 
It just says Linux_x86, yet comes up if I select 64-bit. Is it?
Muffinabus Jan 17, 2013 @ 10:13pm 
I think they're the same driver for 32 and 64 bit.
Comrade msw1 Jan 17, 2013 @ 10:41pm 
Do you know that for sure? It's not that I don't trust you, I just don't want to mess up my computer.

*EDIT* My bad, my computer hid the x86_64 part after the . , hopefully it works!
Last edited by Comrade msw1; Jan 17, 2013 @ 11:05pm
linux|epic failaments Jan 17, 2013 @ 11:13pm 
There seems to be a slight improvement for tf2 with 6950
El Pollo Santos Jan 17, 2013 @ 11:27pm 
Odd update, TF2 works better most of the time, and AA mode is working decently, however I am getting big performance dips periodically regardless of what is happening in game. Having AA enabled greatly worsens this problem. Overall 12.11 beta 11 gave me more consistant performace. However these drivers seem to run cooler, or at least have better fan control on my dual 5870m's
El Pollo Santos Jan 17, 2013 @ 11:59pm 
Interesting note on the new drivers, I get much better performance on them using Unity VS LDXE which is what I normally use for games.
yabba Jan 18, 2013 @ 1:43am 
Originally posted by l8ernewb:
Yeah, no real performance improvements on Radeon HD 7750. The installation process on 12.10 was significantly better, though.

Yeah but these are Windows hardware quality labs certified! Whoo
mattyy1hp |Linux| Jan 18, 2013 @ 4:42am 
I don't see any difference.

I have two graphics cards, look at this:

6520G APU
- vSync don't works
- black screen in full screen games on CInnamon
- I have to play in windowed mode
- weird graphics artefacts on Cinnamon
- extremly low performance comparing to Windows

6470M GPU
- AMD Vari-bright don't work
- invisible line in a middle of screen - top is rendered slower, than the bottom one (really awesome for movies or games, just awesome...)
- vSync don't work
- can't start TF2 (hangs on "loading ..." screen)
- extremly low performance comparing to Windows

6520G + 6470M
- AMD Dual graphics - absolutely no support
- black screen on switching from GPU to APU

What I have to do to play TF2?
1/ Switch to 6520G APU
2/ Log out to restart Xserver (required for GPU switching)
3/ Black screen = reboot
4/ On login screen, switch to Mate DE
5/ Change TF2 launch commands to windowed mode,1280x720
6/ Hey, I can finally play it!

There is no hope. AMD are unable idiots.
Fred Jan 18, 2013 @ 4:54am 
Originally posted by mattyy1hp Linux:
I don't see any difference.

I have two graphics cards, look at this:

6520G APU
- vSync don't works
- black screen in full screen games on CInnamon
- I have to play in windowed mode
- weird graphics artefacts on Cinnamon
- extremly low performance comparing to Windows

6470M GPU
- AMD Vari-bright don't work
- invisible line in a middle of screen - top is rendered slower, than the bottom one (really awesome for movies or games, just awesome...)
- vSync don't work
- can't start TF2 (hangs on "loading ..." screen)
- extremly low performance comparing to Windows

6520G + 6470M
- AMD Dual graphics - absolutely no support
- black screen on switching from GPU to APU

What I have to do to play TF2?
1/ Switch to 6520G APU
2/ Log out to restart Xserver (required for GPU switching)
3/ Black screen = reboot
4/ On login screen, switch to Mate DE
5/ Change TF2 launch commands to windowed mode,1280x720
6/ Hey, I can finally play it!

There is no hope. AMD are unable idiots.

Have you properly generated a dual graphics processing unit configuration with amdconfig for /etc/X11/xorg.conf?
mattyy1hp |Linux| Jan 18, 2013 @ 5:06am 
Originally posted by Fred:
Originally posted by mattyy1hp Linux:
I don't see any difference.

I have two graphics cards, look at this:

6520G APU
- vSync don't works
- black screen in full screen games on CInnamon
- I have to play in windowed mode
- weird graphics artefacts on Cinnamon
- extremly low performance comparing to Windows

6470M GPU
- AMD Vari-bright don't work
- invisible line in a middle of screen - top is rendered slower, than the bottom one (really awesome for movies or games, just awesome...)
- vSync don't work
- can't start TF2 (hangs on "loading ..." screen)
- extremly low performance comparing to Windows

6520G + 6470M
- AMD Dual graphics - absolutely no support
- black screen on switching from GPU to APU

What I have to do to play TF2?
1/ Switch to 6520G APU
2/ Log out to restart Xserver (required for GPU switching)
3/ Black screen = reboot
4/ On login screen, switch to Mate DE
5/ Change TF2 launch commands to windowed mode,1280x720
6/ Hey, I can finally play it!

There is no hope. AMD are unable idiots.

Have you properly generated a dual graphics processing unit configuration with amdconfig for /etc/X11/xorg.conf?

I used "# aticonfig --initial".
I didn't know, that there is a special config for dual graphics. Please, tell me how.
Showing 1-15 of 44 comments
< >
Per page: 15 30 50
Date Posted: Jan 17, 2013 @ 6:15pm
Posts: 44