adewolf11 Jan 13, 2013 @ 7:28pm
Steam for Linux, primus and Lenovo Y480
TF2 is crashing weather I use optirun or primusrun. Ths is on a Lenvov Y480, which requires the levovo-hack to get to the nvidia 630m GPU. I am running Arch linux 64 bit:
LANG=C LC_NUMERIC=C SteamAppId=440 vblank_mode=0 primusrun ./hl2.sh -steam -console -game tf -novid
..
Installing breakpad exception handler for appid(hl2_linux)/version(1.0_client)
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
warning: Unknown nb_ctl request: 4
Uploading dump (in-process) [proxy '']
/tmp/dumps/crash_20130113190436_1.dmp
success = yes
response: CrashID=bp-ef48eb0b-f89d-4d7e-b629-f685d2130113
/home/adewolf/.local/share/Steam/SteamApps/adewolf/Team Fortress 2/hl2.sh: line 72: 16825 Segmentation fault (core dumped) ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"

I wonder if the lenovo-hack is causing this problem.
Showing 1-3 of 3 comments
< >
zenter Feb 6, 2013 @ 5:40am 
I have similar bug on my asus u30sd with optimus:
http://pastebin.com/nvKuNa3y
Last edited by zenter; Feb 6, 2013 @ 5:41am
kwahoo Feb 6, 2013 @ 11:09am 
Try disable "Multicore rendering" in TF2 settings menu. Works for me (Lenovo Z500 + acpi-hack here).
Deprecated Feb 12, 2013 @ 9:03pm 
I had the same problem playing Counter Strike Source on my Dell Xps 15 with Optimus, disabling Multicore rendering worked perfectly, thanks
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Jan 13, 2013 @ 7:28pm
Posts: 3