Steam for Linux > Dyskusje ogólne > Szczegóły tematu
Fred 13 Sty, 2013 - 8:02
Team Fortress 2 occasionally has a slow down issue on start
Sometimes when I start Team Fortress 2, the game is generally very slow. It is unplayable, so I have to close the game and run it again.

When the slow down issue does not occur, I can play the game fine, with up to two hundred frames per second.
Wyświetlanie 1-7 z 7 komentarzy
< >
gutigen o) 13 Sty, 2013 - 8:32 
Distro?
GPU Drivers?
Desktop manager?
Terminal output?
Fred 13 Sty, 2013 - 8:36 
Distro?

Ubuntu 12.10 64-bit.

GPU Drivers?

AMD HD5850 using the latest beta driver provided by AMD.

Desktop manager?

The default.

Terminal output?

I have no idea how to launch Team Fortress 2 from the terminal.
Ostatnio edytowany przez: Fred; 13 Sty, 2013 - 8:36
gutigen o) 13 Sty, 2013 - 9:15 
Turn off Steam, open terminal, paste:
steam steam://rungameid/440
Enter.
Ostatnio edytowany przez: gutigen o); 13 Sty, 2013 - 9:15
dpc 20 Sty, 2013 - 7:57 
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.
Ostatnio edytowany przez: dpc; 20 Sty, 2013 - 8:00
Fred 20 Sty, 2013 - 10:22 
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.

Exactly. It seems that if I launch the game with there being no load, and me not switching away from the game, it will launch fine. But if I dare to multi-task, even as much as browsing through some web pages, the issue occurs until I restart and try again.
mikesart 28 Sty, 2013 - 16:08 
Someone posted here:

http://www.reddit.com/r/linux_gaming/comments/17cdj5/tf2_issues_in_ubuntu_1210/

To try this: "try turning off steam community in game in steam settings."

Does that help? And can someone try setting the engine_no_focus_sleep convar to 0 and see if that does anything?

Also, if someone could enter this bug into github I'd appreciate it. Thanks!
dpc 28 Sty, 2013 - 17:22 
It seems that the game stopped lagging for me after latest steam update. I now have around 5 starts which all went smooth. I need to make sure this is permanent or just a better day.

Also, non of the tricks posted here really helped me before.
Ostatnio edytowany przez: dpc; 28 Sty, 2013 - 17:25
Wyświetlanie 1-7 z 7 komentarzy
< >
Na stronę: 15 30 50
Data napisania: 13 Sty, 2013 - 8:02
Posty: 7