Fred 13. Jan. 2013 um 8:02 Uhr
Team Fortress 2 occasionally has a slow down issue on start
Sometimes when I start Team Fortress 2, the game is generally very slow. It is unplayable, so I have to close the game and run it again.

When the slow down issue does not occur, I can play the game fine, with up to two hundred frames per second.
Beiträge 1-7 von 7
< >
gutigen o) 13. Jan. 2013 um 8:32 Uhr 
Distro?
GPU Drivers?
Desktop manager?
Terminal output?
Fred 13. Jan. 2013 um 8:36 Uhr 
Ursprünglich geschrieben von Linux gutigen o):
Distro?

Ubuntu 12.10 64-bit.

Ursprünglich geschrieben von Linux gutigen o):
GPU Drivers?

AMD HD5850 using the latest beta driver provided by AMD.

Ursprünglich geschrieben von Linux gutigen o):
Desktop manager?

The default.

Ursprünglich geschrieben von Linux gutigen o):
Terminal output?

I have no idea how to launch Team Fortress 2 from the terminal.
Zuletzt bearbeitet von Fred; 13. Jan. 2013 um 8:36 Uhr
gutigen o) 13. Jan. 2013 um 9:15 Uhr 
Turn off Steam, open terminal, paste:
steam steam://rungameid/440
Enter.
Zuletzt bearbeitet von gutigen o); 13. Jan. 2013 um 9:15 Uhr
dpc 20. Jan. 2013 um 7:57 Uhr 
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.
Zuletzt bearbeitet von dpc; 20. Jan. 2013 um 8:00 Uhr
Fred 20. Jan. 2013 um 10:22 Uhr 
Ursprünglich geschrieben von dpc:
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.

Exactly. It seems that if I launch the game with there being no load, and me not switching away from the game, it will launch fine. But if I dare to multi-task, even as much as browsing through some web pages, the issue occurs until I restart and try again.
mikesart 28. Jan. 2013 um 16:08 Uhr 
Someone posted here:

http://www.reddit.com/r/linux_gaming/comments/17cdj5/tf2_issues_in_ubuntu_1210/

To try this: "try turning off steam community in game in steam settings."

Does that help? And can someone try setting the engine_no_focus_sleep convar to 0 and see if that does anything?

Also, if someone could enter this bug into github I'd appreciate it. Thanks!
dpc 28. Jan. 2013 um 17:22 Uhr 
It seems that the game stopped lagging for me after latest steam update. I now have around 5 starts which all went smooth. I need to make sure this is permanent or just a better day.

Also, non of the tricks posted here really helped me before.
Zuletzt bearbeitet von dpc; 28. Jan. 2013 um 17:25 Uhr
Beiträge 1-7 von 7
< >
Pro Seite: 15 30 50
Geschrieben am: 13. Jan. 2013 um 8:02 Uhr
Beiträge: 7