Fred 13 jan 2013 à 8h02
Team Fortress 2 occasionally has a slow down issue on start
Sometimes when I start Team Fortress 2, the game is generally very slow. It is unplayable, so I have to close the game and run it again.

When the slow down issue does not occur, I can play the game fine, with up to two hundred frames per second.
Affichage des commentaires 1 à 7 sur 7
< >
gutigen o) 13 jan 2013 à 8h32 
Distro?
GPU Drivers?
Desktop manager?
Terminal output?
Fred 13 jan 2013 à 8h36 
Linux gutigen o) a écrit :
Distro?

Ubuntu 12.10 64-bit.

Linux gutigen o) a écrit :
GPU Drivers?

AMD HD5850 using the latest beta driver provided by AMD.

Linux gutigen o) a écrit :
Desktop manager?

The default.

Linux gutigen o) a écrit :
Terminal output?

I have no idea how to launch Team Fortress 2 from the terminal.
Dernière modification de Fred; 13 jan 2013 à 8h36
gutigen o) 13 jan 2013 à 9h15 
Turn off Steam, open terminal, paste:
steam steam://rungameid/440
Enter.
Dernière modification de gutigen o); 13 jan 2013 à 9h15
dpc 20 jan 2013 à 7h57 
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.
Dernière modification de dpc; 20 jan 2013 à 8h00
Fred 20 jan 2013 à 10h22 
dpc a écrit :
I can confirm similar issues.

I'm running Ubuntu 12.10 x64 on i7-4420K, 32GB RAM, Radeon HD 7750.

Sometimes (25% of the launch times) the game launches fine, sometimes it's laggy. Like each 0.5 - 1 second there is some temporary slowdown that pauses/slowdowns everything for a short moment.

I've tried lowering graphic and sound settings with no effect. I've also tried running from gnome classical desktop so that compositor is not in effect, but this does not seem to solve it neither.

Launching with

steam steam://rungameid/440

does not change anything it seems but pressing Shift+Tab to access Steam Community in-game seems to help a bit (that was advised by someone on this forum), but not completely it seems.

Exactly. It seems that if I launch the game with there being no load, and me not switching away from the game, it will launch fine. But if I dare to multi-task, even as much as browsing through some web pages, the issue occurs until I restart and try again.
mikesart 28 jan 2013 à 16h08 
Someone posted here:

http://www.reddit.com/r/linux_gaming/comments/17cdj5/tf2_issues_in_ubuntu_1210/

To try this: "try turning off steam community in game in steam settings."

Does that help? And can someone try setting the engine_no_focus_sleep convar to 0 and see if that does anything?

Also, if someone could enter this bug into github I'd appreciate it. Thanks!
dpc 28 jan 2013 à 17h22 
It seems that the game stopped lagging for me after latest steam update. I now have around 5 starts which all went smooth. I need to make sure this is permanent or just a better day.

Also, non of the tricks posted here really helped me before.
Dernière modification de dpc; 28 jan 2013 à 17h25
Affichage des commentaires 1 à 7 sur 7
< >
Par page : 15 30 50