Steam for Linux > 综合讨论 > 主题详情
GamingPenguin [Linux] 2013年1月12日上午8:46
Steam has stopped launching, it worked fine before(SOLVED)
I think it was yesterday there was an update for Steam, when I am trying to start it now, it wont start at all. Its very odd as it has been working very well up until now. I have tried a complete removal in Synaptic, then install and that didn't work. If I run "steam" from a terminal I get
"/usr/bin/steam: line 245: /home/jon/.local/share/Steam/steam.sh: Success" but steam is not open, not on either Unity or KDE. Not there when I open System Monitor either.

Please help, thanks in advance, more details below if they help. oh and Steam works fine on my laptop running Ubuntu 12.10 fully updated.

Ubuntu 12.10
AMD FX(tm)-4100 Quad-Core
8GB Ram
AMD HD6850
Catalyst 12.11 Beta driver
最后由 GamingPenguin [Linux] 编辑于; 2013年1月12日上午8:58
正在显示第 1 - 4 条,共 4 条留言
< >
GamingPenguin [Linux] 2013年1月12日上午8:57 
Ok I have fixed it myself turns out steam.sh was blank somehow????? Failed update I guess. So I deleted steam.sh, the launched Steam and choose reinstall when a warning came up, fixed :D
rudeboyskunk 2013年1月12日下午4:13 
I guess I should have tried that, too. I just decided that since it wouldn't work it was a good time to do a clean install of Ubuntu and changed from 12.04 to 12.10. Now fglrx isn't listed in my "proprietary drivers" list. Go figure.
GamingPenguin [Linux] 2013年1月13日上午2:16 
No 12.10 seems to hide proprietary drivers for AMD crads, there is a reason though the default 12.10 kernel headers are not compatible. Howvere I am running on Ubuntu 12.10 and I strongly reccomend Catalyst 12.11 beta drivers, just follow a guide to install the kernel headers, then the driver itself, works brilliantly for me.
Ninjolai 2013年1月28日上午10:30 
Doing rm -rf ~/.local/share/Steam/steam.sh and pressing Yes to reinstall worked for me too :-)
正在显示第 1 - 4 条,共 4 条留言
< >
每页显示数: 15 30 50
发帖日期: 2013年1月12日上午8:46
帖子数: 4