Steam for Linux > 일반 토론 > 제목 정보
mattyy1hp 2013년 1월 12일 오전 5시 18분
Any solution to TF2 "loading ..." freeze ?
I have this bug more than one month.
It has been already reported: https://github.com/ValveSoftware/steam-for-linux/issues/407

TF2 hangs on "loading ..." after it loads 351.4MB to RAM.
I can't get to main menu. I waited more than 30 minutes, but when it stops loading to RAM at 351.4MB, it's permanently freezed = I have to kill it.
I starts on 15-30 attempt.

This makes the Linux version totally unplayable for me, I don't have more nerves for it - start, kill, start, kill, start kill.... If I want to play it with my friends, I can't, because they are waiting for me 30-45 minutes.

If think it does not happen on AMD 12.10. Anyway I can't downgrade from 12.11 beta11, because my kernel is not supported on 12.10.

So, please, is there any solution?
mattyy1hp님이 마지막으로 수정; 2013년 1월 12일 오전 5시 22분
14개 중 1-14 표시중
< >
instabilis 2013년 1월 12일 오전 7시 35분 
Have you tried updating to the xorg-edgers repository as mentioned on the GitHub comments?
mattyy1hp 2013년 1월 12일 오전 7시 53분 
Yes, I tried it.
This PPA made my system very unstable and AMD drivers and Xserver didn't work.
Maybe I did something wrong or this packages aren't comatible with my distro (LM13).

Is it needed for TF2? I don't want to risk again. ppa-purge saved me.
mattyy1hp님이 마지막으로 수정; 2013년 2월 14일 오전 4시 45분
bane_killgrind 2013년 2월 13일 오후 3시 18분 
This seems to be related to the locale, try editing /etc/local.gen and deleting the # (called a hash) on the en_US.UTF-8 line. then run locale-gen
ryan@RaugMoss:~$ sudo vim /etc/locale.gen
[sudo] password for ryan:
ryan@RaugMoss:~$ sudo locale-gen
Generating locales (this might take a while)...
en_CA.UTF-8... done
en_US.UTF-8... done
Generation complete.
ryan@RaugMoss:~$

this was on debian linux 64bit, testing.
Linux-storma 2013년 2월 13일 오후 5시 41분 
I had the same problem, it gets stuck because a warning window about locales doesn't 'popup' correctly. You can see this if you start in windowed mode.

sudo dpkg-reconfigure locales and add the missing US* locale. It's an alternative way of doing what bane_killgrind mentioned above.
[Linux] Junior s2 Camila 2013년 2월 14일 오전 12시 43분 
Try disabling HDR
mattyy1hp 2013년 2월 14일 오전 4시 42분 
bane_killgrind and storma:

I can try it, but there is no "locale" warning window, look at the screen here: https://github.com/ValveSoftware/steam-for-linux/issues/1219

Junior s2 Camila:

I can't disable it. It's not possible for me to get into the main menu (only on integrated APU = another AMD issue - black screen in all full screen games on Cinnamon).
Maybe I could try switch to integrated APU + MATE = TF2 will start, disable HDR and switch back to dedicated GPU and Cinnamon.



mattyy1hp님이 마지막으로 수정; 2013년 2월 14일 오전 4시 44분
mattyy1hp 2013년 2월 15일 오전 7시 28분 
Ok, I disabled HDR - it's same.

Something similar on CS:Source. Why nobody cares? This should be high priority bug.
Steam for Linux was released ouf of beta too early.
Shark 2013년 2월 15일 오전 7시 44분 
catalyst 13.1?
mattyy1hp 2013년 2월 15일 오전 8시 05분 
Wouter님이 먼저 게시:
catalyst 13.1?

Yes. But same issue on 12.10 and 12.11beta11.
mattyy1hp님이 마지막으로 수정; 2013년 2월 15일 오전 8시 07분
Shark 2013년 2월 15일 오전 8시 08분 
Have you tried 13.1 legacy, if you have an amd 4000 series or older it is not supported by any other drivers after 12.6 legacy.
Shark님이 마지막으로 수정; 2013년 2월 15일 오전 8시 08분
mattyy1hp 2013년 2월 15일 오전 8시 14분 
No, I have integrated APU 6520G and dedicated 6470M GPU - both are supported.
This is not happening on integrated 6520G, only on the dedicated GPU.

I wrote more details about it here:
https://github.com/ValveSoftware/steam-for-linux/issues/1219
pepe33l 2013년 3월 1일 오후 2시 56분 
This has been moved to: https://github.com/ValveSoftware/Source-1-Games/issues/102
If you have the same bug (and same or similar hardware: AMD APU+dede GPU), please report there, so we can add a bit of pressure...
Also, this post: http://steamcommunity.com/app/221410/discussions/0/864957182847070880/ is related to the same problem.
mattyy1hp 2013년 3월 1일 오후 3시 26분 
This ( https://github.com/ValveSoftware/Source-1-Games/issues/102 ) is my bug report :)
Someone just moved it elsewhere and it's not asscociated to my nickname anymore (sad, it's my major issue - i'm forced to AMD integrated APU = blackscreen on Cinnamon = forced to Gnome 3 = f*ck you, AMD!)
Also reported here to AMD - http://devgurus.amd.com/message/1286557#1286557
mattyy1hp님이 마지막으로 수정; 2013년 3월 1일 오후 3시 33분
14개 중 1-14 표시중
< >
페이지당: 15 30 50
게시된 날짜: 2013년 1월 12일 오전 5시 18분
게시글: 14