Radish Jan 9, 2013 @ 5:49pm
Team Fortress 2 - Server Connection
Hi all

Since updating steam i can successfully start tf2 and i get the first menu of the game. But when I try to start a match or view servers I get the error message. "There was a problem connecting to steam servers. Please ensure that you are logged in and try again."

when I try to view servers manually none show up. Does anyone know how to fix this problem and what is causing it?
Showing 1-9 of 9 comments
< >
sounds like a wooosh Jan 9, 2013 @ 5:51pm 
Probably the update. - if you look at the threads before your post - they have similar descriptions :(
Radish Jan 9, 2013 @ 5:52pm 
Ubuntu Release 12.04 (precise) 64-bit
Kernel Linux 3.2.0-34-generic
GNOME 3.4.2

Ram: 7.8 GB
CPU: AMD Phenom(tm) 8450 Triple-Core Processor × 3
Last edited by Radish; Jan 9, 2013 @ 5:53pm
Radish Jan 9, 2013 @ 5:54pm 
sorry but i tried searching for tf2 and the error message but only found one other thread with no clear answers so i thought i would try again.
Radish Jan 9, 2013 @ 6:38pm 
i have some error messagesfrom running steam from terminal.

(hl2_linux:3834): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
Gtk-Message: Failed to load module "canberra-gtk-module"
[0109/202956:ERROR:resource_bundle.cc(411)] Failed to load /home/radish/.local/share/Steam/SteamApps/redslash_/Team Fortress 2/cef_gtk.pak
Some features may not be available.
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 2100 MHz, Processor: AuthenticAMD
GlobalMemoryStatus: 4294967295
CShaderDeviceMgrBase::GetRecommendedConfigurationInfo: CPU speed: 2100 MHz, Processor: AuthenticAMD
GlobalMemoryStatus: 4294967295
[0109/202956:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
IDirect3DDevice9::Create: BackBufWidth: 1680, BackBufHeight: 1050, D3DFMT: 3, BackBufCount: 1, MultisampleType: 0, MultisampleQuality: 0
Loaded program cache file "glbaseshaders.cfg", total keyvalues: 266, total successfully linked: 266
Loaded program cache file "glshaders.cfg", total keyvalues: 266, total successfully linked: 266
Precache: Took 2166 ms, Vertex 864, Pixel 1367
Game.so loaded for "Team Fortress"
Setting breakpad minidump AppID = 440
Forcing breakpad minidump interfaces to load
Looking up breakpad interfaces from steamclient
Calling BreakpadMiniDumpSystemInit
Installing breakpad exception handler for appid(440)/version(5153_client)
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

I am looking for this file in particular "cef_gtk.pak". What I find strange is the requirement of steamclient.dll.

but I will search for it and probably get it from the windows version of steam and copy it into places where it could obviously be found.

Radish Jan 9, 2013 @ 6:42pm 
updating my os didn't fix the problem I will try to update steam or reinstall it after I try some things.
Junior s2 Camila Jan 9, 2013 @ 7:01pm 
Originally posted by Radish:
updating my os didn't fix the problem I will try to update steam or reinstall it after I try some things.
I'd recomend removing everything related.

apt-get remove --purge steam
apt-get remove --purge ia32-libs (IF you have installed)

Then go to your home folder, press CTRL+H, go to /share/ and delete the Steam folder. I Think you can also delete de .Steam folder in your home folder.

Then re-install everything back again.
FranzeR225 Feb 20, 2013 @ 1:43pm 
I am having the same problem with windows
Walter937 Dah Comunist Guy Jun 15, 2013 @ 10:43pm 
It means i got the game in spanish and it is in english and i got this problem too D:
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Jan 9, 2013 @ 5:49pm
Posts: 9