Steam for Linux

Steam for Linux

Steam for Linux > 総合掲示板 > トピックの詳細
[Bug]Steam reboots instead of shutting down
I'm having a weird bug since today's update. Whenever I click Steam->Exit steam closes but then immediately restarts... Am I the only one experiencing this issue ?
< >
1-15 / 15 のコメントを表示
I'm having it too.
dasm 2013年1月9日 12時19分 
Here the same. Steam quits in second attempt. First time it restarts
I believe this issue has been reported already

https://github.com/ValveSoftware/steam-for-linux/issues/605
Only happened once for me too. Not a problem now.
Yea last night steam update really rustled some jimmys
Well I spoke too early, it still does sometimes restart after exit lol
It seems that Steam likes our Linux machines so much, he just refuse to go away :)
1. Starting steam. It installs some updates(yes, every time). Then I starting the game(Killing Floor, for instance), and got
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

and see that:
user@comp ~/.steam $ ls -l
total 8
lrwxrwxrwx 1 user user 24 jan. 10 16:26 bin -> /home/user/.steam/bin32
lrwxrwxrwx 1 user user 35 jan. 10 16:26 bin32 -> /home/user/.steam/root/ubuntu12_32
lrwxrwxrwx 1 user user 35 jan. 10 16:26 bin64 -> /home/user/.steam/root/ubuntu12_64
-rw-r--r-- 1 user user 1125 jan. 10 16:26 registry.vdf
lrwxrwxrwx 1 user user 23 jan. 10 16:36 root -> /home/user/.steam/root
-rw-r--r-- 1 user user 0 jan. 10 16:26 starting
lrwxrwxrwx 1 user user 23 jan. 10 16:26 steam -> /home/user/.steam/root
-rw-r--r-- 1 user user 6 jan. 10 16:26 steam.pid
prw------- 1 user user 0 jan. 10 16:26 steam.pipe
(lots of broken symlinks)

I shutdown steam client. Immediately it restarts, installs something again, and work nice..in .steam I can see
user@comp ~/.steam $ ls -l
total 8
lrwxrwxrwx 1 user user 24 jan. 10 16:37 bin -> /home/user/.steam/bin32
lrwxrwxrwx 1 user user 42 jan. 10 16:37 bin32 -> /home/user/.local/share/Steam/ubuntu12_32
lrwxrwxrwx 1 user user 42 jan. 10 16:37 bin64 -> /home/user/.local/share/Steam/ubuntu12_64
-rw-r--r-- 1 user user 1125 jan. 10 16:37 registry.vdf
lrwxrwxrwx 1 user user 30 jan. 10 16:37 root -> /home/user/.local/share/Steam
-rw-r--r-- 1 user user 0 jan. 10 16:37 starting
lrwxrwxrwx 1 user user 30 jan. 10 16:37 steam -> /home/user/.local/share/Steam
-rw-r--r-- 1 user user 6 jan. 10 16:37 steam.pid
prw------- 1 user user 0 jan. 10 16:37 steam.pipe

Bad wrapper script? Or something like that?
Just to confirm that this happens to me too, pretty much everytime, though will close properly on the 2nd run. Kubuntu 12.04
same here. ubuntu 12.04 LTS 32 Bit. could get more worse :P
confirmed: Ubuntu 12.10 64bit (Unity)
Also confirming. It's like Stream fails to start up properly, and needs the restart to find itself.
Stolid 2013年1月11日 18時22分 
I also have the same problem as zapolz. Killing Floor claims no internet until I close Steam and run it again (which Steam does automatically after clicking exit...strange).
Fixed in today's update.
< >
1-15 / 15 のコメントを表示
ページ毎: 15 30 50

Steam for Linux > 総合掲示板 > トピックの詳細
投稿日: 2013年1月9日 12時13分
投稿数: 15