Steam for Linux > Γενικές συζητήσεις > Λεπτομέρειες θέματος
Schnabeltier mutter 9 Ιαν, 2013 @ 12:13μμ
[Bug]Steam reboots instead of shutting down
I'm having a weird bug since today's update. Whenever I click Steam->Exit steam closes but then immediately restarts... Am I the only one experiencing this issue ?
Εμφάνιση 1-15 από 15 σχόλια
< >
sounds like a wooosh 9 Ιαν, 2013 @ 12:16μμ 
no
Cheogh 9 Ιαν, 2013 @ 12:18μμ 
I'm having it too.
dasm 9 Ιαν, 2013 @ 12:19μμ 
Here the same. Steam quits in second attempt. First time it restarts
Tweakedenigma 9 Ιαν, 2013 @ 12:24μμ 
I believe this issue has been reported already

https://github.com/ValveSoftware/steam-for-linux/issues/605
Rain Ninja 9 Ιαν, 2013 @ 2:54μμ 
Only happened once for me too. Not a problem now.
icecoldhaterade \\DzG// 9 Ιαν, 2013 @ 3:28μμ 
Yea last night steam update really rustled some jimmys
Rain Ninja 9 Ιαν, 2013 @ 5:40μμ 
Well I spoke too early, it still does sometimes restart after exit lol
gutigen o) 9 Ιαν, 2013 @ 8:55μμ 
It seems that Steam likes our Linux machines so much, he just refuse to go away :)
DHIWE_CPAHOE 9 Ιαν, 2013 @ 9:58μμ 
1. Starting steam. It installs some updates(yes, every time). Then I starting the game(Killing Floor, for instance), and got
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

and see that:
user@comp ~/.steam $ ls -l
total 8
lrwxrwxrwx 1 user user 24 jan. 10 16:26 bin -> /home/user/.steam/bin32
lrwxrwxrwx 1 user user 35 jan. 10 16:26 bin32 -> /home/user/.steam/root/ubuntu12_32
lrwxrwxrwx 1 user user 35 jan. 10 16:26 bin64 -> /home/user/.steam/root/ubuntu12_64
-rw-r--r-- 1 user user 1125 jan. 10 16:26 registry.vdf
lrwxrwxrwx 1 user user 23 jan. 10 16:36 root -> /home/user/.steam/root
-rw-r--r-- 1 user user 0 jan. 10 16:26 starting
lrwxrwxrwx 1 user user 23 jan. 10 16:26 steam -> /home/user/.steam/root
-rw-r--r-- 1 user user 6 jan. 10 16:26 steam.pid
prw------- 1 user user 0 jan. 10 16:26 steam.pipe
(lots of broken symlinks)

I shutdown steam client. Immediately it restarts, installs something again, and work nice..in .steam I can see
user@comp ~/.steam $ ls -l
total 8
lrwxrwxrwx 1 user user 24 jan. 10 16:37 bin -> /home/user/.steam/bin32
lrwxrwxrwx 1 user user 42 jan. 10 16:37 bin32 -> /home/user/.local/share/Steam/ubuntu12_32
lrwxrwxrwx 1 user user 42 jan. 10 16:37 bin64 -> /home/user/.local/share/Steam/ubuntu12_64
-rw-r--r-- 1 user user 1125 jan. 10 16:37 registry.vdf
lrwxrwxrwx 1 user user 30 jan. 10 16:37 root -> /home/user/.local/share/Steam
-rw-r--r-- 1 user user 0 jan. 10 16:37 starting
lrwxrwxrwx 1 user user 30 jan. 10 16:37 steam -> /home/user/.local/share/Steam
-rw-r--r-- 1 user user 6 jan. 10 16:37 steam.pid
prw------- 1 user user 0 jan. 10 16:37 steam.pipe

Bad wrapper script? Or something like that?
Footissimo 10 Ιαν, 2013 @ 11:02μμ 
Just to confirm that this happens to me too, pretty much everytime, though will close properly on the 2nd run. Kubuntu 12.04
vargablood 11 Ιαν, 2013 @ 12:00πμ 
same here. ubuntu 12.04 LTS 32 Bit. could get more worse :P
gutigen o) 11 Ιαν, 2013 @ 12:46πμ 
confirmed: Ubuntu 12.10 64bit (Unity)
[Linux] DGFone 11 Ιαν, 2013 @ 5:36μμ 
Also confirming. It's like Stream fails to start up properly, and needs the restart to find itself.
Stolid 11 Ιαν, 2013 @ 6:22μμ 
I also have the same problem as zapolz. Killing Floor claims no internet until I close Steam and run it again (which Steam does automatically after clicking exit...strange).
[Linux] timopm 12 Ιαν, 2013 @ 3:15πμ 
Fixed in today's update.
Εμφάνιση 1-15 από 15 σχόλια
< >
Ανά σελίδα: 15 30 50
Ημ/νία ανάρτησης: 9 Ιαν, 2013 @ 12:13μμ
Αναρτήσεις: 15