suavestag 8. jan, 2013 @ 11:42pm
Steam Fedora Repo?
I know that the spot repo went down, but now the "new" repo isn't working either...

Anyone in the same boat?
Viser 1-15 av 20 kommentarer
< >
maci 9. jan, 2013 @ 7:22am 
made a repo for f16, f17 and f18

cd /etc/yum.repos.d/ &&wget http://maci.satgnu.net/fedora-steam/fedora-steam.repo &&yum install steam
Sist redigert av maci; 9. jan, 2013 @ 7:23am
suavestag 9. jan, 2013 @ 1:58pm 
Is that the only one available?

Any news as to when an official one may come out?
Junior s2 Camila 9. jan, 2013 @ 4:00pm 
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs
suavestag 9. jan, 2013 @ 10:52pm 
cheers
maci 10. jan, 2013 @ 2:40am 
Opprinnelig skrevet av Linux Junior s2 Camila:
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
Junior s2 Camila 10. jan, 2013 @ 8:08am 
Opprinnelig skrevet av maci:
Opprinnelig skrevet av Linux Junior s2 Camila:
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.
Аладор 10. jan, 2013 @ 8:35am 
Opprinnelig skrevet av Linux Junior s2 Camila:
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared
Qydfac 10. jan, 2013 @ 12:39pm 
Opprinnelig skrevet av Аладор:
Opprinnelig skrevet av Linux Junior s2 Camila:
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared

The OpenSUSE team have removed the Steam package indefinitely, beacuse of GPL licensing.
arc| Gps 10. jan, 2013 @ 4:05pm 
The next part is picked from git hub.
There seem to be questions about the licence.

Something about converting the deb to an rpm as far as I understand it.

quote:
I have been in contact with the steam engineers and lawyers ever since I originally put steam in the repositories for Arch Linux.

The license allow packages to re distribute should be finished in the next week or too.

https://github.com/ValveSoftware/steam-for-linux/issues/13#issuecomment-12048792
maci 12. jan, 2013 @ 2:03pm 
i updated the packages in my repo to steam version 1.0.0.21

this should fix the annoying message which tells us to upgrade
Sist redigert av maci; 12. jan, 2013 @ 2:03pm
Cheeseness 12. jan, 2013 @ 3:13pm 
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
PulkaSkurken 12. jan, 2013 @ 4:20pm 
Opprinnelig skrevet av Cheeseness:
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
dosent work for me, get the same "error" msg as the other URLś in this thread, iam also using Fedora 17 and would be so happy to try this. :)
d3athsd00r 12. jan, 2013 @ 8:41pm 
Everytime I try to install steam from here it tells me I need libpng12 but I already have both the i686 and x86_64 versions of libpng-compat installed.

Any help?
instabilis 13. jan, 2013 @ 3:39am 
Try

yum list libpng*

Which packages are listed as installed? I think you need more than just libpng-compat.i686
Sist redigert av instabilis; 13. jan, 2013 @ 3:43am
d3athsd00r 13. jan, 2013 @ 11:34am 
I just installed all the libpng packages and it still doesn't work. :(

Installed Packages
libpng.i686
libpng.x86_64
libpng-compat.i686
libpng-compat.x86_64
libpng-devel.i686
libpng-devel.x86_64
libpng-static.x86_64
libpng10.i686
libpng10.x86_64
libpng10-devel.i686
libpng10-devel.x86_64

There error i get is:

Error: Package: steam-1.0.0.21-1.fc18.x86_64 (fedora-steam)
Requires: libpng12(x86-32) >= 1.2.13

I had version 1.0.0.18 installed fine but now it won't install .21 for some reason.


***EDIT***
just noticed that there is no fc17 package, it is trying to install fc18, so I forced the fc16 and it is working now.
Sist redigert av d3athsd00r; 13. jan, 2013 @ 11:41am
Viser 1-15 av 20 kommentarer
< >
Per side: 15 30 50
Dato lagt ut: 8. jan, 2013 @ 11:42pm
Innlegg: 20