Steam for Linux > 一般的な話題 > トピックの詳細
suavestag 2013年1月8日 23時42分
Steam Fedora Repo?
I know that the spot repo went down, but now the "new" repo isn't working either...

Anyone in the same boat?
1-15 / 20 のコメントを表示
< >
maci 2013年1月9日 7時22分 
made a repo for f16, f17 and f18

cd /etc/yum.repos.d/ &&wget http://maci.satgnu.net/fedora-steam/fedora-steam.repo &&yum install steam
最近の変更はmaciが行いました; 2013年1月9日 7時23分
suavestag 2013年1月9日 13時58分 
Is that the only one available?

Any news as to when an official one may come out?
[Linux] Junior s2 Camila 2013年1月9日 16時00分 
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs
suavestag 2013年1月9日 22時52分 
cheers
maci 2013年1月10日 2時40分 
Linux Junior s2 Camila の投稿を引用:
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
[Linux] Junior s2 Camila 2013年1月10日 8時08分 
maci の投稿を引用:
Linux Junior s2 Camila の投稿を引用:
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.
Аладор 2013年1月10日 8時35分 
Linux Junior s2 Camila の投稿を引用:
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared
Qydfac 2013年1月10日 12時39分 
Аладор の投稿を引用:
Linux Junior s2 Camila の投稿を引用:
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared

The OpenSUSE team have removed the Steam package indefinitely, beacuse of GPL licensing.
arc| Gps 2013年1月10日 16時05分 
The next part is picked from git hub.
There seem to be questions about the licence.

Something about converting the deb to an rpm as far as I understand it.

quote:
I have been in contact with the steam engineers and lawyers ever since I originally put steam in the repositories for Arch Linux.

The license allow packages to re distribute should be finished in the next week or too.

https://github.com/ValveSoftware/steam-for-linux/issues/13#issuecomment-12048792
maci 2013年1月12日 14時03分 
i updated the packages in my repo to steam version 1.0.0.21

this should fix the annoying message which tells us to upgrade
最近の変更はmaciが行いました; 2013年1月12日 14時03分
Cheeseness 2013年1月12日 15時13分 
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
PulkaSkurken 2013年1月12日 16時20分 
Cheeseness の投稿を引用:
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
dosent work for me, get the same "error" msg as the other URLś in this thread, iam also using Fedora 17 and would be so happy to try this. :)
d3athsd00r 2013年1月12日 20時41分 
Everytime I try to install steam from here it tells me I need libpng12 but I already have both the i686 and x86_64 versions of libpng-compat installed.

Any help?
instabilis 2013年1月13日 3時39分 
Try

yum list libpng*

Which packages are listed as installed? I think you need more than just libpng-compat.i686
最近の変更はinstabilisが行いました; 2013年1月13日 3時43分
d3athsd00r 2013年1月13日 11時34分 
I just installed all the libpng packages and it still doesn't work. :(

Installed Packages
libpng.i686
libpng.x86_64
libpng-compat.i686
libpng-compat.x86_64
libpng-devel.i686
libpng-devel.x86_64
libpng-static.x86_64
libpng10.i686
libpng10.x86_64
libpng10-devel.i686
libpng10-devel.x86_64

There error i get is:

Error: Package: steam-1.0.0.21-1.fc18.x86_64 (fedora-steam)
Requires: libpng12(x86-32) >= 1.2.13

I had version 1.0.0.18 installed fine but now it won't install .21 for some reason.


***EDIT***
just noticed that there is no fc17 package, it is trying to install fc18, so I forced the fc16 and it is working now.
最近の変更はd3athsd00rが行いました; 2013年1月13日 11時41分
1-15 / 20 のコメントを表示
< >
ページ毎: 15 30 50
投稿日: 2013年1月8日 23時42分
投稿数: 20