suaveswerve 8 jan 2013 à 23h42
Steam Fedora Repo?
I know that the spot repo went down, but now the "new" repo isn't working either...

Anyone in the same boat?
Affichage des commentaires 1 à 15 sur 20
< >
maci 9 jan 2013 à 7h22 
made a repo for f16, f17 and f18

cd /etc/yum.repos.d/ &&wget http://maci.satgnu.net/fedora-steam/fedora-steam.repo &&yum install steam
Dernière modification de maci; 9 jan 2013 à 7h23
suaveswerve 9 jan 2013 à 13h58 
Is that the only one available?

Any news as to when an official one may come out?
[Linux] Junior s2 Camila 9 jan 2013 à 16h00 
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs
suaveswerve 9 jan 2013 à 22h52 
cheers
maci 10 jan 2013 à 2h40 
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
[Linux] Junior s2 Camila 10 jan 2013 à 8h08 
maci a écrit :
The Fedora repo is the same as the openSUSE one.

http://software.opensuse.org/package/steam

It installs all dependencies it needs

just that it says



Package steam not found...


and when it still worked it didnt have packages for fedora18
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.
Аладор 10 jan 2013 à 8h35 
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared
Qydfac 10 jan 2013 à 12h39 
Аладор a écrit :
It's there, but not right now. I guess they are updating all packages, since Steam updated a couple of days back. Should be up in a few hours.

I am the second day already I come on opensuse, but steam packages have not yet appeared

The OpenSUSE team have removed the Steam package indefinitely, beacuse of GPL licensing.
arc| Gps 10 jan 2013 à 16h05 
The next part is picked from git hub.
There seem to be questions about the licence.

Something about converting the deb to an rpm as far as I understand it.

quote:
I have been in contact with the steam engineers and lawyers ever since I originally put steam in the repositories for Arch Linux.

The license allow packages to re distribute should be finished in the next week or too.

https://github.com/ValveSoftware/steam-for-linux/issues/13#issuecomment-12048792
maci 12 jan 2013 à 14h03 
i updated the packages in my repo to steam version 1.0.0.21

this should fix the annoying message which tells us to upgrade
Dernière modification de maci; 12 jan 2013 à 14h03
Cheeseness 12 jan 2013 à 15h13 
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
PulkaSkurken 12 jan 2013 à 16h20 
Cheeseness a écrit :
Spot's one is back up if anybody needs it: http://spot.fedorapeople.org/steam/steam.repo
dosent work for me, get the same "error" msg as the other URLś in this thread, iam also using Fedora 17 and would be so happy to try this. :)
d3athsd00r 12 jan 2013 à 20h41 
Everytime I try to install steam from here it tells me I need libpng12 but I already have both the i686 and x86_64 versions of libpng-compat installed.

Any help?
instabilis 13 jan 2013 à 3h39 
Try

yum list libpng*

Which packages are listed as installed? I think you need more than just libpng-compat.i686
Dernière modification de instabilis; 13 jan 2013 à 3h43
d3athsd00r 13 jan 2013 à 11h34 
I just installed all the libpng packages and it still doesn't work. :(

Installed Packages
libpng.i686
libpng.x86_64
libpng-compat.i686
libpng-compat.x86_64
libpng-devel.i686
libpng-devel.x86_64
libpng-static.x86_64
libpng10.i686
libpng10.x86_64
libpng10-devel.i686
libpng10-devel.x86_64

There error i get is:

Error: Package: steam-1.0.0.21-1.fc18.x86_64 (fedora-steam)
Requires: libpng12(x86-32) >= 1.2.13

I had version 1.0.0.18 installed fine but now it won't install .21 for some reason.


***EDIT***
just noticed that there is no fc17 package, it is trying to install fc18, so I forced the fc16 and it is working now.
Dernière modification de d3athsd00r; 13 jan 2013 à 11h41
Affichage des commentaires 1 à 15 sur 20
< >
Par page : 15 30 50