CaptainSarcastic Jan 6, 2013 @ 1:27am
Can't launch TF 2 - getting OpenGL error
I'm getting:

Could not find required OpenGL entry point 'glGetError'
You seem to have version 1.4 installed, and you need >2.0

I'm running openSUSE 12.2 64-bit KDE, and have installed the beta 313.09 Nvidia drivers for my GTX 460 v2 GPU. Other OpenGL games and apps work just fine, and according to glxinfo I have OpenGL version 4.3.0 from Nvidia.

I can play World of Goo and Amnesia just fine from Steam, but TF2 will not launch because of the above error. I've been searching a lot on this, but have found no clear answer on how to go forward. Like I said, I already installed the latest drivers, and my system is completely up to date.

Thanks for any help anyone can give.
Showing 1-15 of 16 comments
< >
bobebubab Jan 6, 2013 @ 1:29am 
+1
gutigen o) Jan 6, 2013 @ 1:47am 
Did you install NVIDIA drivers manually? In Ubuntu manual installation very often creates same problem, using drivers from repositories (official or xswat) fixed it. If that's the case and OpenSuse repos provide at least 310.x drivers, try them.
Last edited by gutigen o); Jan 6, 2013 @ 1:47am
CaptainSarcastic Jan 6, 2013 @ 1:54am 
I didn't install the blob from Nvidia - I installed through openSUSE repos. OpenGL works great for everything but TF2.
CaptainSarcastic Jan 6, 2013 @ 1:31pm 
Bumping this question up
JonesyBarber Jan 6, 2013 @ 2:25pm 
After trying a few other approached – and at least one reinstallation of Ubuntu 12.04, I found the following post to be very helpful.
http://www.reddit.com/r/linux_gaming/comments/13jukj/how_to_fix_atiamd_tf2_black_screen_for_ubuntu/
CaptainSarcastic Jan 6, 2013 @ 2:40pm 
I have an Nvidia card, and I'm not running Ubuntu. I don't see how that post relates to my issue.
gutigen o) Jan 6, 2013 @ 2:48pm 
Try to install drivers from geforce.com.
[Linux] Junior s2 Camila Jan 7, 2013 @ 11:54am 
Originally posted by Linux gutigen o):
Did you install NVIDIA drivers manually? In Ubuntu manual installation very often creates same problem, using drivers from repositories (official or xswat) fixed it. If that's the case and OpenSuse repos provide at least 310.x drivers, try them.
openSUSE for me provides 304.64, so I manually isntall 310.19 and works great, even better perfornance:

openSUSE + manual 310.19 + 3.0GHz processor clock = 100%
Ubuntu + repo drivers (310.14) + 3.6GHz = 60% (compared to openSUSE)

Of course it's not the system, it's the driver. But manual install = steam.so crash, which means removing all packages and steam. But then when I lanuch TF2 this openGL error appears.
CaptainSarcastic Jan 7, 2013 @ 5:38pm 
Is there a command to launch TF2 without the OpenGL check? Since I do, in fact, have OpenGL installed and working properly with the Nvidia drivers, it seems that whatever check TF2 is doing is not returning the correct information.
mikomikonurse Jan 7, 2013 @ 6:32pm 
Have you had a look at this and trying to transpose it to OpenSuse?

https://wiki.archlinux.org/index.php/Steam#glGetError_message_on_startup
Knot Even Close Jan 8, 2013 @ 5:09pm 
Originally posted by CaptainSarcastic:
I'm getting:

Could not find required OpenGL entry point 'glGetError'
You seem to have version 1.4 installed, and you need >2.0

Thanks for any help anyone can give.

Hello, I am running Fedora, and not OpenSuSE, but I had the same issue with TF2. In order to get it to run on a 64 bit system, I also had to install the 32bit Nvidia libraries. On fedora this is the xorg-x11-drv-nvidia-libs-304.64-3.fc17.i686 package.

CaptainSarcastic Jan 9, 2013 @ 12:36am 
Thanks, I'll give that a try next. Tried removing the Noubeau driver, but still no joy at this point.
thrift Jan 13, 2013 @ 8:06pm 
I am on Fedora 64 bit using the nvidia driver from rpmfusion.

Installing the 32 bit nvidia libraries fixed this problem for me as well.

Command line: sudo yum install xorg-x11-drv-nvidia-libs.i686
Exagone313 May 15, 2013 @ 9:58am 
They is a deb version of this package (I have Ubuntu 12.04 x64) ?
CaptainSarcastic Jun 7, 2013 @ 5:35pm 
Installed the stock Nvidia drivers from the repos and all is good - sorry I didn't update this previously.
Showing 1-15 of 16 comments
< >
Per page: 15 30 50
Date Posted: Jan 6, 2013 @ 1:27am
Posts: 16