Funky Cat msw1 1 jan 2013 à 19h49
[SOLVED] "You appear to have OpenGL 1.4.0, but we need at least 2.0.0!"
NOTE: If you have this error, I fixed it by re-installing my OS. I know that's depressing, and hopefully there is another way, but it worked for me!




Hi. I am using Ubuntu 12.10. I get a "Could not find required OpenGL entry point 'glGetError'!
Either your graphics card is unsupported, or your OpenGL driver needs to be updated.

I have a ATI Radeon HD 6670 and am using AMD catalyst 12.11.

Here is a log copied from console of launching steam and trying to run Team Fortress 2.





msw1@msw1-System-Product-Name:~/Downloads$ /usr/bin/steam %U
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
unlinked 0 orphaned pipes
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Gtk-Message: Failed to load module "overlay-scrollbar"
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",

(steam:15396): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
surface_linux.cpp (1383) : Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...

Assert( Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...
):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/vgui2/src/surface_linux.cpp:1383

Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Gtk-Message: Failed to load module "canberra-gtk-module"
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130101194230_1.dmp
[0101/194230:WARNING:proxy_service.cc(646)] PAC support disabled because there is no system implementation
success = yes
response: CrashID=bp-e2e58bc5-c2a9-49e7-8abe-5aacf2130101
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Generating new string page texture 2: 48x256, total string texture memory is 49.15 KB
Generating new string page texture 3: 256x256, total string texture memory is 311.30 KB
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Adding license for package 515
Adding license for package 8183
Adding license for package 8538
Adding license for package 12373
Adding license for package 469
Adding license for package 218
Adding license for package 12114
Adding license for package 11734
Adding license for package 14842
Adding license for package 34
Adding license for package 13523
Adding license for package 2481
Adding license for package 14337
Adding license for package 2644
Adding license for package 13191
Adding license for package 7877
Adding license for package 13435
Adding license for package 13674
Adding license for package 17642
Adding license for package 17250
Adding license for package 37
Adding license for package 994
Adding license for package 8186
Adding license for package 18203
Adding license for package 15933
Adding license for package 3083
Adding license for package 14107
Adding license for package 0
roaming config store loaded successfully - 4450 bytes.
migrating temporary roaming config store
ExecCommandLine: "/home/msw1/.local/share/Steam/ubuntu12_32/steam %U"
Generating new string page texture 72: 1024x256, total string texture memory is 1.36 MB
Generating new string page texture 73: 128x256, total string texture memory is 1.49 MB
Generating new string page texture 74: 128x256, total string texture memory is 131.07 KB
Generating new string page texture 75: 64x256, total string texture memory is 1.56 MB
Generating new string page texture 76: 8x256, total string texture memory is 1.56 MB
Generating new string page texture 77: 32x256, total string texture memory is 1.60 MB
Generating new string page texture 90: 128x256, total string texture memory is 1.73 MB
Generating new string page texture 92: 384x256, total string texture memory is 2.12 MB
Generating new string page texture 93: 256x256, total string texture memory is 2.38 MB
System startup time: 18.05 seconds
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
ExecSteamURL: "steam://open/driverhelperready"
Game update: AppID 440 "Team Fortress 2", ProcID 15482, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
SDL video target is 'x11'
SDL video target is 'x11'
SDL failed to create GL compatibility profile (whichProfile=0!
PROBLEM: You appear to have OpenGL 1.4.0, but we need at least 2.0.0!
Could not find required OpenGL entry point 'glGetError'! Either your video card is unsupported, or your OpenGL driver needs to be updated.
Game removed: AppID 440 "Team Fortress 2", ProcID 15482
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Dernière modification de Funky Cat msw1; 2 jan 2013 à 22h56
Affichage des commentaires 1 à 11 sur 11
< >
RobbieThe1st [Linux] 1 jan 2013 à 19h58 
Run 'glxinfo', and paste the first five lines here.
If you don't have it, it's in package 'mesa-utils'.
Dernière modification de RobbieThe1st [Linux]; 1 jan 2013 à 19h58
Jidea 1 jan 2013 à 20h00 
i think you have a 64 bits OS and you forgot to install 32 bits libs for xorg-catalyst (sorry i don't know the name on ubuntu, i use fedora)
Funky Cat msw1 1 jan 2013 à 20h02 
Run 'glxinfo', and paste the first five lines here.
If you don't have it, it's in package 'mesa-utils'.

I did not have it.

name of display: :0.0
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
display: :0 screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Those are the first five lines.

Thanks so much for the quick reply.
Funky Cat msw1 1 jan 2013 à 20h03 
Jidea a écrit :
i think you have a 64 bits OS and you forgot to install 32 bits libs for xorg-catalyst (sorry i don't know the name on ubuntu, i use fedora)
That is likely the answer. I am using a 64-bit OS and installed no additional software for steam. If anyone knows what the libs are called I would greatly appreciate it.

Thank you for a quick reply.


*EDIT* Did "sudo apt-get install libgl1-mesa-glx:i386". It said I already had it.
Dernière modification de Funky Cat msw1; 1 jan 2013 à 20h36
8 Dimensional Octagon 2 jan 2013 à 14h26 
I think it is fglrx-amdcc(c?)le. Also, use fglrxinfo instead of glxinfo with the proprietary drivers.
Funky Cat msw1 2 jan 2013 à 18h36 
fglrxinfo:


msw1@msw1-System-Product-Name:~$ fglrxinfo
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: AMD Radeon HD 6670
OpenGL version string: 1.4 (2.1 (4.2.11995 Compatibility Profile Context))

I also did the verbose information if it's helpful.

http://pastebin.com/JEqeuZad

Sorry that it's incredibly long.
RobbieThe1st [Linux] 2 jan 2013 à 19h37 
Well, the fact that it's saying 'failed to load driver', and is trying to load the 'swrast' or SoftWare RASTerizer driver means that your AMD driver isn't correctly installed - OpenGL is still trying to be run on your CPU only, and components to even do that is missing.
Try going a reinstall of the AMD driver.

Also, until 'glxgears' brings up a small window with three spinning gears(one red, one blue, one green), you've not a chance of getting any Steam games working.
Dernière modification de RobbieThe1st [Linux]; 2 jan 2013 à 19h38
Funky Cat msw1 2 jan 2013 à 20h10 
I can play Killing Floor and Dungeons of Dredmor. 'glxgears' does bring up all three of the colored gears. I'll make sure my BIOS is running off my graphics card, and then re-install the driver. Will using --force work?
Funky Cat msw1 2 jan 2013 à 22h07 
I am having so many problems with Ubuntu ATM, I'm going to re-install my OS and see if it works then.
supermariolinux 2 jan 2013 à 22h18 
Try running this in the terminal with no quotes: "export LD_LIBRARY_PATH=/usr/lib32:/usr/lib/i386-linux-gnu/mesa:$LD_LIBRARY_PATH/usr/bin/steam:~/.steam/bin32" then run steam (type steam). If it works then you are going to want to add it to your .bashrc configuartion file. just do this with out the outer quotes : "echo "alias steam=''export LD_LIBRARY_PATH=/usr/lib32:/usr/lib/i386-linux-gnu/mesa:$LD_LIBRARY_PATH/usr/bin/steam:~/.steam/bin32 && steam'" >> .bashrc" then run a new terminal and just type steam and it should work (assuming you have your graphics libraies and 32-bit librarues installed properly).
Funky Cat msw1 2 jan 2013 à 22h37 
I re-installed my OS and everything and I think it works! Unity was broken anyway beyond repair so I had to do this eventually anyway. I haven't installed steam yet, but fglrxinfo doesn't error anymore and it says I have version 4.2 of OpenGL. Thank you to everyone who has helped me! :)
Affichage des commentaires 1 à 11 sur 11
< >
Par page : 15 30 50