[Linux] Junior s2 Camila Jan 1, 2013 @ 4:12pm
Should I get another distro?
Hi everyone. I'm having some issues regarding Steam on Linux + Ubuntu 12.04.1 64bit.

If I install the proprietary drivers (that one recomended) everything works fine. Steam installs and I can play TF2. But on the game there are a couple if issues regarding game freezing, low fps rate and etc, so I decided to download the 310.19 version from nvidia.com, but after the install everything gets screwd up and I think Steam has something to do with it, and will explain now:

  • With proprietary drivers installed before Steam.deb, Steam works fine, but the game crashes and freezes at some points, except when on Windowed mode.

  • With the driver installed from the .run from nvidia.com BEFORE Steam.deb, Steam won't load (Failed to load steamui.so), but the driver works fine.

  • With the driver installed from the .run from nvidia.com AFTER Steam.deb, the driver does't work.

So I want to know what distro you guys recommend that works the most "OK" as possible, in 64 bit architecture, and it's the most "pretty" and has the best user interface + no need to keep installing everything. And if it has a "Ubuntu Software Center" like it's more than welcome.

Thanks
Last edited by [Linux] Junior s2 Camila; Jan 1, 2013 @ 4:34pm
Showing 1-9 of 9 comments
< >
seek help Jan 1, 2013 @ 4:26pm 
Everything works fine here on Arch, but it's not user friendly at all and hasn't any GUI by default. If you really want to try out another distro, check out Mint, Mandriva, openSUSE or Sabayon, but I believe that the issues you're having aren't really distro dependent, because Steam for Linux's target platform is Ubuntu.
Kiori Jan 1, 2013 @ 4:26pm 
Keep Ubuntu, and -only- install drivers from jockey(the additional proprietary drivers installation interface). Did you install the xorg updates ppa, as instructed by steam?? https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
Give those a try, plus check the other lib. thread.
Kiori Jan 1, 2013 @ 4:30pm 
And btw i have Steam running on two Ubuntu pcs at home(since everyone uses linux), and they are running fine.
Also, if you wanted more FPS, check the latest ubuntu, they are improving things on that arena. OR simply run something called "OpenBox", and execute Steam from it. Its what I would do...
[Linux] Junior s2 Camila Jan 1, 2013 @ 4:32pm 
Thank you both, I'm looking for the most stable distro related to Nvidia and Steam right know.

Originally posted by Kiori:
Keep Ubuntu, and -only- install drivers from jockey(the additional proprietary drivers installation interface). Did you install the xorg updates ppa, as instructed by steam?? https://launchpad.net/~ubuntu-x-swat/+archive/x-updates
Give those a try, plus check the other lib. thread.
No I didn't update the ppa, I'm sorry. Could these be related to the issues I reported above?
Yes, I only install from jockey, but I wanted to give a try on nvidia's drive, from the website.
Could you past the link to the other lib?
[Linux] Junior s2 Camila Jan 1, 2013 @ 4:35pm 
Originally posted by Kiori:
And btw i have Steam running on two Ubuntu pcs at home(since everyone uses linux), and they are running fine.
Also, if you wanted more FPS, check the latest ubuntu, they are improving things on that arena. OR simply run something called "OpenBox", and execute Steam from it. Its what I would do...
Thanks, but the FPS issue is not related to the real performance. I start the game at 100-200fps, and on the sudden it drops to 10, it's confusing why that happens. BTW Vsync is disabled.
blackout24 Jan 1, 2013 @ 5:52pm 
- With the driver installed from the .run from nvidia.com BEFORE Steam.deb, Steam won't load (Failed to load steamui.so), but the driver works fine.
- With the driver installed from the .run from nvidia.com AFTER Steam.deb, the driver does't work.

What do you mean by that? So in the first case you started into desktop but couldn't launch steam and in the second you couldn't even boot into the desktop? Or what does "driver doesn't work" mean?

There is no need to pick out a specific distro for Steam in terms of stability. If the latest driver in the Ubuntu repo is causing problems for you see if you can get a newer version through PPAs. Installing drivers manually is bad practice, since those files won't be handled by the package manager and are almost guarenteed to lead to file conflicts when you switch back to using the package manager and don't do a clean removal first. Furthermore it wouldn't surprise me if you couldn't start into desktop anymore after a kernel update since the nvidia module is compiled against your current version of the linux headers at that time. So new kernel might not be compatible with the "old" module.

The latest driver is 313.09 btw.
Last edited by blackout24; Jan 1, 2013 @ 6:00pm
[Linux] Junior s2 Camila Jan 1, 2013 @ 6:03pm 
Originally posted by t.jp:
- With the driver installed from the .run from nvidia.com BEFORE Steam.deb, Steam won't load (Failed to load steamui.so), but the driver works fine.
- With the driver installed from the .run from nvidia.com AFTER Steam.deb, the driver does't work.

What do you mean by that? So in the first case you started into desktop but couldn't launch steam and in the second you couldn't even boot into the desktop? Or what does "driver doesn't work" mean?

- Fresh system install. Installed the NVIDIA 310.19 manually (downloaded the .run from the website). Then, installed Steam. But in this case, Steam gives that error (Failed to load steamui.so)

- Fresh system install. Installed Steam. Then, installed the .run Nvidia Driver. After reboot, system gives
Starting load fall back graphics devices - Failed
.
With the drivers installed by jockey, everything works "fine", except the game when in full screen (short bugs list above), and friends list bugging sometimes - can't start a chat via "view friends list when it's already open and when someone starts a chat with you, the message does not appear in the laucher -> http://img4.imageshack.us/img4/5950/capturadetelade20121229.png
Last edited by [Linux] Junior s2 Camila; Jan 1, 2013 @ 6:05pm
RobbieThe1st [Linux] Jan 1, 2013 @ 7:43pm 
Give up on fullscreen then?
Just launch TF2 with the "-windowed -noborder" options, set the resolution, and you should have a 'fullscreen' window that's not.
If you've got a compositing windowmanager(Unity by default is - I believe there's a fallback mode which isn't), you'll get lower performance, but that's better than crashing.
[Linux] Junior s2 Camila Jan 1, 2013 @ 7:44pm 
No need for that, I found something that fixes this problem

http://steamcommunity.com/app/221410/discussions/0/846940249040428050/
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Jan 1, 2013 @ 4:12pm
Posts: 9