Czechanada Jan 1, 2013 @ 1:29pm
Crusader Kings II on Steam for Linux
So just in this past hour, Crusader Kings II decided to show up in my Linux games library. It installed the full 900 megs, but it doesn't start, citing that there is a missing executable file.

Considering that it has not shown up in the Linux store yet, nor have the system requirements yet, are we to assume that this is merely a sign of things to come?

Has it shown up in anyone else's libraries?
Last edited by Czechanada; Jan 1, 2013 @ 1:32pm
Showing 1-15 of 39 comments
< >
d10sfan Jan 1, 2013 @ 1:40pm 
Showed up for me too but cant run it cause of the exectuable missing
elandread Jan 1, 2013 @ 2:33pm 
Same here.

Note that it's not the first time CK2 shows up in the Steam client for Linux, it was there at the very beginning of the closed beta (and couldn't be started due to the same error); but with one of the updates of the Steam client (maybe the very first one) they removed CK2 from the list.

By the way, the developers of CK2 officially stated some time ago that at some point they will release a Linux version.
Last edited by elandread; Jan 1, 2013 @ 2:46pm
MrTennessee17 Jan 1, 2013 @ 3:05pm 
Reporting the same thing. :(
Spongeroberto Squarepantalones Jan 1, 2013 @ 3:25pm 
Same here. Was disappointing, but maybe this means a proper release is coming soon?
Heisenberg Jan 1, 2013 @ 5:21pm 
there are several games with this issue..
Guess the only option is to wait
Nitro[rAfA] Jan 3, 2013 @ 9:04am 
The problem is still there...
rudeboyskunk Jan 3, 2013 @ 3:53pm 
I haven't bought this game, but I do have the same issue with Cave Story+. It's in my linux section of my library, and when I try to install it, it gives me file sizes and it's downloading like a real install should, but then it's got a missing executable.
dionissos Jan 8, 2013 @ 1:09pm 
same here :( and i was happy that finally i can run my loved game to linux :(
[DFC]bydolord Jan 8, 2013 @ 1:51pm 
I guess we'll just have to wait and see what valve has to offer than. It could be coming it could be a bug till we get an official response.
bucaneer Jan 14, 2013 @ 3:35am 
vargablood Jan 14, 2013 @ 3:39am 
nice :) another top title for the penguin :D
Spongeroberto Squarepantalones Jan 14, 2013 @ 9:42am 
Yep, just noticed an update and it's playable. Aside from a long initial loading time it looks spotless so far. This is great!
Seph//roth || Linux UK Jan 14, 2013 @ 10:02am 
when steam 1.0 is released they need to have a penguin sale!
fac3l3ss Jan 14, 2013 @ 10:09am 
I can confirm that CKII is up and running. The initial loading time, when you boot the game for the first time takes a while but subsequent loadings are fast. The only problem I have is with active corners. If you have active corners enabled in Ubuntu the game window in fullscreen will be out of place if you put the mouse cursor over those hot corners.
Herzog Jan 14, 2013 @ 10:45am 
It didnt work for me. I am using a Nvidia Optimus card, so at first I used normal graphics mode without opti/primusrun. It started and loaded everything except for the map, so I couldnt play (GUI was displayed!). Then I tried starting Steam with primusrun where CKII didnt start at all. Starting with optirun caused the game to hang at the "graphics loading" screen. I killed the process then after a few minutes.

Showing 1-15 of 39 comments
< >
Per page: 15 30 50
Date Posted: Jan 1, 2013 @ 1:29pm
Posts: 39