MRxSNIPES2 Dec 29, 2012 @ 6:51am
team fortress 2 mic bug
TF2 has some kind of bug where I cant use my mic in game my mic work fine I use it for ever thing els. i am using Ubuntu 12.04 with mate.
if you need more info let let me know
UPDATE: I for get to put in here that I do use a usb headset
Last edited by MRxSNIPES2; Dec 31, 2012 @ 2:15am
Showing 1-13 of 13 comments
< >
bobebubab Dec 29, 2012 @ 7:15am 
+1
The Triggerhappy Innocent Dec 29, 2012 @ 10:36am 
The same here on 12.10. Mic works for a brief time then stops working after maybe 10 minutes of gameplay.
alwaysd Jan 19, 2013 @ 12:27pm 
I have the same issue thought had it fixed
Cheogh Jan 19, 2013 @ 12:46pm 
Did you set it in steam's settings?
alwaysd Jan 19, 2013 @ 1:18pm 
I am going to try it out tonight steam settings are fine I think it is a ubuntu issue disable the auto mute in alsamixer
Karlodinium May 13, 2013 @ 7:56pm 
Did anyone ever get this working? I tried to troubleshoot by putting voice_loopback 1 in the tf2 console, which apparently plays your own voice back to you. Disabling automute in alsamixer did nothing for me. Also, I attempted setting input via Steam to PuselAudio default and ALSA default, but neither worked.
alwaysd May 14, 2013 @ 2:23pm 
I have not had success I switched to alsa mixer it does not crash as much I have been limiting my talking but when it does crash it now takes the machine down and have to reset.
alwaysd May 14, 2013 @ 2:24pm 
I have seen in a ubuntu install fresh it was looping just using the mic not steam
Karlodinium May 14, 2013 @ 5:26pm 
Sorry, I don't quite understand. So you are saying that after you disabled automute in alsamixer, and set ALSA default in Steam, the microphone works, although frequently crashes the computer? And what do you mean "just using the mic not steam".
Karlodinium May 14, 2013 @ 8:47pm 
Hmm… now I'm looking more, it seems that a server-side setting might be to blame [1]. Apparently, if sv_use_steam_voice is set to 0, then Linux clients' microphones won't work. That's pretty horrible.

Apparently there are some other issues associated with changing this setting, so it's either "better for Windows/Mac users" or "works for Linux users". And I suspect I know which will win out here.

[1] https://github.com/ValveSoftware/Source-1-Games/issues/106
alwaysd May 15, 2013 @ 1:50pm 
yes just setting the mic to alsa seems better but then crashes the whole computer need to hit reset. I had a fresh install of 12.10 on a machine the had a loop when you use the mic no steam installed.
Karlodinium May 16, 2013 @ 5:19am 
Ah okay. Well, that doesn't really seem like a real solution then. Thanks for the reply anyway. Cheers.
Showing 1-13 of 13 comments
< >
Per page: 15 30 50
Date Posted: Dec 29, 2012 @ 6:51am
Posts: 13