Steam for Linux

Steam for Linux

Steam for Linux > Algemene discussies > Details van topic
Serious Sam 3 BFE not launching [Solved]
I have just purchased SS3 BFE and I have tried to launch it under my Linux Beta client, however I am unable to get this to work.

The output on the console when I attempt to launch is

Game update: AppID 41070 "Serious Sam 3: BFE", ProcID 8526, IP 0.0.0.0:0
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded: ignored.
WRN: CPU Power saving is enabled and performance governor is not used.
INF: GameEnv API: Steam
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
Game removed: AppID 41070 "Serious Sam 3: BFE", ProcID 8526
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Generating new string page texture 140: 256x256, total string texture memory is 393.22 KB
Generating new string page texture 141: 256x256, total string texture memory is 1.74 MB


I get no graphical output on the screen, no black screens etc.

I am running Linux Mint 14, Mate desktop.

The game has just been downloaded and installed today.
Have verified local cache

Thanks.
Laatst bewerkt door OversizedSpoon; 5 jan 2013 om 11:42nm
< >
1-14 van 14 reacties weergegeven
What are your specs? Do you have the 32 bit version of your graphics driver installed?
Also opt-in into the public beta for SS3. Library -> Serious Sam 3 -> Right Click -> Properties -> Betas -> publicbeta and let it update.

You should also see if you can install a cpufreq indicator for your desktop so you can set the CPU to performance mode. Otherwise you might have a performance penalty if you keep using powersaving options for the CPU.
Laatst bewerkt door blackout24; 29 dec 2012 om 3:46vm
Specs are:
i5 3570, 8 GB RAM, Geforce Ti 560, 64 Bit Linux Mint with Mate desktop.
I am running the 64 Bit of the Nvidia driver.

I tried the publicbeta option just after I posted, it went through the update but no difference.

I have conky running on the desktop. When I launch SS3 my CPU usage will go from 5% to 7% for a split second then drop again.
I ran cpufreq-set -c 0 -g performance for each of my cores as they were listed as ondemand. Again no difference.
If you don't install the 32 bit version of your driver it will never start. This is simply a fact since it is a 32 bit game.
Can you try to deactivate Steam Community? Just go to your library, right click your game and got to properties and untick "Enable Steam Community In-Game". Then try to start the game again.

I have reinstalled the nvidia driver and selected the 32 bit support option, as well as disabling the community support option. So far same issue
These two are the issue here:

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.

Seems like Steam is not correctly installed or somehow incompatible with the libsteamapi.so in Sam3 folder. Can you paste Sam3.log here?
Did you guys create a simlink of any kind? Some users had problems with some games when they did this.
Katsura, I have not setup any symlinks at all for steam.
AlenL
I can't find the sam3.log. Have rerun updatedb and location can't pick it up, had a look manually and can't see any of it.
I think Steam should be installed fine as TF2 runs without issue.
Could be that it quit too early to create the log. The location is in the FAQ. Can you do

strings Bin/Sam3 | grep "$Version:"

to see which version of Sam3 is installed?
I have found libsteamapi.so however it is named libsteam_api.so. I tried symlinking to fix the issue however I still cannot launch


INF: GameEnv API: Steam
[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed.
[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll.
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Game removed: AppID 41070 "Serious Sam 3: BFE", ProcID 2893
Generating new string page texture 126: 256x256, total string texture memory is 4.87 MB
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully

I ran the strings | grep "$version:" command, there is a hell of a lot of output, so here's a pastebin of it.

http://pastebin.com/SfMaTVKC

I reran verify of local data to test with and all completed without needed a fix.
Uh, sorry, those are both my typos. It's libsteam_api.so - no need to symlink. Btw according to those messages, Sam3 loads that library correctly, but when the library tries to locate where Steam is - it cannot find it. Not sure how that is possible. Maybe compare that steamapi with the one in TeamFortress folder? I know that layout of Steam folders was/is/will be changed due to some rearranging, but not sure what's the status of that, and perhaps that's wrong on some systems.

The grep line should have been:

strings Bin/Sam3 | grep -F \$Version:

That should give only one line :). Anyway, I found the version in your paste manually.

As far as I see, you are in the latest beta of Sam3, but perhaps Steam is not latest?
Woot that thread had the key.
I will had in addition the the script I did need to run chown me:users ~/.steam/steam.pid before it would launch.

Thanks for you help guys!!!
< >
1-14 van 14 reacties weergegeven
Per pagina: 15 30 50

Steam for Linux > Algemene discussies > Details van topic
Geplaatst op: 29 dec 2012 om 12:53vm
Aantal berichten: 14