The Sleeper Awakes Dec 23, 2012 @ 9:25pm
Proprietary Driver failure
My laptop can run more recent games (not all, mind you) and I got along fine with them on the Windows version of Steam on the same machine. On Ubuntu, Steam is throwing the error that I need to have newer drivers and closes the application.

Can we get rid of that error and make it a warning instead? I'd like to take my chances and figure out what runs instead of not getting the option to even look at my library.

And if anyone's wondering why I don't update the drivers, it's because none of them are compatible for me. If I update my drivers to anything other than the nvidia_173, the computer boots into shell mode and won't go back into unity until I remove them. Likewise, on Windows it causes OpenGL to fail. Long story short? Don't buy a laptop and expect to have driver support.
Date Posted: Dec 23, 2012 @ 9:25pm
Posts: 0