Heeter Dec 20, 2012 @ 9:19am
TF2 audio/video very choppy on Ubuntu.
Hi All,

Steam application is installed and working flawlessly so far.

Installed TF2, no problems there either.

Fire up TF2 and the valve logo plays flawlessly too.

It is when the actual TF2 starts up that the audio/video both is very choppy.

Here are my specs:

AMD PhemonII 6core 1090T CPU
Asus M4A785T-M Mobo
Integrated ATI HD4220 Graphics
4 GIGS DDR3 RAM
150GIG WDD RAPTOR HD
Ubuntu 12.10 64Bit
Kernel Linux 3.5.0-21-generic.

I have the maximum 512MB allotted of RAM to the integrated video card.

I am assuming that my video card setup is not enough, am I correct to assume this?

If this is correct, what vid card company would work best, nvidia or ATI, for my Steam Linux setup?

Thanks

Heeter

Showing 1-9 of 9 comments
< >
Heeter Dec 23, 2012 @ 2:51pm 
Anyone?

Thanks

Heeter
CASTIRON IV Dec 23, 2012 @ 2:53pm 
no idea. have the same problem, intel i5, gt540m, 6b ram, 1gb vram. I'm running Optimus though, so maybe that has something to do with it?
[LINUX]FinCoder Dec 23, 2012 @ 3:08pm 
I assume too that it's the video card. ati 7770 should not be too expensive for your computer.
gumbo Dec 23, 2012 @ 3:16pm 
Same problem here
嘔吐 Dec 24, 2012 @ 4:16am 
There's a setting called multithreading enabled or something like that (sorry, I don't have the time to check the exact wording right now) in TF2. It doesn't seem to work with something commonly used in Linux environment, even though it's enabled by default for multicore processors.

You should try disabling it first, it might help. It might also be that it's the video card, but still, it's worth trying that first when attempting to play TF2 on Linux.

I played TF2 ~150 hours on Wine before the Linux version came out, and disabling it was always something that had to be done. The same holds with the native client; disabling it improves FPS *considerably* (I'd say at least ~+40 for me).
Last edited by 嘔吐; Dec 24, 2012 @ 4:17am
Heeter Dec 24, 2012 @ 11:23am 
Thanks for your responses, guys.


Heeter
GodModeMario May 14, 2014 @ 7:54am 
Originally posted by 嘔吐:
There's a setting called multithreading enabled or something like that (sorry, I don't have the time to check the exact wording right now) in TF2. It doesn't seem to work with something commonly used in Linux environment, even though it's enabled by default for multicore processors.

You should try disabling it first, it might help. It might also be that it's the video card, but still, it's worth trying that first when attempting to play TF2 on Linux.

I played TF2 ~150 hours on Wine before the Linux version came out, and disabling it was always something that had to be done. The same holds with the native client; disabling it improves FPS *considerably* (I'd say at least ~+40 for me).
^ This person. This person knows what they are talking about. +1 to that guy You Rock!
gutigen o) May 15, 2014 @ 3:37am 
Ubuntu 12.10... lol, there is your problem. Not only outdated packages, but 12.10 was one of the most buggy Ubuntu releases in years. There is new long term support release now, 14.04 which has much much faster open source drivers and more recent kernel.

Srsly, Linux is not frakking Windows, updates actually make difference and are deployed at weekly or daily basis - take advantage of that.
GodModeMario May 15, 2014 @ 11:13am 
smh... gutigen, you sound enlightened bro...
Showing 1-9 of 9 comments
< >
Per page: 15 30 50
Date Posted: Dec 20, 2012 @ 9:19am
Posts: 9