r0ssar00 Dec 19, 2012 @ 6:44pm
amd64 install failing on Ubuntu 12.04
I get the following when I try to install 1.0.0.17 on ubuntu-12.04 amd64:
dpkg: dependency problems prevent configuration of steam:i386:
steam:i386 depends on libcurl3-gnutls (>= 7.16.2-1).
steam:i386 depends on libpixman-1-0 (>= 0.24.4-1).
steam:i386 depends on libcairo2 (>= 1.6.0).
steam:i386 depends on libgtk2.0-0 (>= 2.24.0).
steam:i386 depends on libpango1.0-0 (>= 1.22.0).
I start by installing the i386 version of libcurl3-gnutls and that requires librtmp0:i386. So I got to install that and all of a sudden I have to remove a whole bunch of libcurl dependent packages. Not cool. For the curious, the list of packages is in Listing 1 near the bottom of the post. Okay, so I'm not gonna remove all that stuff so I'll just hope for the best. On to the next package (skipping a few blah depends on blah depends on blah steps), libcairo2. Well, Listing 2 tells me I have to uninstall not only xserver-xorg-core but also nvidia-current, along with calibre, cups (the print daemon, really??), and java. Uninstalling the display server? What does that accomplish other than prevent me from using steam in the first place? Uninstalling the display driver?? Really??

Suffice it to say, there are *serious* dependency issues with the current build of steam and I'll unfortunately be unable to run it until these get resolved. Anyone have the same issues and managed to get them resolved?


Listing 1
apt-transport-https aptdaemon curl evolution-data-server git git-core libcurl3
libcurl3-gnutls libcurl3-nss libcurl4-openssl-dev libgdata13 liboauth0 librtmp-dev librtmp0
python-aptdaemon python-aptdaemon.gtk3widgets python-aptdaemon.pkcompat python-pycurl
python-software-properties software-properties-gtk transmission-cli transmission-daemon
vorbis-tools whoopsie xul-ext-ubufox

Listing 2
calibre cups default-jre evolution-data-server firefox firefox-globalmenu gedit
gir1.2-gtk-3.0 gir1.2-gtksource-3.0 gir1.2-pango-1.0 gir1.2-peas-1.0 gir1.2-vte-2.90 gksu
gnome-control-center gnome-icon-theme gnome-icon-theme-symbolic gnome-keyring
gnome-online-accounts gnome-session-bin gnome-settings-daemon gnome-system-monitor
gnome-user-guide graphviz humanity-icon-theme icedtea-netx indicator-applet
indicator-application indicator-datetime indicator-messages indicator-power indicator-session
indicator-sound indicator-status-provider-mc5 libappindicator3-1 libatk-wrapper-java
libatk-wrapper-java-jni libcairo-gobject2 libcairo-perl libcairo2 libcairomm-1.0-1
libcanberra-gtk3-0 libcanberra-gtk3-module libdbusmenu-gtk3-4 libdbusmenu-gtk4
libedataserverui-3.0-1 libgail-3-0 libgcr-3-1 libgksu2-0 libglade2-0 libglademm-2.4-1c2a
libgnome-bluetooth8 libgnome-control-center1 libgnome-desktop-3-2 libgnomekbd7 libgoa-1.0-0
libgtk-3-0 libgtk-3-bin libgtk2-perl libgtk2.0-0 libgtk2.0-bin libgtkmm-2.4-1c2a
libgtkmm-3.0-1 libgtksourceview-3.0-0 libgvc5 libgweather-3-0 libido3-0.1-0 libindicator3-7
liblaunchpad-integration-3.0-1 libmagickcore4-extra libnm-gtk0 libpanel-applet-4-0
libpango-perl libpango1.0-0 libpangomm-1.4-1 libpeas-1.0-0 libpixman-1-0 librsvg2-2
librsvg2-common libtimezonemap1 libvte-2.90-9 libvte9 libwebkitgtk-3.0-0 libwnck-3-0
libwnck22 libxfce4ui-1-0 libyelp0 mousetweaks network-manager-gnome
network-manager-pptp-gnome notification-daemon nvidia-current nvidia-settings openjdk-6-jdk
openjdk-6-jre openjdk-7-jre paman paprefs pavucontrol pavumeter policykit-1-gnome
poppler-utils printer-driver-gutenprint python-aptdaemon.gtk3widgets python-cairo python-gtk2
screen-resolution-extra software-properties-gtk synaptic ubuntu-docs unity-greeter wireshark
xfwm4 xserver-xorg-core yelp zeitgeist zeitgeist-datahub zenity
Showing 1-7 of 7 comments
< >
gens Dec 19, 2012 @ 7:23pm 
thats all standard packages, the first couple you listed

and since you'r installing a 32bit package on a 64bit machine you have to install them

dependancy resolution is a distro thing and there shouldnt be no reason for it to do what you say it wants to do
Cybertao Dec 19, 2012 @ 8:47pm 
Double-click on steam.deb and it opens in the Software Center, allowing you to install it and all dependencies. Done.
r0ssar00 Dec 19, 2012 @ 11:36pm 
@gens hence the confusion. I follow the exact same steps everyone else does and I get this.
@Cybertao the exact equivalent of "dpkg -i steam.deb; apt-get -f install". Either way, graphical or CLI, I'll have the same errors.
Hormel Chavez Dec 19, 2012 @ 11:44pm 
don't know if this will help anyone but I ran into this and was able to install the client after the dependancy warning using "sudo apt-get -f install"
Line Noise Jan 25, 2013 @ 3:48pm 
I had this same problem. It turns out it was because I had installed librtmp0 from a PPA instead of the Ubuntu repos and that wouldn't let me install both the amd64 and i386 versions of librtmp0 at the same time.

Here is how I fixed it (YMMV).

Remove librtmp0 (and librtmp0-dev if installed):

sudo dpkg -r --force-all librtmp0 librtmp-dev

This removes just the librtmp0 packages, ignoring any dependencies (as opposed to "apt-get remove" which also tries to remove dependencies). After this anything that depends on librtmp0 will be broken. But we fix that in the next step:

Re-install librtmp0 (and librtmp0-dev if necessary):

sudo apt-get install librtmp0 librtmp0:i386 librtmp-dev

Note that I installed both the default amd64 package and the i386 package required by Steam.

You should now be able to install the Steam package.
r0ssar00 Feb 1, 2013 @ 1:04am 
I ended up uninstalling the xorg-updates ppa and purging all it's packages, reverting back to official repo versions. Now Steam whines about my system not having version 304.64 of the nvidia drivers, even though that is the exact version installed via apt. *sigh*. I do only have a 7600GS in the system so it was a "let's see if it works at all" scenario.
Showing 1-7 of 7 comments
< >
Per page: 15 30 50
Date Posted: Dec 19, 2012 @ 6:44pm
Posts: 7