Steam for Linux > 综合讨论 > 主题详情
Chief Oppupu 2012年12月17日下午8:31
Issue Report: TF2 sound stuttering and unplayably low FPS
So I can launch TF2 fine, but when I start a match, I get terrible sound stuttering. It just loops the same half second of sound for several seconds, then the next bit of sound, etc. I just started a match and the announcer sounded like:

Miss-Miss-Miss-Miss-Miss-ion-ion-ion-ion-ion-ion beg-beg-beg-beg-beg-ins-ins-ins-ins-ins-ins in-in-in-in-in thir-thir-thir-thir-ty-ty-ty-ty-ty....... and so on

If I continue and try to play, I get roughly a frame every few seconds.

This is a fresh install of Linux Mint 14. It ran fine for a day before this started, and I don't think I changed anything that should affect TF2.

Has anyone else seen this issue?

My system info:

Processor Information:
Vendor: GenuineIntel
Speed: 3601 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Linux Mint 14 Nadia (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-17-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 460/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0xe22
Number of Monitors: 1
Number of Logical Video Cards: 2
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 20.51" x 11.54" (23.50" diag)
52.1cm x 29.3cm (59.7cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 1023 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 7982 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 118233 Mb
Largest Free Hard Disk Block: 92082 Mb

Installed software:

Recent Failure Reports:
Tue Dec 18 04:13:56 2012 GMT: file ''/tmp/dumps/crash_20121217231354_1.dmp'', upload yes: ''CrashID=bp-c6e7b088-ae09-4e6e-9dac-8d37b2121217''
正在显示第 1 - 15 条,共 43 条留言
< >
Jinouchi 2012年12月28日下午2:01 
Same problem. Just installed Ubuntu, Steam and TF2 today. First time running it I got the same symptoms as you. 1 frame per second at best, and stuttering sound.

Some quick specs:

RAM: 20GB
CPU: 8 core AMD 3.1GHz
30GB HDD free space
[Linux] Junior s2 Camila 2012年12月28日下午6:14 
Hello guys. The same problem with me, BUT when I launch the game by the Desktop, everthing works fine.

If you wish, colaborate on my thread.

Regards.
[Linux] Junior s2 Camila 2012年12月28日下午6:25 
And BTW if I recall, the distro they're putting effeorts on is Ubuntu. I'd recommend installing it and giving it a try =)
Jinouchi 2013年1月1日上午12:35 
I'm using Ubuntu, but I was using 12.10. I noticed that 12.04 LTS was the more supported version, so I installed that instead. Things seem to be running more smoothly so far. TF2 is downloading now - did not work from my SteamApps backup folder. Will update with any major news.
CѺƦЯЦƥȚ ƧƜΊҬʗӇ 2013年1月13日上午8:30 
Same issue here. Mint 14 Cinnamon.
Lysius 2013年1月14日上午9:30 
Had a very similar problem on Fedora 17 with nvidia driver 310.19. In various games (also in TF2) I sometimes saw an FPS drop to one frame per few seconds that suddenly appeared and could only be ended with exiting and restarting the game.
I updated the nvidia driver to 313.09 and the problem went away.
CѺƦЯЦƥȚ ƧƜΊҬʗӇ 2013年1月14日下午1:51 
Turns out that my HDD was dying.
Elizium23 2013年1月29日下午3:44 
I am having intermittent problems. I have only tried the training and offline-with-bots missions, and 90% of the time the game plays smooth as silk. But the times it stutters are crippling. It is impossible to play like this. My hardware: i5-2400 CPU, 8GB DDR3 RAM, GeForce 9600 GT.
Lysius 2013年1月30日上午4:36 
Elizium23: Did you try the 313.x nvidia driver? You description matches perfectly to my problem I had with 310.x.
Elizium23 2013年1月30日下午5:36 
Lysius: thanks for the reply. Where can I get the 313.x driver? Do I have to download and install it manually? I had a lot of grief the last time I tried to do that. The best driver I can find through the "Additional Hardware" control panel is 310.x. I have been getting updates for that. I have precise-proposed added to my software repositories. (Ubuntu 12.04 in case you didn't know.)
nate.sh 2013年1月30日下午6:09 
Disable multicore rendering and vsync. Solved my issues. Using 310.x drivers.
最后由 nate.sh 编辑于; 2013年1月30日下午6:10
Lysius 2013年1月31日上午1:52 
I don't use Ubuntu. If there are no packages for 313.x, you could try to get the source package used to build the driver package for Ubuntu, put the new driver version into that and build the package with the desired driver version yourself. That is what I normally do when I want to install a driver version on Fedora that is not available as a package.
HOMOSENSUAL ULTRA-GOD 2013年3月2日下午5:37 
Getting the exact same problem. It was working fine a day or two ago, but i guess something updated or changed because I'm now getting the annoying stutter and a single frame every five seconds or so.
[Linux] Junior s2 Camila 2013年3月2日下午5:39 
It's not a Ubuntu problem, it's a Steam one and specially Team Fortress 2.

Disabling Antialiasing resolved some of my problems
最后由 [Linux] Junior s2 Camila 编辑于; 2013年3月2日下午5:40
HOMOSENSUAL ULTRA-GOD 2013年3月2日下午10:21 
I've tried everything suggested here as well as everything i can think of, including reinstalling all the xorg, unity, and video driver packages. nothing will fix this problem that literally sprang up over night. =(
正在显示第 1 - 15 条,共 43 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年12月17日下午8:31
帖子数: 43