Steam for Linux > 综合讨论 > 主题详情
Elegant Light Bulb 2012年12月14日上午11:20
Can't change installation directory of games?
So as it says, I can't change the installation directory of my games. This is after I added a few folders in the settings. This happens with both restoration of backups and installing from the store page.

Is this actually and issue, or is it just a feature that hasn't been incorporated in to Steam Linux yet?
正在显示第 1 - 15 条,共 50 条留言
< >
8 Dimensional Octagon 2012年12月14日下午12:36 
You can change the directory. If I remember correctly you go into settings and it's under one of the tabs.
Elegant Light Bulb 2012年12月14日下午12:38 
I don't understand. I can easily add new directories to install in. It's just thatr it never installs to that directory. It never asks for where to install it, so it just defaults to the original SteamApps folder, which doesn't have much space left.
z411 2012年12月14日下午12:57 
I can confirm. The option is there but it doesn't really do anything.
Elegant Light Bulb 2012年12月14日下午12:58 
Darn. I'll have to wait until Valve fixes this then.
8 Dimensional Octagon 2012年12月14日下午4:43 
Huh, cause I switched mine to /opt and it worked fine. Maybe this is a regression.
8 Dimensional Octagon 2012年12月14日下午5:51 
This isn't how I did it, but modifying the symlinks in ~/.steam should work
spqrPh 2012年12月15日上午7:24 
Needs fix, especially useful for people, who have their steam folder on external hdd and switch platforms or use dual boot
Krasny 2012年12月15日上午11:48 
Hi

I came here to say the same thing. I have a SSD drive, with no much space left. I installed steam and configured another directory for games, but the program doesn't allow change default path or asks for a directory to install the game or move after it´s installed. The result: 0 bytes left in my drive downloading TF2. Make symbolic links for newbie users isn't an option.

Please, fix this issue

(and sorry for my bad english)
Veg 2012年12月23日上午5:25 
The same here - this makes Steam pretty useless, as my home folder is also low on space.
Halber 2012年12月23日上午5:42 
Maybe it is defaulting to the first entry and only going down the list when installing a game that won't fit?
Veg 2012年12月23日上午5:52 
Nope, even if the first (top down) entry is another folder, it installs in the default (last) folder!
iTux 2012年12月23日上午5:54 
You can move your Steam home directory to the new directory and then create symbolic link for the new Steam directory at your home.
Elegant Light Bulb 2012年12月23日上午9:56 
I've created symbolic links for both Steam and SteamApps, (Not at the same time) and neither worked. The former made Steam unlaunchable and the latter made TF2 crash. Interestingly, the other games seemed to have survivied the link.
Elegant Light Bulb 2012年12月23日上午10:55 
Ah ha. So apparently, I'm never ever supposed to symlink just the SteamApps folder, and I always have to do the whole Steam directory. However, that won't work, because it so stubbornly insists that it can't copy the bin_steam.sh to /usr/bin/steam
miguel.l5862u 2012年12月23日下午2:00 
well the usr/bin/steam is a system directory therefore you need root access. do you have the permissions to copy the bin_steam.sh file to that directory??? otherwise remember to use the sudo command if you're using the terminal or run nautilus as superuser and with that you should be able to copy the file
正在显示第 1 - 15 条,共 50 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年12月14日上午11:20
帖子数: 50