breed808 Dec 13, 2012 @ 12:12am
TF2 Cannot find servers.
Hi Guys, I'm trying to run TF2 through the beta (I have the beta invite if that helps), and am getting the following error message when attempting to find servers within TF2:

"Steam beta required to find servers"

Now TF2 is launching and running just fine apart from this, and I don't know what's causing it, as I am participating in the beta. I've deleted my ClientRegistry.blob in an attempt to solve the problem but this has not helped in any way.

Has anyone else come across this error? Does anyone know how to solve it? Are the servers currently down and I just don't realize it?
Showing 1-6 of 6 comments
< >
rudeboyjamaica Dec 13, 2012 @ 12:40am 
try connect to this one:
208.115.218.38:27045
208.115.218.38:27035
78.46.106.151:29045
83.142.226.201:27085
77.232.128.228:27036
109.63.144.13:27047

Some of them are at this moment empty some of them have also playing bots.

But in my opinion if i see only 6 server in server list it is too small amount. Few days back I think it was more servers than only Six ...
Last edited by rudeboyjamaica; Dec 13, 2012 @ 12:41am
breed808 Dec 13, 2012 @ 2:54am 
I'm getting a 'This server requires you to be logged into Steam" error, which is strange, as I launched TF2 from the client.
breed808 Dec 13, 2012 @ 3:17am 
Ah, I've run steam through the terminal and it's complaining that it can't find steamapi.dll or something. I think I'm missing a file. I'll validate the TF2 local files and report back here.
rudeboyjamaica Dec 13, 2012 @ 3:25am 
ok try it.
breed808 Dec 13, 2012 @ 3:34am 
No luck. All files validated successfully, but still getting

[S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll
rudeboyjamaica Dec 13, 2012 @ 3:48am 
just try install apt-get install ia32-libs
Showing 1-6 of 6 comments
< >
Per page: 15 30 50
Date Posted: Dec 13, 2012 @ 12:12am
Posts: 6