cjplooy Dec 11, 2012 @ 1:36pm
TF2 complains about missing S3TC but glxinfo says it's there
Team Fortress 2 gives me this error message:
Required OpenGL extension "GL_EXT_testure_compression_s3tc" is not supported. Please install S3TC texture support.

Based on comments in this forum, I installed libtxc-dxtn-s2tc0, but the problem remains.

Note that glxinfo says I do have the S3TC OpenGL extension:
Click for glxinfo output[www.ultimatestunts.nl]

Note: some people recommend using driconf and enable option "Enable S3TC texture compression...", but driconf doesn't have that option on my system.

My system:
HP Pavilion g6 laptop with 4x AMD A6-3420 APU and Radeon HD 6400M videocard
64-bit Linux Mint 13 LTS (could 64-bit be the problem?)
Open source Radeon drivers ("Gallium 0.4 on AMD SUMO")
http://www.ultimatestunts.nl/tmp/steam/Xorg.0.log
Showing 1-10 of 10 comments
< >
Credomane Dec 12, 2012 @ 10:27am 
I installed both libtxc-dxtn-s2tc0 and libtxc-dxtn-s2tc-bin. Not sure if I needed the bin now or not.

I didn't know about driconf until I read this. I installed driconf and found the "Enable S3TC Texture Compression" on the image tab. Running DRIconf 0.9.1.
Last edited by Credomane; Dec 12, 2012 @ 10:28am
Kano Dec 12, 2012 @ 10:49am 
sudo apt-get instal libtxc-dxtn-s2tc0:i386
cjplooy Dec 12, 2012 @ 10:55am 
Thanks, I'll try to see if installing libtxc-dxtn-s2tc-bin makes a difference. I already know it does NOT make a difference for the options listed in driconf:
screenshot[www.ultimatestunts.nl]

My driconf version is also 0.9.1 (it seems to be the default version in Mint 13 and Ubuntu 12.04). The options shown in driconf are probably driver/hardware dependent.

In another thread I found the following suggestions:
"force_s3tc_enable=true steam"
"export R600_ENABLE_S3TC=1"

I now have a couple of things to try; I'll come back here to report my results.

For now, I just want to comment that, on my system, TF2 doesn't run out of the box because of this issue. I guess it's fine for a beta release, but this should really be fixed for the final release.
cjplooy Dec 12, 2012 @ 12:02pm 
With libtxc-dxtn-s2tc-bin and libtxc-dxtn-s2tc0:i386 installed, it doesn't display the error message anymore: I now get a black screen with nothing but a mouse cursor and some sounds.

So I guess I'm one step further now; I'll search the forum for the black screen issue.

I don't know which of the two packages was the solution; since libtxc-dxtn-s2tc0:i386 sounds to me like it makes a lot of sense on a 64-bit system, I guess it was that one. I'll also try without libtxc-dxtn-s2tc-bin.
mikeym Dec 12, 2012 @ 12:19pm 
Originally posted by cjplooy:
I don't know which of the two packages was the solution; since libtxc-dxtn-s2tc0:i386 sounds to me like it makes a lot of sense on a 64-bit system, I guess it was that one.

Yes, 99.9% it's that one.
Anakin Solo Dec 13, 2012 @ 9:08am 
I'm having the blackscreen issue too after fixing the S3TC thing... :(
cjplooy Dec 13, 2012 @ 10:02am 
FYI: libtxc-dxtn-s2tc-bin was not needed. It's the libtxc-dxtn-s2tc0:i386 package you need on 64-bit systems.

I haven't solved the black screen issue yet, but I consider that a separate issue, deserving a separate thread.
Kano Dec 13, 2012 @ 11:23am 
You need mesa 9+ for tf2.
vittorio88 Jan 21, 2013 @ 6:27pm 
This did it for me!

Originally posted by Kano:
sudo apt-get instal libtxc-dxtn-s2tc0:i386
Fabioamd87 Apr 8, 2013 @ 3:30am 
and this for me (ArchLinux):

sudo pacman -S libtxc_dxtn
Showing 1-10 of 10 comments
< >
Per page: 15 30 50
Date Posted: Dec 11, 2012 @ 1:36pm
Posts: 10