Steam for Linux > 综合讨论 > 主题详情
Hizeph, o Guaxininja 2012年12月10日上午10:33
[Solved] Fatal Error: Failed to load steamui.so
Hey,
I'm trying to run Steam on Fedora 17 x86_64, but during the installation, i get this:
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
and the link on /home/myuser/.steam/bin64 is broken because de .local/share/Steam/ubuntu12_64 doesn't exist.
Someone got any ideas?
最后由 Hizeph, o Guaxininja 编辑于; 2012年12月11日下午4:18
正在显示第 1 - 11 条,共 11 条留言
< >
eliteSchaf 2012年12月10日上午11:31 
Are the 32bit libraries installed? On Ubuntu i had to install "ia32-libs" to make it work.
Seems like they missed a dependency
最后由 eliteSchaf 编辑于; 2012年12月10日上午11:31
Hizeph, o Guaxininja 2012年12月11日下午4:18 
I just got a repo for Fedora, and it installed those 32 bits libs as a dependencies, guess it was the problem! Thanks
DNStorage 2012年12月18日下午1:18 
Thanks for the solution. installing "ia32-libs" worked for me. Xubuntu 12.04.1.
lushb0x 2012年12月22日上午11:03 
Hey if it's not to much trouble what was the repo that you used for Fedora?
Hizeph, o Guaxininja 2012年12月22日下午2:01 
Create a file like "steam.repo" with this content:

# Place this file in your /etc/yum.repos.d/ directory

[steam]
name=Steam RPM packages (and dependencies) for Fedora
baseurl=http://spot.fedorapeople.org/steam/fedora-$releasever/
enabled=1
skip_if_unavailable=1
gpgcheck=0
jyoung546 2012年12月26日下午2:40 
I have Ubuntu 12.10 installed on an HP dv6-7014 with a GT-650m Optimus (bumblebee installed). To fix this error I followed the instructions in this thread. http://steamcommunity.com/app/221410/discussions/1/846939071105489121/
choucroute 2012年12月28日下午11:51 
I fixed this error on Debian Wheezy (amd64) with export LD_PRELOAD=${HOME}/.local/share/Steam/ubuntu12_32/steamui.so before running steam

EDIT: fix is incorrect, the proper solution is to upgrade /usr/lib32/libgdk-x11-2.0.so so the symbol gdk_window_get_screen is present (this was due to my ia32-libs-gtk package being from squeeze, and thus too old)
最后由 choucroute 编辑于; 2012年12月29日上午12:15
lushb0x 2013年1月2日下午12:46 
Yeah but fedora is different , it lacks a lot of the libraries that Debian has. Plus it's not a noob distro like Ubuntu you have to compile the steam beta from source.
blackout24 2013年1月2日下午1:00 
There is no source available for the Steam Client. Repackagin a deb file is far from "compiling it from source" it's more like extracting a zip file and repackaging it as a rar file so it can be registered in the local package manager...
lushb0x 2013年1月3日下午12:17 
Have you looked around? I'm not talking about a deb file. That's like a bit rpm
lushb0x 2013年1月3日下午12:23 
P.S the repos that are stated in this discussion are out dated and don't work anymore.
正在显示第 1 - 11 条,共 11 条留言
< >
每页显示数: 15 30 50
发帖日期: 2012年12月10日上午10:33
帖子数: 11