Hizeph 10 déc 2012 à 10h33
[Solved] Fatal Error: Failed to load steamui.so
I'm trying to run Steam on Fedora 17 x86_64, but during the installation, i get this:
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
Installing breakpad exception handler for appid(steam)/version(1354925460_client)
and the link on /home/myuser/.steam/bin64 is broken because de .local/share/Steam/ubuntu12_64 doesn't exist.
Someone got any ideas?
Dernière modification de Hizeph; 11 déc 2012 à 16h18
Affichage des commentaires 1 à 11 sur 11
< >
eliteSchaf 10 déc 2012 à 11h31 
Are the 32bit libraries installed? On Ubuntu i had to install "ia32-libs" to make it work.
Seems like they missed a dependency
Dernière modification de eliteSchaf; 10 déc 2012 à 11h31
Hizeph 11 déc 2012 à 16h18 
I just got a repo for Fedora, and it installed those 32 bits libs as a dependencies, guess it was the problem! Thanks
DNStorage 18 déc 2012 à 13h18 
Thanks for the solution. installing "ia32-libs" worked for me. Xubuntu 12.04.1.
lushb0x 22 déc 2012 à 11h03 
Hey if it's not to much trouble what was the repo that you used for Fedora?
Hizeph 22 déc 2012 à 14h01 
Create a file like "steam.repo" with this content:

# Place this file in your /etc/yum.repos.d/ directory

name=Steam RPM packages (and dependencies) for Fedora
jyoung546 26 déc 2012 à 14h40 
I have Ubuntu 12.10 installed on an HP dv6-7014 with a GT-650m Optimus (bumblebee installed). To fix this error I followed the instructions in this thread. http://steamcommunity.com/app/221410/discussions/1/846939071105489121/
choucroute 28 déc 2012 à 23h51 
I fixed this error on Debian Wheezy (amd64) with export LD_PRELOAD=${HOME}/.local/share/Steam/ubuntu12_32/steamui.so before running steam

EDIT: fix is incorrect, the proper solution is to upgrade /usr/lib32/libgdk-x11-2.0.so so the symbol gdk_window_get_screen is present (this was due to my ia32-libs-gtk package being from squeeze, and thus too old)
Dernière modification de choucroute; 29 déc 2012 à 0h15
lushb0x 2 jan 2013 à 12h46 
Yeah but fedora is different , it lacks a lot of the libraries that Debian has. Plus it's not a noob distro like Ubuntu you have to compile the steam beta from source.
blackout24 2 jan 2013 à 13h00 
There is no source available for the Steam Client. Repackagin a deb file is far from "compiling it from source" it's more like extracting a zip file and repackaging it as a rar file so it can be registered in the local package manager...
lushb0x 3 jan 2013 à 12h17 
Have you looked around? I'm not talking about a deb file. That's like a bit rpm
lushb0x 3 jan 2013 à 12h23 
P.S the repos that are stated in this discussion are out dated and don't work anymore.
Affichage des commentaires 1 à 11 sur 11
< >
Par page : 15 30 50