HarlemSquirrel Dec 9, 2012 @ 9:50am
Logitech Rumblepad F510 Gamepad
I have two F510 gamepads my wife and I have been using to play Trine 2 in Windows. I finally got them to work in X-mode under Linux Mint 14 64-bit. I understand that D-mode is supposed to be better.

The gamepad works for BIG PICTURE mode but has to be configured. I submitted my profile to Steam under "Logitech F510 X-mode"

Does anyone else have experience with this? What is the difference between x-mode and d-mode? Is d-mode "Direct Input" part of Microsoft's Direct X?
Showing 1-3 of 3 comments
< >
Sukarn Maini Dec 9, 2012 @ 11:56am 
I have the same gamepad but I've had no success making it work. Then again, I probably haven't tried hard enough.
X-Mode sends the input in Xbox-360 compatible mode, while D-Mode sends the input in the direct-input mode which predates xbox-360. I'm sorry, but I cannot provide any details beyond this.
seb Dec 9, 2012 @ 2:10pm 
yep. x-mode is the XBOX Mode. Under windows this means there is a wonderful integration with games. E.g. my Need for Speed Hot Pursuit on Windows displays a green A button, when I need to press it...
In d-mode it is just another gamepad...

I just tried my Logitech F710 with Steam's Big Picture Mode on Ubuntu 12.04 64-bit:
* the gamepad works in general out of the box in x-mode (which I think is awesome)
* however the integration with steam lacks the level of integration I am used from Windows:
** it tells me to "press A to select", but reacts to B
** same with "press B", but reacts to Y

System Information:

Processor Information:
Vendor: GenuineIntel
Speed: 2793 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.1 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-29-generic
X Server vendor: The X.Org Foundation
X Server release: 11103000

Video Card:
Driver: NVIDIA Corporation GeForce GTX 275/PCIe/SSE2

Driver Version: 3.3.0 NVIDIA 310.14
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0x5e6
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1600 x 1200
Desktop Resolution: 1600 x 1200
Primary Display Size: 16.06" x 12.05" (20.08" diag)
40.8cm x 30.6cm (51.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 896 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device:

Memory:
RAM: 5968 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 300115 Mb
Largest Free Hard Disk Block: 275211 Mb

Installed software:

Recent Failure Reports:
Sun Dec 9 21:27:28 2012 GMT: file ''/tmp/dumps/assert_20121209222716_1.dmp'', upload yes: ''CrashID=bp-ad529fa8-defc-4afb-908c-fc7ef2121209''
Sun Dec 9 21:44:27 2012 GMT: file ''/tmp/dumps/assert_20121209224420_1.dmp'', upload yes: ''CrashID=bp-de9b4417-5e6b-4e84-a48e-788282121209''
Sun Dec 9 21:56:38 2012 GMT: file ''/tmp/dumps/assert_20121209225622_2.dmp'', upload yes: ''CrashID=bp-25ec7827-5d84-4bff-8b65-83af32121209''

Last edited by seb; Dec 9, 2012 @ 2:13pm
jazztickets Mar 27, 2013 @ 8:04pm 
X is actually referring to XInput API:
http://logitech-en-amr.custhelp.com/app/answers/detail/a_id/20400/related/1

D mode doesn't even work for me in linux.

The problem i have most of the time is with the trigger buttons. They're treated as axises but the default value is negative instead of 0. You need to use jscal to play games like Shank.
Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Dec 9, 2012 @ 9:50am
Posts: 3