M Parker Dec 8, 2012 @ 9:07am
Issue Report: ground textures missing or transparent in Dustbowl during Soldier training.
When playing training on Dustbowl, I can see through the ground!

Product

  • Team Fortress 2 Beta

Map

  • Dustbowl

Environment

  • Ubuntu 12.10 "quantal" amd64
  • Unity desktop environment
  • ASUS Radeon HD 6850 graphics card
  • AMD Catalyst Proprietary Display Driver 12.11 Beta, released 12/3/2012

Detailed hardware information and driver versions at gist.github.com/4240985

Setup

1. Download and install Steam.
2. Download Team Fortress 2 Beta.
3. Ensure you have a fresh TF2 profile (i.e.: never played before).
4. Right-click TF2 in Library, click "Properties". In the General tab, click "Set launch options". Enter
-nojoy
.
Steps to reproduce

Step no. What to do
> Expected result.
! Actual result.

1. Right-click TF2.
> TF2 starts.
> Main game menu appears.
> A tip suggesting that you do the training for each class appears.
2. Click the training button.
> A window asking you to choose a class to train with appears. The only available option is the Soldier.
3. Click "Soldier" and complete the first part of the soldier training. When prompted to continue or return to main menu, click return to main menu.
> Watch a video.
> Shoot some wooden targets.
> Shoot some moving targets.
4. Quit the game and start it again.
> TF2 starts.
> Main menu appears.
5. Click the training button.
> A window asking you to choose a class to train with appears. The only available option is the Soldier (50% complete).
6. Click "Soldier".
> You are prompted to continue or restart training.
7. Choose to continue training.
> Dustbowl loads.
> Watch a video.
> Control character in map.
! Note that some ground textures are missing!

Notes

It seems that the primary Dustbowl ground texture is either missing or transparent. Other textures, including (vehicle?) tracks, buildings and their interiors, NPCs, doodads, etc. are all working fine AFAIK (I've never played TF2 before).
Last edited by M Parker; Dec 8, 2012 @ 11:16am
Showing 1-3 of 3 comments
< >
M Parker Dec 8, 2012 @ 11:20am 
Forgot to include my system information as reported by Steam...

Processor Information:
Vendor: AuthenticAMD
Speed: 2800 Mhz
6 logical processors
6 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-19-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. AMD Radeon HD 6800 Series

Driver Version: 4.2.11995 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x1002
DeviceID: 0x6739
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 2048 x 1152
Desktop Resolution: 2048 x 1152
Primary Display Size: 20.08" x 11.30" (23.03" diag)
51.0cm x 28.7cm (58.5cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Realtek ALC892

Memory:
RAM: 7948 Mb

Miscellaneous:
UI Language: English
LANG: en_CA.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 181713 Mb
Largest Free Hard Disk Block: 102735 Mb

Installed software:

Recent Failure Reports:
Sat Dec 8 14:14:39 2012 GMT: file ''/tmp/dumps/assert_20121208091423_1.dmp'', upload yes: ''CrashID=bp-3ecfc6f9-b56e-41cc-ad9f-083502121208''
Sat Dec 8 14:14:55 2012 GMT: file ''/tmp/dumps/assert_20121208091439_2.dmp'', upload yes: ''CrashID=bp-82c8a656-556d-44f3-ae54-c69d72121208''
Sat Dec 8 14:16:47 2012 GMT: file ''/tmp/dumps/assert_20121208091629_3.dmp'', upload yes: ''CrashID=bp-6dd243bb-45ce-418f-8f5f-584392121208''
Sat Dec 8 14:35:20 2012 GMT: file ''/tmp/dumps/crash_20121208093515_1.dmp'', upload yes: ''CrashID=bp-2951480b-6a4f-4916-bcbd-f898c2121208''
Sat Dec 8 14:36:56 2012 GMT: file ''/tmp/dumps/crash_20121208093652_1.dmp'', upload yes: ''CrashID=bp-5d294b25-ffc2-4097-a94d-b12632121208''
dave Dec 16, 2012 @ 2:06am 
I am also seeing this problem in-game, exactly as described.
My system information:

Processor Information:
Vendor: GenuineIntel
Speed: 1600 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-21-generic
X Server vendor: The X.Org Foundation
X Server release: 11300000

Video Card:
Driver: ATI Technologies Inc. ATI Mobility Radeon HD 5800 Series

Driver Version: 4.2.11995 Compatibility Profile Context
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x68a1
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 15.00" x 8.43" (17.17" diag)
38.1cm x 21.4cm (43.6cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: IDT 92HD81B1X5

Memory:
RAM: 7920 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 192246 Mb
Largest Free Hard Disk Block: 166320 Mb

Installed software:

Recent Failure Reports:

m93a.cz Jun 25, 2013 @ 11:05am 
Also having this problem. It seems that the textures are not missing but incorrectly placed.
-------------------------------------------
System information:


Processor Information:
Vendor: GenuineIntel
Speed: 1999 Mhz
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.04.2 LTS (32 bit)
Kernel Name: Linux
Kernel Version: 3.2.0-48-generic-pae
X Server Vendor: The X.Org Foundation
X Server Release: 11103000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release-i386_2013-05-08

Video Card:
Driver: ATI Technologies Inc. ATI Mobility Radeon HD 5000 Series

Driver Version: 4.2.12172 Compatibility Profile Context 9.00.11
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x1002
DeviceID: 0x68e0
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1600 x 900
Desktop Resolution: 1600 x 900
Primary Display Size: 15,04" x 8,43" (17,20" diag)
38,2cm x 21,4cm (43,7cm diag)
Primary VRAM Not Detected

Sound card:
Audio device: Conexant CX20585

Memory:
RAM: 3881 Mb

Miscellaneous:
UI Language: English
LANG: cs_CZ.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 93867 Mb
Largest Free Hard Disk Block: 24663 Mb

Installed software:

Recent Failure Reports:

Showing 1-3 of 3 comments
< >
Per page: 15 30 50
Date Posted: Dec 8, 2012 @ 9:07am
Posts: 3